libctl5_3.2.2-2_amd64.deb


Advertisement

Description

libctl5 - library for flexible control files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libctl5
Package version 3.2.2
Package release 2
Package architecture amd64
Package type deb
Installed size 346 B
Download size 97.40 KB
Official Mirror ftp.br.debian.org
libctl is a free Guile-based library implementing flexible control files for
scientific simulations. It was written to support the MIT Photonic-Bands
program, but will hopefully prove useful in other programs too.
This package contains the runtime libraries required to run any software using
libctl.

Alternatives

Package Version Architecture Repository
libctl5_3.2.2-2_i386.deb 3.2.2 i386 Debian Main
libctl5 - - -

Requires

Name Value
guile-2.0-libs -
libc6 >= 2.14
libgc1c2 >= 1:7.2d
multiarch-support -

Conflicts

Name Value
libctl3 -

Download

Type URL
Binary Package libctl5_3.2.2-2_amd64.deb
Source Package libctl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libctl5 deb package:
    # sudo apt-get install libctl5

Files

Path
/usr/lib/x86_64-linux-gnu/libctl.so.5
/usr/lib/x86_64-linux-gnu/libctl.so.5.0.2
/usr/share/doc/libctl5/AUTHORS
/usr/share/doc/libctl5/NEWS.gz
/usr/share/doc/libctl5/changelog.Debian.gz
/usr/share/doc/libctl5/changelog.gz
/usr/share/doc/libctl5/copyright
/usr/share/libctl/base/class.scm
/usr/share/libctl/base/ctl.scm
/usr/share/libctl/base/extern-funcs.scm
/usr/share/libctl/base/help.scm
/usr/share/libctl/base/include.scm
/usr/share/libctl/base/interaction.scm
/usr/share/libctl/base/io-vars.scm
/usr/share/libctl/base/main.c
/usr/share/libctl/base/math-utils.scm
/usr/share/libctl/base/matrix3x3.scm
/usr/share/libctl/base/simplex.scm
/usr/share/libctl/base/utils.scm
/usr/share/libctl/base/vector3.scm
/usr/share/libctl/utils/ctl-io.scm
/usr/share/libctl/utils/geom.c
/usr/share/libctl/utils/geom.scm
/usr/share/libctl/utils/nlopt-constants.scm
/usr/share/libctl/utils/nlopt.c

Changelog

2014-05-02 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.2.2-2) unstable; urgency=medium
* debian/control: libctl-dev needs to debpend on guile 2.0 as well
2014-05-02 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.2.2-1) unstable; urgency=medium
* upload to unstable (Closes: #722791)
* new upstream release (Closes: #743467)
* debian/control: bump standard to 3.9.5 (no change)
* debian/control: really use guile 2.0 now (Closes: #738318, #746004)
* debian/rules: use --with autoreconf (Closes: #744604)
2013-12-29 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.2.1-3) UNRELEASED; urgency=medium
* upload to unstable
* debian/control: bump standard to 3.9.5 (no change)
* use autotools-dev (debian/control, debian/rules)
2012-11-23 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.2.1-2) experimental; urgency=low
* debian/control: remove DM-Upload-Allowed
* debian/control: use guile 1.8 now
libctl is needed by mpb, the rc1 of 1.5 does not
really work with guile 2.0
2012-08-10 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.2.1-1) experimental; urgency=low
* new upstream release
* debian/control: add conflict to libctl3 (Closes: #684030)
2012-07-24 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.2-1) experimental; urgency=low
* Imported Upstream version 3.2, new upstream release (Closes: #682254)
* debian/rules: get-orig-source added
* debian/control: using dh 9
* debian/control: bump standard to 3.9.3 (no change)
* debian/copyright: correct version
* debian/control: use guile 2.0 now
* debian/*.install: use multiarch path
2011-12-13 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.1.0-5) unstable; urgency=low
* debian/rules: use cp instead of install
2011-12-12 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.1.0-4) unstable; urgency=low
* debian/control: moved to dh 8
* debian/control: remove dependency on dpatch
* debian/control: remove dependency on cdbs
* debian/control: standards version 3.9.2, no changes
* debian/source: switch to format 3.0 (quilt)
* debian/README.source: moved to quilt
* debian/copyright: changed to DEP5 format
* debian/patches: moved from dpatch to quilt
2011-04-09 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.1.0-3) unstable; urgency=low
* *.la files removed (Closes: #621516)
* Standards-Version changed to 3.9.1 (no changes needed)
2009-12-09 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.1.0-2) unstable; urgency=low
* Standards-Version changed to 3.8.3 (no changes needed)
* patch in configure for sh4 added (Closes: #555525)
* debian/README.source added
* debian/control: DM-Upload-Allowed added

See Also

Package Description
libctpl-dev_0.3.3.dfsg-4_amd64.deb template engine written in C, development files
libctpl-doc_0.3.3.dfsg-4_all.deb template engine written in C, documentation files
libctpl2_0.3.3.dfsg-4_amd64.deb template engine written in C
libctpp2-2_2.8.3-15_amd64.deb HTML template engine for C++
libctpp2-dev_2.8.3-15_amd64.deb HTML template engine for C++ (development)
libctypes-ocaml-dev_0.2.3-1_amd64.deb library for binding to C libraries using pure OCaml (dev)
libctypes-ocaml_0.2.3-1_amd64.deb library for binding to C libraries using pure OCaml (runtime)
libcuba-doc_3.0+20111124-2_all.deb library for multidimensional numerical integration: documentation
libcuba3-dev_3.0+20111124-2_amd64.deb library for multidimensional numerical integration: development files
libcuba3_3.0+20111124-2_amd64.deb library for multidimensional numerical integration
libcudf-dev_0.7-2+b1_amd64.deb C library to access descriptions of package upgrade problems
libcudf-ocaml-dev_0.7-2+b1_amd64.deb OCaml library to access descriptions of package upgrade problems
libcue-dev_1.4.0-1_amd64.deb CUE Sheet Parser Library - development files
libcue1_1.4.0-1_amd64.deb CUE Sheet Parser Library
libcunit1-dev_2.1-2.dfsg-2_amd64.deb Unit Testing Library for C -- development files
Advertisement
Advertisement