libcsfml-graphics2_2.1-2_amd64.deb


Advertisement

Description

libcsfml-graphics2 - Libraries for the C Binding of SFML - Graphics Part

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcsfml-graphics2
Package version: 2.1
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 189 B
Download size: 39.24 KB
Official Mirror: ftp.br.debian.org
SFML is a modern multimedia library offering a wide range of subsystems useful to produce a multimedia app. It offers OpenGL integration for Hardware accelerated Graphics, Windowing and Input support, Audio and Network facilities and supports GNU/Linux, MS Windows and Mac OS X. CSFML provides the bindings needed to use SFML with the C programming language. The Graphics library contains all the OpenGL and drawing code. It needs the Window library for Window creation.

Alternatives

    Download

    Source package: libcsfml

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcsfml-graphics2 deb package:
      # sudo apt-get install libcsfml-graphics2

    Files

    • /usr/lib/x86_64-linux-gnu/libcsfml-graphics.so.2
    • /usr/lib/x86_64-linux-gnu/libcsfml-graphics.so.2.1
    • /usr/share/doc/libcsfml-graphics2/changelog.Debian.gz
    • /usr/share/doc/libcsfml-graphics2/copyright

    Changelog

    2013-12-16 - James Cowgill <james410@cowgill.org.uk> libcsfml (2.1-2) unstable; urgency=low * Fix Vcs-Browser field in debian/control

    2013-11-15 - James Cowgill <james410@cowgill.org.uk> libcsfml (2.1-1) unstable; urgency=low * New upstream release 2.1 * Added myself to the list of uploaders * Change package priority from extra to optional * Add dependency to libgl-dev and libglu-dev to libcsfml-dev * Modify debian/copyright to use the machine-readable format (http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/) * Added doc-base file for API documentation * Moved debian/watch source to the CSFML github repository * Upgrade source format to 3.0 and debhelper 9 using dh * Upgrade to standards version 3.9.5 * Updated package description to fix typos (Closes: #704462) * Added multiarch support * Added symbols files for the libraries * Removed old conflicts on libcsfml1.deb3-dev * Added lintian override hardening-no-fortify-functions for libcsfml-network2

    2010-05-09 - Christoph Egger <christoph@debian.org> libcsfml (1.6-1) unstable; urgency=low * New upstream 1.6 release * Bump standards version (no changes) * Rename library packages due to soname change * Add a -doc package

    2009-12-26 - Christoph Egger <christoph@debian.org> libcsfml (1.5-3) unstable; urgency=low * Check for CSFML_SYSTEM_FREEBSD alternatively to _LINUX if X11 is needed

    2009-12-18 - Christoph Egger <christoph@debian.org> libcsfml (1.5-2) unstable; urgency=low * Change dh_chlean -k to dh_prep and therefor bump debhelper to 7 * Get rid of strange Make error on systems where topgit is not installed (e.g. buildds, chroots) * Line Break Depends/Build-Depends * Update my Email Address * Fix Build on kFreeBSD and GNU/Hurd

    2009-09-30 - Christoph Egger <debian@christoph-egger.org> libcsfml (1.5-1) unstable; urgency=low * New upstream 1.5 release * Builds against newer libsfml (Closes: #542982) * SONAME bump for libraries * Drop debian/gcc4.3.diff (implemented upstream) * Refresh debian/correct-destdir * Improve descriptions * Clean up rules file -- some quirks no longer needed because of improvements in upstream buildsystem * Bump standards version to 3.8.3 (no changes) * remove duplicate priority entries in control * Add README.source

    2009-03-29 - Christoph Egger <debian@christoph-egger.org> libcsfml (1.4-2) unstable; urgency=low * should really go to unstable

    2009-01-20 - Christoph Egger <debian@christoph-egger.org> libcsfml (1.4-1) experimental; urgency=low [ Christoph Egger ] * New Upstream Version * Drop patches now upstream * RM: add_destdir_to_makefile.patch * RM: fix_soname.patch * Convert patch system to topgit * Fix problem in upstream's destdir implementation * Change my Mailaddress * Wrap -dev package's depends [ Gonéri Le Bouder ] * libcsfml-dev conflicts on/replaces libcsfml1.deb3-dev

    2008-09-09 - Christoph Egger <Christoph.Egger@gmx.de> libcsfml (1.3-2) unstable; urgency=low * Dropping depends on old libsfml packages that should not be there the depends automatically pulled in should be enough here

    2008-06-25 - Christoph Egger <Christoph.Egger@gmx.de> libcsfml (1.3-1) unstable; urgency=low * Initial release (Closes: #481665)

    Advertisement
    Advertisement