libcryptui0a_3.12.2-1+b1_amd64.deb


Advertisement

Description

libcryptui0a - UI library for OpenPGP prompts

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcryptui0a
Package version: 3.12.2
Package release: 1+b1
Package architecture: amd64
Package type: deb
Installed size: 89 B
Download size: 37.35 KB
Official Mirror: ftp.br.debian.org
CryptUI is a library to manage OpenPGP prompts on GUI applications. This package contains the shared library needed to run programs built against the CryptUI library.

Alternatives

Conflicts

  • libcryptui0

    Download

    Source package: libcryptui

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcryptui0a deb package:
      # sudo apt-get install libcryptui0a

    Files

    • /usr/lib/x86_64-linux-gnu/libcryptui.so.0
    • /usr/lib/x86_64-linux-gnu/libcryptui.so.0.0.0
    • /usr/share/doc/libcryptui0a/AUTHORS
    • /usr/share/doc/libcryptui0a/NEWS.gz
    • /usr/share/doc/libcryptui0a/README
    • /usr/share/doc/libcryptui0a/changelog.Debian.amd64.gz
    • /usr/share/doc/libcryptui0a/changelog.Debian.gz
    • /usr/share/doc/libcryptui0a/changelog.gz
    • /usr/share/doc/libcryptui0a/copyright

    Changelog

    2014-07-12 - Andreas Henriksson <andreas@fatal.se> libcryptui (3.12.2-1) unstable; urgency=medium * Team upload. [ Jackson Doak ] * New upstream release [ Andreas Henriksson ] * Bump debhelper build-dependency to >= 9 to match debian/compat * Bump Standards-Version to 3.9.5

    2013-06-11 - Emilio Pozuelo Monfort <pochu@debian.org> libcryptui (3.8.0-1) unstable; urgency=low [ Michael Biebl ] * Change section of gir1.2-cryptui-0.0 to introspection. [ Josselin Mouette ] * Remove MA: same statements for the -dev package, because it depends on the gir package which is not MA compatible. [ Emilio Pozuelo Monfort ] * New upstream release. * debian/control.in: + Update (build-)dependencies. + Remove Build-Conflicts on gnupg2. libgpgme11 depends on it and gets pulled because of libgpgme11-dev. The build conflict comes from seahorse's packaging and shouldn't be needed here. * debian/patches/99_ltmain_as-needed.patch: + Removed. Instead... * debian/rules: + Pass --as-needed to dh_autoreconf so it does the --as-needed magic. The patch was useless before as we were calling autoreconf after applying the patch.

    2011-11-23 - Jordi Mallach <jordi@debian.org> libcryptui (3.2.2-1) unstable; urgency=low * Initial release, based on Seahorse's packaging. * This library is split from the seahorse source, so the soname bump is kept. * Introduce a new seahorse-daemon package. Make it Break seahorse < 3.2. * Let libcryptui0a depend on seahorse-daemon, as the D-Bus service is required. * Add Breaks for older seahorse and seahorse-plugins, as there was a small unannounced API break. * Refresh patches. * Add a libcryptui-doc. Add necessary Replaces/Breaks. * Add Multi-Arch support: - Bump debhelper & cdbs. - Add Pre-Depends. - Fix install dirs in *.install. - Use the M-A dir as $libdir. - Mark libcryptui0a Multi-Arch: same. - Mark seahorse-daemon Multi-Arch: foreign. - Mark libcryptui-doc Multi-Arch: foreign. * Add debian/patches/02_seahorse-daemon_libcryptui_static_link.patch, by Michael Biebl: create a noinst libcryptui-private.la, and link seahorse-daemon against it to avoid a dependency loop between seahorse-daemon and libcryptui which requires the D-Bus service. * Don't pass obsolete --with-pgp. * Pass --enable-gtk-doc, and Build-Depend on libgtk-3-doc to ensure correct cross-references. * Move locales to seahorse-daemon. * Add -Wl,-z,defs to LDFLAGS. * Update copyright.

    Advertisement
    Advertisement