libcrypt-eksblowfish-perl_0.009-1+b2_amd64.deb


Advertisement

Description

libcrypt-eksblowfish-perl - Perl module implementing the Eksblowfish block cipher

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libcrypt-eksblowfish-perl
Package version 0.009
Package release 1+b2
Package architecture amd64
Package type deb
Installed size 82 B
Download size 46.81 KB
Official Mirror ftp.br.debian.org
Crypt::Eksblowfish provides an implementation of the Eksblowfish encryption.
Eksblowfish is a variant of the Blowfish cipher, modified to make the
key setup very expensive.  ("Eks" stands for "expensive key schedule".)
This doesn't make it significantly cryptographically stronger,
but is intended to hinder brute-force attacks.  It also makes it
unsuitable for any application requiring key agility.  It was designed
by Niels Provos and David Mazieres for password hashing in OpenBSD.
See Crypt::Eksblowfish::Bcrypt for the hash algorithm.
Eksblowfish is a parameterised (family-keyed) cipher.  It takes a cost
parameter that controls how expensive the key scheduling is.  It also
takes a family key, known as the "salt".  Cost and salt parameters
together define a cipher family.  Within each family, a key determines an
encryption function in the usual way.  See Crypt::Eksblowfish::Family
for a way to encapsulate an Eksblowfish cipher family.

Alternatives

Package Version Architecture Repository
libcrypt-eksblowfish-perl_0.009-1+b2_i386.deb 0.009 i386 Debian Main
libcrypt-eksblowfish-perl - - -

Requires

Name Value
libc6 >= 2.4
libclass-mix-perl -
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libcrypt-eksblowfish-perl_0.009-1+b2_amd64.deb
Source Package libcrypt-eksblowfish-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcrypt-eksblowfish-perl deb package:
    # sudo apt-get install libcrypt-eksblowfish-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Crypt/Eksblowfish.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Crypt/Eksblowfish/Bcrypt.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Crypt/Eksblowfish/Blowfish.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Crypt/Eksblowfish/Family.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Crypt/Eksblowfish/Subkeyed.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Crypt/Eksblowfish/Uklblowfish.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Crypt/Eksblowfish/Eksblowfish.bs
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Crypt/Eksblowfish/Eksblowfish.so
/usr/share/doc/libcrypt-eksblowfish-perl/changelog.Debian.amd64.gz
/usr/share/doc/libcrypt-eksblowfish-perl/changelog.Debian.gz
/usr/share/doc/libcrypt-eksblowfish-perl/changelog.gz
/usr/share/doc/libcrypt-eksblowfish-perl/copyright
/usr/share/man/man3/Crypt::Eksblowfish.3pm.gz
/usr/share/man/man3/Crypt::Eksblowfish::Bcrypt.3pm.gz
/usr/share/man/man3/Crypt::Eksblowfish::Blowfish.3pm.gz
/usr/share/man/man3/Crypt::Eksblowfish::Family.3pm.gz
/usr/share/man/man3/Crypt::Eksblowfish::Subkeyed.3pm.gz
/usr/share/man/man3/Crypt::Eksblowfish::Uklblowfish.3pm.gz

Changelog

2012-12-23 - Xavier Guimard <x.guimard@free.fr>
libcrypt-eksblowfish-perl (0.009-1) unstable; urgency=low
* Take over for the Debian Perl Group on maintainer's request
(http://bugs.debian.org/677732#10)
* Imported Upstream version 0.009
* Update source format to 3.0 (quilt)
* Bump Standards-Version to 3.9.4
* Bump debhelper compatibility to 9
* Update debian/copyright (years and format)
* Update debian/rules to use "dh $@"
* Add libtest-pod-perl and libtest-pod-coverage-perl in dependencies
* Remove libxsloader dependency
2010-03-24 - Ivan Kohler <ivan-debian@420.am>
libcrypt-eksblowfish-perl (0.008-1) unstable; urgency=low
* New upstream release
* Fix watch file for uscan
* debhelper compat 5
2008-05-07 - Ivan Kohler <ivan-debian@420.am>
libcrypt-eksblowfish-perl (0.005-1) unstable; urgency=low
* New upstream release.
2008-04-01 - Ivan Kohler <ivan-debian@420.am>
libcrypt-eksblowfish-perl (0.003-6) unstable; urgency=low
* Remove perl 5.10 from Dep: as well as Build-Dep:, doh!
2008-03-24 - Ivan Kohler <ivan-debian@420.am>
libcrypt-eksblowfish-perl (0.003-5) unstable; urgency=low
* Okay.  perl 5.10-5 Provides: libxsloader-perl now (and 5.10 never did hit
unstable in the week it was claimed to), so we should be able to just
depend on that going forward, with no FTBFS issues under 5.8.
Closes: Bug#470436
2008-02-26 - Ivan Kohler <ivan-debian@420.am>
libcrypt-eksblowfish-perl (0.003-4) unstable; urgency=low
* Depend on perl 5.10 OR libxsloader-perl
2008-02-12 - Ivan Kohler <ivan-debian@420.am>
libcrypt-eksblowfish-perl (0.003-3) unstable; urgency=low
* Update rules file based on current dh-make-perl template for
Module-Build.xs (closes: Bug#464908).  Yow.
2008-02-03 - Ivan Kohler <ivan-debian@420.am>
libcrypt-eksblowfish-perl (0.003-2) unstable; urgency=low
* Add Build-Dep on libmodule-build-perl used by new upstream version
(closes: Bug#463879)
2008-02-02 - Ivan Kohler <ivan-debian@420.am>
libcrypt-eksblowfish-perl (0.003-1) unstable; urgency=low
* New upstream release
* Fix debian/rules for perl 5.10 FTBFS, patch from Damyan Ivanov
(closes: Bug#463534)
2007-02-20 - Ivan Kohler <ivan-debian@420.am>
libcrypt-eksblowfish-perl (0.001-1) unstable; urgency=low
* Initial Release (closes: Bug#411717).

See Also

Package Description
libcrypt-gcrypt-perl_1.26-2_amd64.deb Perl interface to the GNU Cryptographic library
libcrypt-generatepassword-perl_0.04-1_all.deb perl module to generate secure passwords
libcrypt-gpg-perl_1.52-1_all.deb An Object Oriented Interface to GnuPG
libcrypt-hcesha-perl_0.70-3_all.deb Perl extension for one way hash chaining encryption using SHA
libcrypt-mysql-perl_0.04-5+b2_amd64.deb Perl module to emulate the MySQL PASSWORD() function
libcrypt-openssl-bignum-perl_0.04-4+b2_amd64.deb Perl module to access OpenSSL multiprecision integer arithmetic libraries
libcrypt-openssl-dsa-perl_0.14-1+b1_amd64.deb module which implements the DSA signature verification system
libcrypt-openssl-random-perl_0.04-2+b1_amd64.deb module to access the OpenSSL pseudo-random number generator
libcrypt-openssl-rsa-perl_0.28-2+b1_amd64.deb module for RSA encryption using OpenSSL
libcrypt-openssl-x509-perl_1.8.4-1+b1_amd64.deb Perl extension to OpenSSL's X509 API
libcrypt-passwdmd5-perl_1.3-10_all.deb interoperable MD5-based crypt() for perl
libcrypt-pbkdf2-perl_0.142390-1_all.deb Perl implementation of PBKDF2 password hash
libcrypt-random-seed-perl_0.03-1_all.deb Perl module providing strong randomness for seeding
libcrypt-random-source-perl_0.08-1_all.deb get weak or strong random data from pluggable sources
libcrypt-rc4-perl_2.02-2_all.deb Perl implementation of the RC4 encryption algorithm
Advertisement
Advertisement