libcrypt-des-perl_2.07-1+b2_amd64.deb


Advertisement

Description

libcrypt-des-perl - Perl DES encryption module

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcrypt-des-perl
Package version: 2.07
Package release: 1+b2
Package architecture: amd64
Package type: deb
Installed size: 110 B
Download size: 20.28 KB
Official Mirror: ftp.br.debian.org
This is Crypt::DES, an XS-based implementation of the DES cryptography algorithm. The module implements the Crypt::CBC interface, which has blocksize, keysize, encrypt and decrypt functions.

Alternatives

    Download

    Source package: libcrypt-des-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcrypt-des-perl deb package:
      # sudo apt-get install libcrypt-des-perl

    Files

    • /usr/lib/x86_64-linux-gnu/perl5/5.20/Crypt/DES.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Crypt/DES/DES.so
    • /usr/share/doc/libcrypt-des-perl/README
    • /usr/share/doc/libcrypt-des-perl/changelog.Debian.amd64.gz
    • /usr/share/doc/libcrypt-des-perl/changelog.Debian.gz
    • /usr/share/doc/libcrypt-des-perl/copyright
    • /usr/share/doc/libcrypt-des-perl/examples/test.pl.gz
    • /usr/share/man/man3/Crypt::DES.3pm.gz

    Changelog

    2013-08-09 - Salvatore Bonaccorso <carnil@debian.org> libcrypt-des-perl (2.07-1) unstable; urgency=low * Team upload. * Imported Upstream version 2.07 * Drop svupgrade.patch patch

    2013-05-17 - gregor herrmann <gregoa@debian.org> libcrypt-des-perl (2.05-3) unstable; urgency=low [ gregor herrmann ] * debian/control: Added: ${misc:Depends} to Depends: field. [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ gregor herrmann ] * Email change: gregor herrmann -> gregoa@debian.org [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Switch to "3.0 (quilt)" source format. * Use tiny debian/rules with dh(1), debhelper 9.20120312 and compat 9. * debian/copyright: switch formatting to Copyright-Format 1.0. Update years of packaging copyright. * Add svupgrade.patch, taken from CPAN RT. (Closes: #708468) * Set Standards-Version to 3.9.4 (no changes).

    2007-11-26 - Damyan Ivanov <dmn@debian.org> libcrypt-des-perl (2.05-2) unstable; urgency=low [ gregor herrmann ] * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza). Removed: XS- Vcs-Svn fields. * debian/watched is fixed since quite some time in svn (closes: #449801). * Set Standards-Version to 3.7.2 (no changes needed). [ Frank Lichtenheld ] * debian/rules: build-stamp should depend on configure-stamp, not build. Fixes build with dpkg-buildpackage -j. Found by Daniel Schepler. * debian/control: Remove superfluous quotes in Maintainer field [ Damyan Ivanov ] * Use debhelper compatibility level 5 + add debian/compat + remove DH_COMPAT export from debian/rules + adjust build-depends accordingly * debian/rules: cleanup + stop ignoring realclean errors + remove unused debhelper calls + move README from debian/docs to dh_installdocs + use proper DESTDIR and PREFIX when installing * use search.cpan.org/dist/Crypt-DES/ as download location in debian/copyright * add myself to Uploaders

    2005-12-24 - Krzysztof Krzyzaniak (eloy) <eloy@debian.org> libcrypt-des-perl (2.05-1) unstable; urgency=low * New upstream release (closes: #344647) * Added me to Uploaders * Standards-Version updated to 3.6.2 with change DH_COMPAT=4

    2005-06-15 - Jaldhar H. Vyas <jaldhar@debian.org> libcrypt-des-perl (2.03-4) unstable; urgency=low * Package now maintained by the Debian Perl group. (Closes: #313465)

    2004-06-18 - Shell Hung <shell@debian.org> libcrypt-des-perl (2.03-3) unstable; urgency=low * moved out from non-us section

    2002-10-09 - Shell Hung <shell@debian.org> libcrypt-des-perl (2.03-2) unstable; urgency=low * Close bug report. (Closes: #158945) * Add libcrypt-cbc-perl to build-depend

    2002-08-31 - Colin Watson <cjwatson@debian.org> libcrypt-des-perl (2.03-1.1) unstable; urgency=low * NMU for perl 5.8. * Build-depend on perl (>= 5.8.0-7), in order to use perlapi-5.8.0. * Set PREFIX at 'make install' time, not while processing Makefile.PL, otherwise VENDORPREFIX gets set wrongly and the build process ends up trying to write to /usr on the build machine. * 'make realclean' rather than 'clean'.

    2001-11-03 - Shell Hung <shell@debian.org> libcrypt-des-perl (2.03-1) unstable; urgency=low * Initial Release. (Closes: #118133)

    Advertisement
    Advertisement