libcrypt-blowfish-perl_2.14-1+b2_amd64.deb


Advertisement

Description

libcrypt-blowfish-perl - Blowfish cryptography for Perl

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcrypt-blowfish-perl
Package version: 2.14
Package release: 1+b2
Package architecture: amd64
Package type: deb
Installed size: 34 B
Download size: 18.89 KB
Official Mirror: ftp.br.debian.org
This is Crypt::Blowfish, an XS-based implementation of the Blowfish cryptography algorithm designed by Bruce Schneier. It's designed to take full advantage of Crypt::CBC when desired. Blowfish keys may be up to 448 bits (56 bytes) long.

Alternatives

    Download

    Source package: libcrypt-blowfish-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcrypt-blowfish-perl deb package:
      # sudo apt-get install libcrypt-blowfish-perl

    Files

    • /usr/lib/x86_64-linux-gnu/perl5/5.20/Crypt/Blowfish.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Crypt/Blowfish/Blowfish.so
    • /usr/share/doc/libcrypt-blowfish-perl/changelog.Debian.amd64.gz
    • /usr/share/doc/libcrypt-blowfish-perl/changelog.Debian.gz
    • /usr/share/doc/libcrypt-blowfish-perl/changelog.gz
    • /usr/share/doc/libcrypt-blowfish-perl/copyright
    • /usr/share/man/man3/Crypt::Blowfish.3pm.gz

    Changelog

    2013-08-09 - Salvatore Bonaccorso <carnil@debian.org> libcrypt-blowfish-perl (2.14-1) unstable; urgency=low * Team upload. * Imported Upstream version 2.14 * Refresh blowfish_make_bfkey.patch patch for offset * Drop svupgrade.patch patch * Wrap and sort fields in debian/control

    2013-05-17 - gregor herrmann <gregoa@debian.org> libcrypt-blowfish-perl (2.12-2) unstable; urgency=low [ Ansgar Burchardt ] * Email change: Ansgar Burchardt -> ansgar@debian.org * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Add patch from CPAN RT to fix build failure with Perl 5.18. (Closes: #708467) * debian/copyright: switch formatting to Copyright-Format 1.0. Update license stanzas and years of packaging copyright. * Set Standards-Version to 3.9.4 (no changes). * Use debhelper 9.20120312 to get all hardening flags.

    2010-03-05 - gregor herrmann <gregoa@debian.org> libcrypt-blowfish-perl (2.12-1) unstable; urgency=low * New upstream release. * Refresh patch. * Add /me to Uploaders. * Update years of upstream copyright.

    2010-02-01 - Ansgar Burchardt <ansgar@43-1.org> libcrypt-blowfish-perl (2.10-2) unstable; urgency=low [ gregor herrmann ] * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza). * debian/control: Added: Homepage field (source stanza). * debian/control: Changed: Maintainer set to Debian Perl Group <pkg- perl-maintainers@lists.alioth.debian.org> (was: Jonathan McDowell <noodles@earth.li>); Jonathan McDowell <noodles@earth.li> moved to Uploaders. * debian/control: Added: ${misc:Depends} to Depends: field. * debian/watch: use dist-based URL. [ Ansgar Burchardt ] * Refresh rules for debhelper 7. * No longer install README. * Use source format 3.0 (quilt). * Convert debian/copyright to proposed machine-readable format. * debian/control: Make build-dep on perl unversioned. * debian/control: Add build-dep on libcrypt-cbc-perl for an additional test. * debian/control: Remove duplicate Section, Priority fields from binary package stanza. * Move changes to upstream source to a patch, drop changes to README. + New patch: blowfish_make_bfkey.patch * Bump Standards-Version to 3.8.4. * Add myself to Uploaders.

    2006-01-19 - Jonathan McDowell <noodles@earth.li> libcrypt-blowfish-perl (2.10-1) unstable; urgency=low * New upstream release. * Updated Standards-Version to 3.6.2.0 (no changes).

    2004-10-10 - Jonathan McDowell <noodles@earth.li> libcrypt-blowfish-perl (2.09-5) unstable; urgency=low * Add watch file. * Fix blowfish_make_bfkey comments. (closes: #269088) * Add versioned depends on debhelper >= 3. * Updated Standards-Version.

    2003-06-15 - Jonathan McDowell <noodles@earth.li> libcrypt-blowfish-perl (2.09-4) unstable; urgency=low * Change dependancy on Perl to versioned dependancy. (closes: #197474) * Change section to perl.

    2002-08-26 - Jonathan McDowell <noodles@earth.li> libcrypt-blowfish-perl (2.09-3) unstable; urgency=low * Rebuilt for Perl 5.8

    2002-04-24 - Jonathan McDowell <noodles@earth.li> libcrypt-blowfish-perl (2.09-2) unstable; urgency=low * Moved into main.

    2001-12-15 - Jonathan McDowell <noodles@earth.li> libcrypt-blowfish-perl (2.09-1) unstable; urgency=low * New upstream version. * Updated Standards-Version.

    Advertisement
    Advertisement