libcpan-meta-requirements-perl_2.128-1_all.deb


Advertisement

Description

libcpan-meta-requirements-perl - set of version requirements for a CPAN dist

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcpan-meta-requirements-perl
Package version: 2.128
Package release: 1
Package architecture: all
Package type: deb
Installed size: 81 B
Download size: 15.42 KB
Official Mirror: ftp.br.debian.org
A CPAN::Meta::Requirements object models a set of version constraints like those specified in the META.yml or META.json files in CPAN distributions. It can be built up by adding more and more constraints, and it will reduce them to the simplest representation. Logically impossible constraints will be identified immediately by thrown exceptions.

Replaces

  • libcpan-meta-perl << 2.120921-1

    Download

    Source package: libcpan-meta-requirements-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcpan-meta-requirements-perl deb package:
      # sudo apt-get install libcpan-meta-requirements-perl

    Files

    • /usr/share/doc/libcpan-meta-requirements-perl/CONTRIBUTING.mkdn
    • /usr/share/doc/libcpan-meta-requirements-perl/changelog.Debian.gz
    • /usr/share/doc/libcpan-meta-requirements-perl/changelog.gz
    • /usr/share/doc/libcpan-meta-requirements-perl/copyright
    • /usr/share/man/man3/CPAN::Meta::Requirements.3pm.gz
    • /usr/share/perl5/CPAN/Meta/Requirements.pm

    Changelog

    2014-09-07 - gregor herrmann <gregoa@debian.org> libcpan-meta-requirements-perl (2.128-1) unstable; urgency=medium [ Salvatore Bonaccorso ] * Update Vcs-Browser URL to cgit web frontend [ gregor herrmann ] * Add debian/upstream/metadata * Imported upstream version 2.128 * Add (build) dependency on version.pm 0.88. * Add autopkgtest control file.

    2014-07-31 - gregor herrmann <gregoa@debian.org> libcpan-meta-requirements-perl (2.126-1) unstable; urgency=medium * Install CONTRIBUTING file. * Strip trailing slash from metacpan URLs. * New upstream release. * Update years of packaging copyright. * Declare compliance with Debian Policy 3.9.5.

    2013-09-30 - gregor herrmann <gregoa@debian.org> libcpan-meta-requirements-perl (2.125-1) unstable; urgency=low * New upstream release. * Drop debian/libcpan-meta-requirements-perl.docs. The formerly installed file is gone.

    2013-09-17 - gregor herrmann <gregoa@debian.org> libcpan-meta-requirements-perl (2.123-1) unstable; urgency=low [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * New upstream release. * Update years of packaging copyright. * Declare compliance with Debian Policy 3.9.4.

    2012-05-05 - Salvatore Bonaccorso <carnil@debian.org> libcpan-meta-requirements-perl (2.122-1) unstable; urgency=low * Team upload. * Imported Upstream version 2.122

    2012-04-07 - gregor herrmann <gregoa@debian.org> libcpan-meta-requirements-perl (2.121-1) unstable; urgency=low * Initial release (closes: #667913).

    Advertisement
    Advertisement