libcpan-meta-check-perl_0.009-1_all.deb


Advertisement

Description

libcpan-meta-check-perl - verify requirements in a CPAN::Meta object

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcpan-meta-check-perl
Package version: 0.009
Package release: 1
Package architecture: all
Package type: deb
Installed size: 25 B
Download size: 10.70 KB
Official Mirror: ftp.br.debian.org
CPAN::Meta::Check verifies if requirements described in a CPAN::Meta object are present.

Alternatives

    Download

    Source package: libcpan-meta-check-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcpan-meta-check-perl deb package:
      # sudo apt-get install libcpan-meta-check-perl

    Files

    • /usr/share/doc/libcpan-meta-check-perl/README
    • /usr/share/doc/libcpan-meta-check-perl/buildinfo_all.gz
    • /usr/share/doc/libcpan-meta-check-perl/changelog.Debian.gz
    • /usr/share/doc/libcpan-meta-check-perl/changelog.gz
    • /usr/share/doc/libcpan-meta-check-perl/copyright
    • /usr/share/man/man3/CPAN::Meta::Check.3pm.gz
    • /usr/share/perl5/CPAN/Meta/Check.pm

    Changelog

    2014-07-03 - Jonas Smedegaard <dr@jones.dk> libcpan-meta-check-perl (0.009-1) unstable; urgency=medium [ upstream ] * New release. + Various POD fixes.

    2014-05-20 - Jonas Smedegaard <dr@jones.dk> libcpan-meta-check-perl (0.008-1) unstable; urgency=medium [ upstream ] * New release. + Switch to using merged_requirements. + Test Env instead of Carp for version overshoot. + Document $incdirs in the right function. [ Jonas Smedegaard ] * Bump to standards-version 3.9.5. * Fix use canonical Vcs-Git URL. * Update watch file to use metacpan.org URL. * Update copyright info: + Fix use comment and license pseudo-sections to obey silly restrictions of copyright format 1.0. + Extend coverage of packaging. * Update package relations: + Fix build-depend explicitly on perl. + Tighten (build-)dependency on libcpan-meta-perl, and add fallback on (very) recent perl. + (Favor recent perl and) tighten (build-)dependency on libcpan-meta-requirements-perl. + Fix slightly relax perl version favored over libmodule-metatadata-perl. + Fix stop build-depend explicitly on libtest-simple-perl: Version included with perl in recent enough even in oldstable.

    2013-08-09 - Jonas Smedegaard <dr@jones.dk> libcpan-meta-check-perl (0.007-1) unstable; urgency=low [ upstream ] * New release. + Swap conflicts test, as underscore versions broke it. [ Jonas Smedegaard ] * Improve watch file to use both www.cpan.org/authors URL (for newest info) and search.cpan.org/dist URL (for change of author). Switch get-orig-source target to use www.cpan.org/authors URL.

    2013-07-27 - Jonas Smedegaard <dr@jones.dk> libcpan-meta-check-perl (0.006-1) unstable; urgency=low [ upstream ] * New release. + Fixed bad dereference during conflicts checking.

    2013-04-24 - Jonas Smedegaard <dr@jones.dk> libcpan-meta-check-perl (0.005-1) unstable; urgency=low [ upstream ] * New release. + Converted from Test::Differences to Test::Deep. + Don't load CPAN::Meta from CPAN::Meta::Check. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) [ Jonas Smedegaard ] * Add README.source emphasizing control.in file as *not* a show-stopper for contributions, referring to wiki page for details. * Stop track md5sum of upstream tarball. * Stop track upstream development releases. * Bump standards-version to 3.9.4. * Update copyright/licensing info: + List upstream issue tracker as preferred upstream contact. + Fix use pseudo-license and pseudo-comment sections to obey silly restrictions of copyright format 1.0. + Add github URL as alternate source. + Bump packaging license to GPL-3+ + Extend copyright coverage for packaging to include current year. * Update package relations: + Build-depend on libtest-deep-perl (not libtest-differences-perl). + Relax to build-depend unversioned on cdbs: Needed version satisfied in stable, and oldstable no longer supported.

    2012-06-05 - Jonas Smedegaard <dr@jones.dk> libcpan-meta-check-perl (0.004-1) unstable; urgency=low * New upstream release. * Use anonscm.debian.org for Vcs-Browser field.

    2012-05-10 - Jonas Smedegaard <dr@jones.dk> libcpan-meta-check-perl (0.003-1) unstable; urgency=low * New upstream release. * Remove debian/source/local-options: abort-on-upstream-changes and unapply-patches are default in dpkg-source since 1.16.1. * Sync long description with upstream (now existing) description.

    2012-05-09 - Jonas Smedegaard <dr@jones.dk> libcpan-meta-check-perl (0.002-2) unstable; urgency=low * Fix build-depend on recent perl favored over recent libtest-simple-perl.

    2012-05-09 - Jonas Smedegaard <dr@jones.dk> libcpan-meta-check-perl (0.002-1) unstable; urgency=low * Initial packaging release. Closes: bug#672161.

    Advertisement
    Advertisement