libcourriel-perl_0.36-1_all.deb


Advertisement

Description

libcourriel-perl - high level email parsing and manipulation module

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libcourriel-perl
Package version 0.36
Package release 1
Package architecture all
Package type deb
Installed size 229 B
Download size 70.52 KB
Official Mirror ftp.br.debian.org
The Courriel class exists to provide a high level API for working with
emails, particular for processing incoming email. It is primarily a wrapper
around the other classes in the Courriel distro, especially
Courriel::Headers, Courriel::Part::Single, and Courriel::Part::Multipart. If
you need lower level information about an email, it should be available from
one of this classes.

Alternatives

Package Version Architecture Repository
libcourriel-perl_0.36-1_all.deb 0.36 all Debian Main
libcourriel-perl - - -

Requires

Name Value
libdatetime-format-mail-perl -
libdatetime-format-natural-perl -
libdatetime-perl -
libdevel-partialdump-perl -
libemail-abstract-perl -
libemail-address-perl -
libemail-messageid-perl -
libemail-mime-encodings-perl -
libfile-libmagic-perl -
libfile-slurp-tiny-perl -
liblist-allutils-perl -
liblist-moreutils-perl >= 0.28
libmoose-perl -
libmoosex-params-validate-perl -
libmoosex-role-parameterized-perl -
libmoosex-strictconstructor-perl -
libmoosex-types-common-perl -
libmoosex-types-perl -
libnamespace-autoclean-perl -
libsub-exporter-perl -
perl -

Download

Type URL
Binary Package libcourriel-perl_0.36-1_all.deb
Source Package libcourriel-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcourriel-perl deb package:
    # sudo apt-get install libcourriel-perl

Files

Path
/usr/share/doc/libcourriel-perl/NEWS.Debian.gz
/usr/share/doc/libcourriel-perl/changelog.Debian.gz
/usr/share/doc/libcourriel-perl/changelog.gz
/usr/share/doc/libcourriel-perl/copyright
/usr/share/doc/libcourriel-perl/examples/sendgrid
/usr/share/man/man3/Courriel.3pm.gz
/usr/share/man/man3/Courriel::Builder.3pm.gz
/usr/share/man/man3/Courriel::Header.3pm.gz
/usr/share/man/man3/Courriel::Header::ContentType.3pm.gz
/usr/share/man/man3/Courriel::Header::Disposition.3pm.gz
/usr/share/man/man3/Courriel::HeaderAttribute.3pm.gz
/usr/share/man/man3/Courriel::Headers.3pm.gz
/usr/share/man/man3/Courriel::Part::Multipart.3pm.gz
/usr/share/man/man3/Courriel::Part::Single.3pm.gz
/usr/share/man/man3/Email::Abstract::Courriel.3pm.gz
/usr/share/perl5/Courriel.pm
/usr/share/perl5/Courriel/Builder.pm
/usr/share/perl5/Courriel/Header.pm
/usr/share/perl5/Courriel/HeaderAttribute.pm
/usr/share/perl5/Courriel/Headers.pm
/usr/share/perl5/Courriel/Helpers.pm
/usr/share/perl5/Courriel/Types.pm
/usr/share/perl5/Courriel/Header/ContentType.pm
/usr/share/perl5/Courriel/Header/Disposition.pm
/usr/share/perl5/Courriel/Part/Multipart.pm
/usr/share/perl5/Courriel/Part/Single.pm
/usr/share/perl5/Courriel/Role/HeaderWithAttributes.pm
/usr/share/perl5/Courriel/Role/Part.pm
/usr/share/perl5/Courriel/Role/Streams.pm
/usr/share/perl5/Courriel/Types/Internal.pm
/usr/share/perl5/Email/Abstract/Courriel.pm

Changelog

2014-09-15 - gregor herrmann <gregoa@debian.org>
libcourriel-perl (0.36-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Imported upstream version 0.36
2014-05-13 - gregor herrmann <gregoa@debian.org>
libcourriel-perl (0.35-1) unstable; urgency=medium
* New upstream release.
* debian/control: replace libfile-slurp-perl with
libfile-slurp-tiny-perl.
2014-05-11 - gregor herrmann <gregoa@debian.org>
libcourriel-perl (0.34-1) unstable; urgency=medium
* New upstream release.
* Update years of packaging copyright.
2014-04-22 - Florian Schlichting <fsfs@debian.org>
libcourriel-perl (0.33-1) unstable; urgency=medium
* Team upload
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Florian Schlichting ]
* Import Upstream version 0.33
* Bump year of upstream copyright
* Declare compliance with Debian Policy 3.9.5
2013-04-05 - Xavier Guimard <x.guimard@free.fr>
libcourriel-perl (0.31-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Xavier Guimard ]
* Imported Upstream version 0.31
* Add eg/* in example files
* Add version to liblist-moreutils-perl dependency
* Update debian/copyright years
2012-09-24 - Xavier Guimard <x.guimard@free.fr>
libcourriel-perl (0.30-1) unstable; urgency=low
* New upstream version
* Add myself to uploaders and copyright
* Bump Standards-Version to 3.9.4
* Update debian/NEWS
2012-03-13 - Salvatore Bonaccorso <carnil@debian.org>
libcourriel-perl (0.29-1) unstable; urgency=low
* Team upload.
* Imported Upstream version 0.29
* Update debian/copyright information.
Update format to copyright-format 1.0 as released together with Debian
policy 3.9.3 (only URL change needed).
* Bump Standards-Version to 3.9.3
2012-02-07 - Salvatore Bonaccorso <carnil@debian.org>
libcourriel-perl (0.28-1) unstable; urgency=low
* Team upload.
* Imported Upstream version 0.28
* Add libemail-abstract-perl as dependency.
Add libemail-abstract-perl to (Build-)Depends(-Indep) fields in
debian/control file.
* Change dependency on liblist-moreutils-perl.
Change versioned (Build-)Depends(-Indep) on liblist-moreutils-perl to a
unversioned dependency as the required version is satisfied in Squeeze
and Lenny (oldstable) is end-of-life.
* Simplify dependencies satisfied in Stable.
Drop alternate (Build-)Depends(-Indep) for perl (>= 5.10.1) |
libtest-simple-perl (>= 0.88) and perl (>= 5.10.1) | libparent-perl as
they are already satisfied in Squeeze.
* Update copyright years for upstream files
2011-09-26 - Salvatore Bonaccorso <carnil@debian.org>
libcourriel-perl (0.27-1) unstable; urgency=low
* Team upload.
[ gregor herrmann ]
* New upstream release. (0.26)
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.27
* Document API changes in debian/NEWS.
Document API changes in 0.27
2011-09-17 - gregor herrmann <gregoa@debian.org>
libcourriel-perl (0.25-1) unstable; urgency=low
* New upstream release.
* Add debian/NEWS about API changes.
* Update build and runtime dependencies.

See Also

Package Description
libcoverart-dev_1.0.0+git20140109-2_amd64.deb library to access the Cover Art Archive (development files)
libcoverart-doc_1.0.0+git20140109-2_all.deb library to access the Cover Art Archive (developer documentation)
libcoverart0_1.0.0+git20140109-2_amd64.deb library to access the Cover Art Archive
libcoy-perl_0.06-7_all.deb replace perl error messages with haiku
libcoyotl-3.1-4_3.1.0-6_amd64.deb portable C++ classes used by acovea
libcoyotl-dev_3.1.0-6_amd64.deb portable C++ classes used by acovea -- development files
libcpan-changes-perl_0.30-1_all.deb module for reading and writing CPAN Changes files
libcpan-checksums-perl_2.09-1_all.deb Perl module to write a CHECKSUMS file for a directory as on CPAN
libcpan-distnameinfo-perl_0.12-1_all.deb module to extract distribution name and version from a filename
libcpan-inject-perl_1.14-1_all.deb module for injecting distributions into CPAN sources
libcpan-meta-check-perl_0.009-1_all.deb verify requirements in a CPAN::Meta object
libcpan-meta-perl_2.142690-1_all.deb Perl module to access CPAN distributions metadata
libcpan-meta-requirements-perl_2.128-1_all.deb set of version requirements for a CPAN dist
libcpan-meta-yaml-perl_0.012-1_all.deb reimplementation of a subset of YAML for CPAN Meta files
libcpan-mini-inject-perl_0.33-1_all.deb module to inject modules into a CPAN::Mini mirror
Advertisement
Advertisement