libconfig8-dev_1.4.9-2_amd64.deb


Advertisement

Description

libconfig8-dev - Transitional package for libconfig-dev

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libconfig8-dev
Package version 1.4.9
Package release 2
Package architecture amd64
Package type deb
Installed size 10 B
Download size 9.85 KB
Official Mirror ftp.br.debian.org
This is a transitional package for libconfig-dev, and can be safely removed
when no other package depends on it.

Alternatives

Package Version Architecture Repository
libconfig8-dev_1.4.9-2_i386.deb 1.4.9 i386 Debian Main
libconfig8-dev - - -

Requires

Name Value
libconfig-dev -

Download

Type URL
Binary Package libconfig8-dev_1.4.9-2_amd64.deb
Source Package libconfig

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libconfig8-dev deb package:
    # sudo apt-get install libconfig8-dev

Files

Path
/usr/share/doc/libconfig8-dev/changelog.Debian.gz
/usr/share/doc/libconfig8-dev/changelog.gz
/usr/share/doc/libconfig8-dev/copyright

Changelog

2013-12-28 - Jonathan McCrohan <jmccrohan@gmail.com>
libconfig (1.4.9-2) unstable; urgency=medium
* Update short package description (Closes: #710783)
* Build using dh-autoreconf rather than autotools-dev; thanks to Matthias
Klose for this fix
* Add tex-workaround.patch from Matthias Klose to fix texinfo/tex FTBFS
* With sponsor's blessing, set myself as maintainer
* Bump Standards-Version to 3.9.5
- No changes required
2013-10-12 - Jonathan McCrohan <jmccrohan@gmail.com>
libconfig (1.4.9-1) unstable; urgency=low
* New upstream release
* Update S-V to 3.9.4
- No changes necessary
* Ensure that libconfig++-dbg depends on libconfig9 (= ${binary:Version})
in addition to libconfig++9 (= ${binary:Version})
- Fixes dbg-package-missing-depends lintian warning
2012-06-26 - Jonathan McCrohan <jmccrohan@gmail.com>
libconfig (1.4.8-5) unstable; urgency=low
* Switch to dh_9 style rules file
- Hardened buildflags now provided automatically
- Fixes E-binary-arch-produces-all buildd warning
2012-04-06 - Jonathan McCrohan <jmccrohan@gmail.com>
libconfig (1.4.8-4) unstable; urgency=low
* Add C++ hardened buildflags
- Thanks to Simon Ruderich for the patch (closes: #662225)
* Fix libconfig(++)8-dev transition packages
- Set section as oldlibs
- Set priority as extra
- Remove package descriptions
* Add Multiarch support 
2012-03-05 - Jonathan McCrohan <jmccrohan@gmail.com>
libconfig (1.4.8-3) unstable; urgency=low
* Add Replaces+Breaks: libconfig(++)8-dev to libconfig(++)-dev
- Thanks to Andreas Beckmann for reporting (closes: #662643)
* Enable hardened buildflags
- Thanks to Simon Ruderich for the patch (closes: #662225)
* Fix incorrect section and arch for transitional packages.
2012-03-01 - Jonathan McCrohan <jmccrohan@gmail.com>
libconfig (1.4.8-2) unstable; urgency=low
* Upload to unstable
* Update to S-V 3.9.3
* debian/rules now uses dpkg-buildflags
* Provide full transitional packages to help -dev package rename
* Multiple lintian fixes
- out-of-date-standards-version
- copyright-with-old-dh-make-debian-copyright
- extended-description-is-probably-too-short
- unneeded-build-dep-on-quilt
2012-02-11 - Jonathan McCrohan <jmccrohan@gmail.com>
libconfig (1.4.8-1~exp1) experimental; urgency=low
* New upstream release (closes: #583528)
- soname bump to 9
* Update to S-V 3.9.2
* Update to Debhelper v7
* Refresh Build-Depends packages
* Add debug packages
* Remove soname from -dev package names
- Build as virtual packages for reverse dependency purposes.
* Fix examples (closes: #632081)
2009-09-13 - Jose Luis Tallon <jltallon@adv-solutions.net>
libconfig (1.3.2-2) unstable; urgency=low
* Removed "conflicts" with older sonames (Closes: #536635)
* Added missing compile-time libconfig++8-dev dependencies 
(libconfig8-dev) (Closes: #537311)
* Removed libtool's ".la" files (clients should use pkg-config)
* Updated to S-V 3.8.3 with no changes
* With many thanks to Christian Hammers, who kindly checked the package.
2009-04-07 - Jose Luis Tallon <jltallon@adv-solutions.net>
libconfig (1.3.2-1) unstable; urgency=low
* New upstream release (Closes: #521725)
- soname bump to 8
- Updated to S-V 3.8.1 with no changes
2008-10-31 - Jose Luis Tallon <jltallon@adv-solutions.net>
libconfig (1.3.1-1) unstable; urgency=low
* First upload to Debian (Closes: #438683)
* New upstream release
- soname bump to 6.1

See Also

Package Description
libconfig9_1.4.9-2_amd64.deb parsing/manipulation of structured configuration files
libconfigreader-perl_0.5-5_all.deb Perl module for reading configuration files
libconfigreader-simple-perl_1.29-1_all.deb simple configuration file parser
libconfuse-common_2.7-5_all.deb Common files for libConfuse
libconfuse-dev_2.7-5_amd64.deb Development files for libConfuse
libconfuse0_2.7-5_amd64.deb Library for parsing configuration files
libconsole-bridge-dev_0.2.5-2+b1_amd64.deb console bridge - development files
libconsole-bridge0.2_0.2.5-2+b1_amd64.deb console bridge - library
libconst-fast-perl_0.014-1_all.deb facility for creating read-only scalars, arrays, and hashes
libconstant-defer-perl_5-1_all.deb Perl module providing constant subs with deferred value calculation
libconstantine-java-doc_0.7-6_all.deb Java Constantine library API documentation
libconstantine-java_0.7-6_all.deb platform constants for Java
libcontext-preserve-perl_0.01-1_all.deb Perl module to preserve calling context
libcontextual-return-perl_0.004007-1_all.deb module for creating context-sensitive return values
libconvert-ascii-armour-perl_1.4-1_all.deb module to convert binary into ASCII-armoured messages
Advertisement
Advertisement