libcommons-validator-java_1.4.0-2_all.deb


Advertisement

Description

libcommons-validator-java - ease and speed development and maintenance of validation rules

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libcommons-validator-java
Package version 1.4.0
Package release 2
Package architecture all
Package type deb
Installed size 330 B
Download size 167.30 KB
Official Mirror ftp.br.debian.org
The Commons Validator is a basic validation framework
that lets you define validation rules for a JavaBean
in an xml file.
Validation rules can be defined in an xml file which
keeps them abstracted from JavaBean you are validating.

Alternatives

Package Version Architecture Repository
libcommons-validator-java_1.4.0-2_all.deb 1.4.0 all Debian Main
libcommons-validator-java - - -

Requires

Name Value
libcommons-beanutils-java >= 1.7
libcommons-collections3-java -
libcommons-digester-java >= 1.6
libcommons-logging-java >= 1.0.4
sgml-base >= 1.26+nmu2

Download

Type URL
Binary Package libcommons-validator-java_1.4.0-2_all.deb
Source Package libcommons-validator-java

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcommons-validator-java deb package:
    # sudo apt-get install libcommons-validator-java

Files

Path
/etc/sgml/libcommons-validator-java.cat
/usr/share/doc/libcommons-validator-java/README.Debian
/usr/share/doc/libcommons-validator-java/changelog.Debian.gz
/usr/share/doc/libcommons-validator-java/changelog.gz
/usr/share/doc/libcommons-validator-java/copyright
/usr/share/java/commons-validator-1.4.0.jar
/usr/share/java/commons-validator.jar
/usr/share/maven-repo/commons-validator/commons-validator/1.4.0/commons-validator-1.4.0.jar
/usr/share/maven-repo/commons-validator/commons-validator/1.4.0/commons-validator-1.4.0.pom
/usr/share/maven-repo/commons-validator/commons-validator/debian/commons-validator-debian.jar
/usr/share/maven-repo/commons-validator/commons-validator/debian/commons-validator-debian.pom
/usr/share/sgml/apache/jakarta/validator/catalog
/usr/share/sgml/apache/jakarta/validator/validator_1_0.dtd
/usr/share/sgml/apache/jakarta/validator/validator_1_0_1.dtd
/usr/share/sgml/apache/jakarta/validator/validator_1_1.dtd
/usr/share/sgml/apache/jakarta/validator/validator_1_1_3.dtd
/usr/share/sgml/apache/jakarta/validator/validator_1_2_0.dtd
/usr/share/sgml/apache/jakarta/validator/validator_1_3_0.dtd
/usr/share/sgml/apache/jakarta/validator/validator_1_4_0.dtd

Changelog

2013-08-08 - Emmanuel Bourg <ebourg@apache.org>
libcommons-validator-java (1:1.4.0-2) unstable; urgency=low
* Specified the source encoding to fix the build failure with Java 7
* Upgraded the dependency on Commons Collections to 3.x
2013-07-30 - Emmanuel Bourg <ebourg@apache.org>
libcommons-validator-java (1:1.4.0-1) unstable; urgency=low
* New upstream release
* Refreshed the patches
* Switched the build to Maven
* Removed debian/orig-tar.sh and use the upstream tarball as is
* debian/rules: Install the upstream changelog
* debian/control:
- Updated Standards-Version to 3.9.4 (no changes)
- Use canonical URLs for the Vcs-* fields
- Removed the no longer used dependency on liboro-java
* debian/copyright: Fixed the Format URI
* Added the Classpath attribute in the manifest of the jar
2012-06-02 - tony mancill <tmancill@debian.org>
libcommons-validator-java (1:1.3.1-9) unstable; urgency=low
* Team upload.
* Sourceful rebuild for Arch: all package (Closes: #675485)
2012-01-08 - Damien Raude-Morvan <drazzib@debian.org>
libcommons-validator-java (1:1.3.1-8) unstable; urgency=low
[ Miguel Landaeta ]
* Team upload.
* Switch to default-jdk. (Closes: #643520).
* Bump Standards-Version to 3.9.2. No changes were required.
[ Damien Raude-Morvan ]
* Fix -compress.js files: Use yui-compressor to minify all .js files.
- Build-Depends on yui-compressor.
- Drop Depends and B-D on rhino.
- d/ant.properties: Use yui-compressor JAR.
- d/patches/yui_compressor_params.diff: Drop -c parameter.
* Reformat d/copyright to DEP-5.
2011-08-07 - Torsten Werner <twerner@debian.org>
libcommons-validator-java (1:1.3.1-7) unstable; urgency=low
* Team upload.
* Remove Arnaud from Uploaders list.
* Switch to source format 3.0.
2009-08-09 - Torsten Werner <twerner@debian.org>
libcommons-validator-java (1:1.3.1-6) unstable; urgency=low
* Upload to unstable.
2009-07-02 - Ludovic Claude <ludovic.claude@laposte.net>
libcommons-validator-java (1:1.3.1-5) experimental; urgency=low
* Change section to java, bump up Standards-Version to 3.8.1
* Add the Maven POM to the package,
* Add a Build-Depends-Indep dependency on maven-repo-helper and quilt
* Use mh_installpom and mh_installjar to install the POM and the jar to the
Maven repository
* Add ${misc:Depends} to Depends to clear Lintian warnings  
* Remove Depends on Java runtimes as it is a library
* Move liboro-java to Recommends as this library is optional
* Use default-jdk for the build instead of java-gcj-compat-dev
* Put the Javadoc into a separate doc package
* Use openjdk-6-jdk for the build instead of default-java as
default-java can use gcj which has issues when generating
the Javadoc.
2009-06-21 - Varun Hiremath <varun@debian.org>
libcommons-validator-java (1:1.3.1-4) unstable; urgency=low
[ Emmanuel Bourg ]
* Update of the URLs
* Rename Jakarta Commons to Apache Commons
[ Varun Hiremath ]
* Reupload with updated URLs in copyright and watch file
2009-06-21 - Varun Hiremath <varun@debian.org>
libcommons-validator-java (1:1.3.1-3) unstable; urgency=low
* debian/rules: fix JAVA_HOME, set it to default-java (Closes: #533869)
2009-06-16 - Varun Hiremath <varun@debian.org>
libcommons-validator-java (1:1.3.1-2) unstable; urgency=low
[ Kumar Appaiah ]
* debian/control:
+ Add Homepage field
[ Varun Hiremath ]
* Update license to Apache-2.0 (Closes: #532887)
* Swicth to default-jdk

See Also

Package Description
libcommons-vfs-java-doc_2.0-3_all.deb Java API for accessing various filesystems - documentation
libcommons-vfs-java_2.0-3_all.deb Java API for accessing various filesystems
libcompare-camlp4-dev_109.60.00-1_amd64.deb OCaml syntax extension for deriving "compare" functions automatically
libcompfaceg1-dev_1.5.2-5_amd64.deb Compress/decompress images for mailheaders, libc6 devel
libcompfaceg1_1.5.2-5_amd64.deb Compress/decompress images for mailheaders, libc6 runtime
libcomplete-clojure_0.2.2-1_all.deb completion of Clojure symbols
libcomposereditorng4_4.14.1-1+deb8u1_amd64.deb compose editor library
libcompress-bzip2-perl_2.18-2_amd64.deb Perl interface to Bzip2 compression library
libcompress-lzf-java_1.0.3-1_all.deb Ning-compress-LZF
libcompress-raw-bzip2-perl_2.066-1_amd64.deb low-level interface to bzip2 compression library
libcompress-raw-lzma-perl_2.066-1_amd64.deb low-level interface to lzma compression library
libcompress-raw-zlib-perl_2.066-1_amd64.deb low-level interface to zlib compression library
libconcord-dev_1.1-3_amd64.deb configuration tool for Harmony remotes - development files
libconcord3_1.1-3_amd64.deb configuration tool for Harmony remotes - runtime libraries
libconcurrent-java-doc_1.3.4-4_all.deb documentation and javadoc API for libconcurrent-java
Advertisement
Advertisement