libclass-method-modifiers-perl_2.11-1_all.deb


Advertisement

Description

libclass-method-modifiers-perl - Perl module providing method modifiers

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libclass-method-modifiers-perl
Package version: 2.11
Package release: 1
Package architecture: all
Package type: deb
Installed size: 31 B
Download size: 18.06 KB
Official Mirror: ftp.br.debian.org
Class::Method::Modifiers provides three modifiers: before, around, and after. The before and after modifiers are run just before and after the method they modify, but cannot really affect that original method. The remaining modifier, around, is run in place of the original method, with a hook to easily call the original method.

Requires

    Download

    Source package: libclass-method-modifiers-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libclass-method-modifiers-perl deb package:
      # sudo apt-get install libclass-method-modifiers-perl

    Files

    • /usr/share/doc/libclass-method-modifiers-perl/CONTRIBUTING
    • /usr/share/doc/libclass-method-modifiers-perl/changelog.Debian.gz
    • /usr/share/doc/libclass-method-modifiers-perl/changelog.gz
    • /usr/share/doc/libclass-method-modifiers-perl/copyright
    • /usr/share/man/man3/Class::Method::Modifiers.3pm.gz
    • /usr/share/perl5/Class/Method/Modifiers.pm

    Changelog

    2014-08-26 - Damyan Ivanov <dmn@debian.org> libclass-method-modifiers-perl (2.11-1) unstable; urgency=medium * Team upload [ Salvatore Bonaccorso ] * Update Vcs-Browser URL to cgit web frontend [ Damyan Ivanov ] * Imported Upstream version 2.11 * add ibtest-requires-perl to build-dependencies * Add debian/upstream/metadata

    2014-04-07 - gregor herrmann <gregoa@debian.org> libclass-method-modifiers-perl (2.10-1) unstable; urgency=medium * New upstream release. * Strip trailing slash from metacpan URLs. * Update build dependencies, lower debhelper version/compatibility level. Module::Build::Tiny isn't used anymore. * Update years of packaging copyright.

    2013-12-15 - gregor herrmann <gregoa@debian.org> libclass-method-modifiers-perl (2.09-1) unstable; urgency=low [ Damyan Ivanov ] * Imported Upstream version 2.08 [ gregor herrmann ] * New upstream release 2.09. * Update build dependencies. * Install new CONTRIBUTING document. * debian/copyright: update Upstream-Contact. * Declare compliance with Debian Policy 3.9.5.

    2013-10-01 - gregor herrmann <gregoa@debian.org> libclass-method-modifiers-perl (2.07-1) unstable; urgency=low * New upstream release. * Update build dependencies.

    2013-09-21 - gregor herrmann <gregoa@debian.org> libclass-method-modifiers-perl (2.06-1) unstable; urgency=low * New upstream release. * Update build dependencies and debian/compat. Upstream went back from Module::Build::Tiny to ExtUtils::MakeMaker.

    2013-09-17 - gregor herrmann <gregoa@debian.org> libclass-method-modifiers-perl (2.05-1) unstable; urgency=low * New upstream release. * debian/copyright: drop information about removed Module::Install. * Update (build) dependencies.

    2013-08-09 - gregor herrmann <gregoa@debian.org> libclass-method-modifiers-perl (2.04-1) unstable; urgency=low * New upstream release. * Update years of packaging copyright.

    2013-02-12 - Alessandro Ghedini <ghedo@debian.org> libclass-method-modifiers-perl (2.03-1) unstable; urgency=low [ Nathan Handler ] * Email change: Nathan Handler -> nhandler@debian.org [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Alessandro Ghedini ] * New upstream release

    2012-11-07 - Alessandro Ghedini <ghedo@debian.org> libclass-method-modifiers-perl (1.12-1) unstable; urgency=low * New upstream release * Bump Standards-Version to 3.9.4 (no changes needed) * Add myself to Uploaders

    2012-04-03 - Alessandro Ghedini <ghedo@debian.org> libclass-method-modifiers-perl (1.09-1) unstable; urgency=low * Team upload * New upstream release * Update copyright years for inc/Module/* * Update debian/copyright format as in Debian Policy 3.9.3 * Bump Standards-Version to 3.9.3 * Add Class::MOP (libmoose-perl (>= 2) | libclass-mop-perl) to build depends (needed by a test)

    Advertisement
    Advertisement