libclass-dbi-plugin-pager-perl_0.566-1_all.deb


Advertisement

Description

libclass-dbi-plugin-pager-perl - Perl extension for paging SQL results

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libclass-dbi-plugin-pager-perl
Package version: 0.566
Package release: 1
Package architecture: all
Package type: deb
Installed size: 80 B
Download size: 16.85 KB
Official Mirror: ftp.br.debian.org
Class::DBI::Plugin::Pager adds a pager method that can query using SQL::Abstract where clauses, and limit the number of rows returned to a specific subset.

    Download

    Source package: libclass-dbi-plugin-pager-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libclass-dbi-plugin-pager-perl deb package:
      # sudo apt-get install libclass-dbi-plugin-pager-perl

    Files

    • /usr/share/doc/libclass-dbi-plugin-pager-perl/changelog.Debian.gz
    • /usr/share/doc/libclass-dbi-plugin-pager-perl/changelog.gz
    • /usr/share/doc/libclass-dbi-plugin-pager-perl/copyright
    • /usr/share/man/man3/Class::DBI::Plugin::Pager.3pm.gz
    • /usr/share/perl5/Class/DBI/Plugin/Pager.pm
    • /usr/share/perl5/Class/DBI/Plugin/Pager/LimitOffset.pm
    • /usr/share/perl5/Class/DBI/Plugin/Pager/LimitXY.pm
    • /usr/share/perl5/Class/DBI/Plugin/Pager/LimitYX.pm
    • /usr/share/perl5/Class/DBI/Plugin/Pager/RowsTo.pm

    Changelog

    2012-12-02 - Xavier Guimard <x.guimard@free.fr> libclass-dbi-plugin-pager-perl (0.566-1) unstable; urgency=low [ Tim Retout ] * Email change: Tim Retout -> diocles@debian.org [ Ansgar Burchardt ] * Email change: Ansgar Burchardt -> ansgar@debian.org * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Xavier Guimard ] * Imported Upstream version 0.566 * Remove fix-tests-new-sql-abstract.patch included now in upstream * Use debhelper 8 * Bump Standards-Version to 3.9.4 * Add libuniversal-require-perl in dependencies * Update debian/copyright (years and format) * Add "libmodule-build-perl (>= 0.400000) | perl (>= 5.17.1)" in Build-Depends * Clean description

    2010-04-07 - Ansgar Burchardt <ansgar@43-1.org> libclass-dbi-plugin-pager-perl (0.561-4) unstable; urgency=low * Update patch to use correct SQL comparison operator. (Closes: #576644) * debian/control: Make dependency on libsql-abstract-perl versioned, same as the Build-Depends. * Use source format 3.0 (quilt); drop quilt framework and README.source. * debian/copyright: Minor formatting changes for current DEP-5 proposal. * Bump Standards-Version to 3.8.4 (no changes). * Add myself to Uploaders.

    2009-08-05 - Tim Retout <tim@retout.co.uk> libclass-dbi-plugin-pager-perl (0.561-3) unstable; urgency=medium [ gregor herrmann ] * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). * debian/control: Added: ${misc:Depends} to Depends: field. [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Tim Retout ] * Switch to 3-line rules file with quilt. + Update debhelper compat and Build-Dependency to 7. + Add quilt Build-Dependency. * Add patch to fix 02main.t with libsql-abstract-perl (>= 1.55), and Build-Depend on that. (Closes: #531230) * Set urgency to medium for RC bug fix. * Add self to Uploaders. * Update Standards-Version to 3.8.2. + Add standard quilt README.source. [ gregor herrmann ] * debian/control: drop build dependency on libmodule-build-perl, debhelper uses EUMM. * debian/copyright: update format and info about debian/*.

    2008-02-10 - Damyan Ivanov <dmn@debian.org> libclass-dbi-plugin-pager-perl (0.561-2) unstable; urgency=low * Taking over maintenance with Ben's approval * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza). Changed: Maintainer set to Debian Perl Group <pkg-perl- maintainers@lists.alioth.debian.org> (was: Ben Hutchings <ben@decadentplace.org.uk>); Ben Hutchings <ben@decadentplace.org.uk> moved to Uploaders. * Add debian/watch. * debian/rules: remade with dh-make-perl template + stop installing README as it contains nothing more that the POD * move debhelper, perl and libmodule-build-perl from B-D-I to B-D. * bump debhelper compatibility level to 5 * Standards-Version 3.7.3 (no changes) * add myself to Uploaders * remove Homepage pseudo-field from long description * debian/copyright: use dist-based upstream URL + convert to machine-readable format

    2005-12-31 - Ben Hutchings <ben@decadentplace.org.uk> libclass-dbi-plugin-pager-perl (0.561-1) unstable; urgency=low * Initial release - closes: #345453

    Advertisement
    Advertisement