libclass-dbi-loader-perl_0.34-2_all.deb


Advertisement

Description

libclass-dbi-loader-perl - Perl module for dynamic definition of Class::DBI sub classes

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libclass-dbi-loader-perl
Package version: 0.34
Package release: 2
Package architecture: all
Package type: deb
Installed size: 108 B
Download size: 22.31 KB
Official Mirror: ftp.br.debian.org
Class::DBI::Loader automates the definition of Class::DBI sub-classes. It scans database schemas to set up tables, columns, and primary keys. Class names are defined by table names and namespace option. It currently supports MySQL, Postgres and SQLite.

Alternatives

    Download

    Source package: libclass-dbi-loader-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libclass-dbi-loader-perl deb package:
      # sudo apt-get install libclass-dbi-loader-perl

    Files

    • /usr/share/doc/libclass-dbi-loader-perl/changelog.Debian.gz
    • /usr/share/doc/libclass-dbi-loader-perl/changelog.gz
    • /usr/share/doc/libclass-dbi-loader-perl/copyright
    • /usr/share/man/man3/Class::DBI::Loader.3pm.gz
    • /usr/share/man/man3/Class::DBI::Loader::Generic.3pm.gz
    • /usr/share/man/man3/Class::DBI::Loader::Pg.3pm.gz
    • /usr/share/man/man3/Class::DBI::Loader::SQLite.3pm.gz
    • /usr/share/man/man3/Class::DBI::Loader::mysql.3pm.gz
    • /usr/share/perl5/Class/DBI/Loader.pm
    • /usr/share/perl5/Class/DBI/Loader/Generic.pm
    • /usr/share/perl5/Class/DBI/Loader/Pg.pm
    • /usr/share/perl5/Class/DBI/Loader/SQLite.pm
    • /usr/share/perl5/Class/DBI/Loader/mysql.pm

    Changelog

    2009-07-27 - Ansgar Burchardt <ansgar@43-1.org> libclass-dbi-loader-perl (0.34-2) unstable; urgency=low [ Ryan Niebur ] * moved with permission from Bart (Closes: #531499) * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza); ${misc:Depends} to Depends: field. Removed: Homepage pseudo-field (Description). Changed: Maintainer set to Debian Perl Group <pkg- perl-maintainers@lists.alioth.debian.org> (was: Bart Martens <bartm@knars.be>); Bart Martens <bartm@knars.be> moved to Uploaders. * debian/watch: use dist-based URL. * remove Bart from Uploaders [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Ansgar Burchardt ] * Bump Standards-Version to 3.8.2. * Use debhelper 7 instead of cdbs. * Convert debian/copyright to proposed machine-readable format. * Do no longer install README (copy of POD documentation). * Add myself to Uploaders.

    2007-04-12 - Bart Martens <bartm@knars.be> libclass-dbi-loader-perl (0.34-1) unstable; urgency=low * New upstream release.

    2006-11-19 - Bart Martens <bartm@knars.be> libclass-dbi-loader-perl (0.33-2) unstable; urgency=low * New maintainer, as agreed with Stephen. * debian/*: Use cdbs. * debian/control: Added libtest-pod-perl, libtest-pod-coverage-perl, libclass-dbi-mysql-perl and libclass-dbi-pg-perl to Build-Depends-Indep to enable most tests of "make test". * debian/rules: Added TEST_POD=yes to enable some tests in "make test". * debian/copyright: Updated to add copyright notice. * debian/control: Fixed description-synopsis-might-not-be-phrased-properly. * debian/watch: Updated to version 3.

    2006-06-15 - Stephen Quinney <sjq@debian.org> libclass-dbi-loader-perl (0.33-1) unstable; urgency=low * New upstream release

    2006-04-16 - Stephen Quinney <sjq@debian.org> libclass-dbi-loader-perl (0.32-1) unstable; urgency=low * New upstream release * Note in the recommends that a minimum version of 0.07 is required for PostgreSQL 8 support. * Also added libclass-dbi-mysql-perl to the recommends list.

    2006-01-28 - Stephen Quinney <sjq@debian.org> libclass-dbi-loader-perl (0.28-1) unstable; urgency=low * New upstream release * New upstream author - updated debian/copyright and debian/watch. * Switched to my debian.org email address.

    2005-06-15 - Stephen Quinney <sjq@debian.org> libclass-dbi-loader-perl (0.22-1) unstable; urgency=low * New upstream release

    2005-04-30 - Stephen Quinney <sjq@debian.org> libclass-dbi-loader-perl (0.20-1) unstable; urgency=low * New upstream release - mainly improved SQLite support.

    2005-04-10 - Stephen Quinney <sjq@debian.org> libclass-dbi-loader-perl (0.18-1) unstable; urgency=low * New upstream release - small bug fix for mysql * Removed tests (and resulting build dependencies) as they weren't actually doing anything useful.

    2005-03-12 - Stephen Quinney <sjq@debian.org> libclass-dbi-loader-perl (0.17-1) unstable; urgency=low * New upstream release - can now specify tables to be excluded

    Advertisement
    Advertisement