libclass-dbi-asform-perl_2.42-6_all.deb


Advertisement

Description

libclass-dbi-asform-perl - module to produce HTML form elements for database columns using Class::DBI

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libclass-dbi-asform-perl
Package version: 2.42
Package release: 6
Package architecture: all
Package type: deb
Installed size: 68 B
Download size: 9.30 KB
Official Mirror: ftp.br.debian.org
The Class::DBI::AsForm module helps to generate HTML forms for creating new database rows or editing existing rows. It maps column names in a database table to HTML form elements which fit the schema. Large text fields are turned into textareas, and fields with a has-a relationship to other Class::DBI tables are turned into select drop-downs populated with objects from the joined class.

Alternatives

    Download

    Source package: libclass-dbi-asform-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libclass-dbi-asform-perl deb package:
      # sudo apt-get install libclass-dbi-asform-perl

    Files

    • /usr/share/doc/libclass-dbi-asform-perl/changelog.Debian.gz
    • /usr/share/doc/libclass-dbi-asform-perl/changelog.gz
    • /usr/share/doc/libclass-dbi-asform-perl/copyright
    • /usr/share/man/man3/Class::DBI::AsForm.3pm.gz
    • /usr/share/perl5/Class/DBI/AsForm.pm

    Changelog

    2011-01-02 - gregor herrmann <gregoa@debian.org> libclass-dbi-asform-perl (2.42-6) unstable; urgency=low [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ Ansgar Burchardt ] * Update my email address. [ gregor herrmann ] * debian/rules: switch order of arguments to dh. * Add DEP3 headers to 01_libhtml-tree-perl_3.23-1.diff. * New patch 02_libhtml-tree-perl_4.0.diff to make the tests work with libhtml-tree-perl >= 4; tighten build dependency (closes: #605793). * Switch to source format 3.0 (quilt). * Set Standards-Version to 3.9.1 (no changes). * Add /me to Uploaders. * debian/control: remove ancient versions from (build) dependencies. * Refresh debian/copyright formatting.

    2009-07-20 - Ansgar Burchardt <ansgar@43-1.org> libclass-dbi-asform-perl (2.42-5) unstable; urgency=low [ Ryan Niebur ] * moved with permission from Bart (Closes: #531510) * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); ${misc:Depends} to Depends: field. Changed: Maintainer set to Debian Perl Group <pkg-perl- maintainers@lists.alioth.debian.org> (was: Bart Martens <bartm@debian.org>); Bart Martens <bartm@debian.org> moved to Uploaders. * debian/watch: use dist-based URL. * remove Bart from Uploaders [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Ansgar Burchardt ] * Mention module name in description. * Use debhelper 7 and quilt instead of cdbs. * Bump Standards-Version to 3.8.2. * Add myself to Uploaders. * Do no longer install README (copy of POD documentation). * Convert debian/copyright to proposed machine-readable format. * Add README.source. [ gregor herrmann ] * debian/control: make short description a noun phrase.

    2008-08-30 - Bart Martens <bartm@debian.org> libclass-dbi-asform-perl (2.42-4) unstable; urgency=low * debian/control: Standards-Version, Homepage, changed my e-mail address, and fixed build-depends-on-1-revision.

    2007-04-24 - Bart Martens <bartm@knars.be> libclass-dbi-asform-perl (2.42-3) unstable; urgency=low * debian/patches/01_libhtml-tree-perl_3.23-1.diff: Added. Closes: #414745. Patch by Niko Tyni <ntyni@iki.fi>, thanks.

    2006-11-19 - Bart Martens <bartm@knars.be> libclass-dbi-asform-perl (2.42-2) unstable; urgency=low * New maintainer, as agreed with Stephen. * debian/*: Use cdbs. * debian/control: Added libtest-pod-perl and libtest-pod-coverage-perl to Build-Depends-Indep for "make test". * debian/watch: Updated to version 3.

    2005-09-22 - Stephen Quinney <sjq@debian.org> libclass-dbi-asform-perl (2.42-1) unstable; urgency=low * New upstream release, closes: #329512. * Switched to my debian.org email address.

    2005-04-01 - Stephen Quinney <sjq@debian.org> libclass-dbi-asform-perl (2.41-2) unstable; urgency=high * Build depend against libdbd-sqlite2-perl instead of libdbd-sqlite-perl, fixes FTBFS in Sarge so urgency is high. When this fix reaches Sarge it will close #301659. * Remove the test.db in the debian/rules "clean" stage

    2004-12-29 - Stephen Quinney <sjq@debian.org> libclass-dbi-asform-perl (2.41-1) unstable; urgency=low * New upstream release - new maintainer. * Updated debian/copyright and debian/watch to reflect change of upstream maintainer.

    2004-09-17 - Stephen Quinney <sjq@debian.org> libclass-dbi-asform-perl (2.3-1) unstable; urgency=low * New upstream release - first upload, closes: #271975.

    2004-05-28 - Stephen Quinney <sjq@debian.org> libclass-dbi-asform-perl (2.2-1) unstable; urgency=low * Initial Release.

    Advertisement
    Advertisement