libcgi-ssi-perl_0.92-3_all.deb


Advertisement

Description

libcgi-ssi-perl - Perl module to use SSI from CGI scripts

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libcgi-ssi-perl
Package version 0.92
Package release 3
Package architecture all
Package type deb
Installed size 48 B
Download size 16.72 KB
Official Mirror ftp.br.debian.org
CGI::SSI is meant to be used as an easy way to filter shtml through CGI
scripts in a loose imitation of Apache's mod_include. If you're using
Apache, you may want to use either mod_include or the Apache::SSI module
instead of CGI::SSI. Limitations in a CGI script's knowledge of how the
server behaves make some SSI directives impossible to imitate from a CGI
script.

Alternatives

Package Version Architecture Repository
libcgi-ssi-perl_0.92-3_all.deb 0.92 all Debian Main
libcgi-ssi-perl - - -

Requires

Name Value
libhtml-simpleparse-perl -
libtimedate-perl -
liburi-perl -
libwww-perl -
perl -

Download

Type URL
Binary Package libcgi-ssi-perl_0.92-3_all.deb
Source Package libcgi-ssi-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcgi-ssi-perl deb package:
    # sudo apt-get install libcgi-ssi-perl

Files

Path
/usr/share/doc/libcgi-ssi-perl/changelog.Debian.gz
/usr/share/doc/libcgi-ssi-perl/changelog.gz
/usr/share/doc/libcgi-ssi-perl/copyright
/usr/share/man/man3/CGI::SSI.3pm.gz
/usr/share/perl5/CGI/SSI.pm

Changelog

2011-09-16 - Ansgar Burchardt <ansgar@debian.org>
libcgi-ssi-perl (0.92-3) unstable; urgency=low
* Team upload.
[ gregor herrmann ]
* debian/rules: switch order of arguments to dh.
[ Tim Retout ]
* debian/control: Update my email address.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
* Remove Piotr Roszatycki <dexter@debian.org> from Uploaders.
(Closes: #636741)
* Use source format 3.0 (quilt).
* debian/copyright: Update formatting.
* Use debhelper compat level 8.
* Bump Standards-Version to 3.9.2.
2009-08-08 - Tim Retout <tim@retout.co.uk>
libcgi-ssi-perl (0.92-2) unstable; urgency=low
[ Damyan Ivanov ]
* Take over for the Debian Perl Group on maintainer's request
(http://lists.debian.org/debian-perl/2008/09/msg00111.html)
[ gregor herrmann ]
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
* debian/control: Added: Homepage field (source stanza).
* debian/control: Changed: Maintainer set to Debian Perl Group <pkg-
perl-maintainers@lists.alioth.debian.org> (was: Piotr Roszatycki
<dexter@debian.org>); Piotr Roszatycki <dexter@debian.org> moved to
Uploaders.
* debian/control: make short description a noun phrase.
* debian/watch: use dist-based URL.
[ Tim Retout ]
* Use short format dh7/quilt rules file.  Remove old yada files.
* Add quilt series file, debhelper compat file and README.source.
* debian/control:
+ Remove yada from Build-Depends.
+ B-D-I: Remove version from perl, remove perl-modules and tofrodos.
+ Add debhelper/quilt to Build-Depends.
+ Depends: Replace ${libcgi-ssi-perl:Depends} with ${perl:Depends},
remove perl-modules.
+ Bump Standards-Version to 3.8.2.
+ Add self to Uploaders.
* debian/copyright: Add new copyright file.
* Add author/description headers to debian patch.
2007-09-10 - Piotr Roszatycki <dexter@debian.org>
libcgi-ssi-perl (0.92-1) unstable; urgency=low
* New usptream release.
* debian/packages:
- Convert LF/CR to LF in *.pm.
- Remove executable bit for *.pm.
2006-04-03 - Piotr Roszatycki <dexter@debian.org>
libcgi-ssi-perl (0.88-2) unstable; urgency=low
* Applied NMU patch. Thanks Thijs Kinkhorst,
* Skip tests in 'make test' that try to access remote sites.
Closes: #337391.
2005-10-04 - Piotr Roszatycki <dexter@debian.org>
libcgi-ssi-perl (0.88-1) unstable; urgency=low
* New upstream release. Closes: #329501.
2004-08-09 - Piotr Roszatycki <dexter@debian.org>
libcgi-ssi-perl (0.53-5) unstable; urgency=low
* Remove Origin field and make lintian happy.
2004-03-11 - Piotr Roszatycki <dexter@debian.org>
libcgi-ssi-perl (0.53-4) unstable; urgency=low
* Fix wrong case in Origin field, closes: #154414.
* Remove Bugs field, closes: #220082.
* Section: perl
* Tweaked dependencies.
* `make test' on build.
2001-12-19 - Piotr Roszatycki <dexter@debian.org>
libcgi-ssi-perl (0.53-3) unstable; urgency=low
* Architecture: all
2001-10-17 - Piotr Roszatycki <dexter@debian.org>
libcgi-ssi-perl (0.53-2) unstable; urgency=low
* Build-Depends-Indep in debian/control
2001-07-09 - Piotr Roszatycki <dexter@debian.org>
libcgi-ssi-perl (0.53-1) unstable; urgency=low
* Initial Debian version, closes: #104050

See Also

Package Description
libcgi-struct-xs-perl_1.04-1+b1_amd64.deb Perl module to build structures from CGI data, XS version
libcgi-untaint-date-perl_1.00-2_all.deb CGI::Untaint::date - validate a date
libcgi-untaint-email-perl_0.03-2_all.deb Input handler for CGI::Untaint to validate an email address
libcgi-untaint-perl_1.26-5_all.deb module to process CGI input parameters
libcgi-uploader-perl_2.18-1_all.deb module for managing CGI uploads using an SQL database
libcgi-validop-perl_0.56-1_all.deb module for validating CGI parameters
libcgi-xml-perl_0.1-14_all.deb perl module for converting CGI variables from/to XML
libcgi-xmlapplication-perl_1.1.3-7_all.deb perl module for creating XML-DOM and OO based CGI scripts
libcgi-xmlform-perl_0.10-14_all.deb perl module for reading/generating formatted XML
libcgic-dev_2.05-3_amd64.deb C library for developing CGI applications
libcgic2_2.05-3_amd64.deb C library for developing CGI applications
libcgicc-doc_3.2.9-3_all.deb C++ class library for writing CGI applications (documentation)
libcgicc5-dev_3.2.9-3_amd64.deb C++ class library for writing CGI applications (development files)
libcgicc5_3.2.9-3_amd64.deb C++ class library for writing CGI applications (library)
libcglib3-java-doc_3.1+dfsg-1_all.deb code generation library for Java - documentation
Advertisement
Advertisement