libcgi-java_0.7.3-1_amd64.deb


Advertisement

Description

libcgi-java - CGI library for Java

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libcgi-java
Package version 0.7.3
Package release 1
Package architecture amd64
Package type deb
Installed size 40 B
Download size 21.12 KB
Official Mirror ftp.br.debian.org
This library allows CGI scripts to be written in Java.  The library provides
access to all the standard CGI variables including POST/GET. It also makes it
easy to create input forms in HTML documents.

Alternatives

Package Version Architecture Repository
libcgi-java_0.7.3-1_i386.deb 0.7.3 i386 Debian Main
libcgi-java - - -

Requires

Name Value
libc6 >= 2.2.5

Download

Type URL
Binary Package libcgi-java_0.7.3-1_amd64.deb
Source Package libmatthew-java

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcgi-java deb package:
    # sudo apt-get install libcgi-java

Files

Path
/usr/lib/jni/libcgi-java.so
/usr/share/doc/libcgi-java/changelog.Debian.gz
/usr/share/doc/libcgi-java/changelog.gz
/usr/share/doc/libcgi-java/copyright
/usr/share/java/cgi-0.5.jar
/usr/share/java/cgi.jar

Changelog

2010-08-05 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.7.3-1) unstable; urgency=low
*  New upstream release, fixes a memory leak (Closes: #590331)
2010-04-17 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.7.2-3) unstable; urgency=low
* Use default-jdk-doc instead of classpath-doc (Closes: #567283)
* Fix some lintian warnings 
* Don't build doc when only building arch: any packages (Closes: #561414) 
2009-12-12 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.7.2-2) unstable; urgency=low
* Convert to dh 7
* don't use default-jdk-builddep but default-jdk
2009-04-05 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.7.2-1) unstable; urgency=low
* New Upstream Release
* Bump Standards-Version
* Bump debhelper compat
* Change to section java
2008-04-26 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.7.1-1) unstable; urgency=low
* New Upstream Release (Closes: #476019)
* Change to use default-jdk-builddep (Closes: #477878)
2008-01-10 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.6-1) unstable; urgency=low
* New Upstream Release
* Use javahelper 
* Bump Standards-Version
2007-12-25 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.5-2) unstable; urgency=low
* Add watch file from watchwiz 
2007-12-05 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.5-1) unstable; urgency=low
* Accompanying upstream change to avoid javadoc talking to the web
(Closes: #447351)
* Change maintainer address 
2007-09-19 - Matthew Johnson <debian@matthew.ath.cx>
libmatthew-java (0.4-2) unstable; urgency=low
* fix javadoc variables to make not to need networking 
2007-05-30 - Matthew Johnson <debian@matthew.ath.cx>
libmatthew-java (0.4-1) unstable; urgency=low
* New Upstream Version
* Add JAVADOC to rules; forces creating javadoc with gjdoc.
* Add docs package 
* Register documentation with doc-base
* Initial upload to Debian: Closes: #413405
* Update to new Java policy
* put docs in section doc and libs in section libs

See Also

Package Description
libcgi-pm-perl_4.09-1_all.deb module for Common Gateway Interface applications
libcgi-psgi-perl_0.15-1_all.deb Adapt CGI.pm to the PSGI protocol
libcgi-session-driver-memcached-perl_0.04-1_all.deb Perl module to allow CGI sessions to be stored in memcache
libcgi-session-expiresessions-perl_1.13-1_all.deb automatic deletion of expired CGI sessions
libcgi-session-perl_4.48-1+deb8u1_all.deb persistent session data in CGI applications
libcgi-session-serialize-yaml-perl_4.26-1_all.deb YAML and YAML::Syck support for CGI::Session's serializers
libcgi-simple-perl_1.115-1_all.deb simple CGI.pm compatible OO CGI interface
libcgi-ssi-parser-perl_0.01-1_all.deb used in CGI scripts for parsing SSI directives
libcgi-ssi-perl_0.92-3_all.deb Perl module to use SSI from CGI scripts
libcgi-struct-xs-perl_1.04-1+b1_amd64.deb Perl module to build structures from CGI data, XS version
libcgi-untaint-date-perl_1.00-2_all.deb CGI::Untaint::date - validate a date
libcgi-untaint-email-perl_0.03-2_all.deb Input handler for CGI::Untaint to validate an email address
libcgi-untaint-perl_1.26-5_all.deb module to process CGI input parameters
libcgi-uploader-perl_2.18-1_all.deb module for managing CGI uploads using an SQL database
libcgi-validop-perl_0.56-1_all.deb module for validating CGI parameters
Advertisement
Advertisement