libcgi-expand-perl_2.05-2_all.deb


Advertisement

Description

libcgi-expand-perl - convert flat hash to nested data using TT2's dot convention

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libcgi-expand-perl
Package version 2.05
Package release 2
Package architecture all
Package type deb
Installed size 37 B
Download size 19.09 KB
Official Mirror ftp.br.debian.org
Converts a CGI query into structured data using a dotted name
convention similar to TT2.  expand_cgi works with CGI.pm,
Apache::Request or anything with an appropriate "param" method. Or you
can use expand_hash directly.
If you prefer to use a different flattening convention then CGI::Expand
can be subclassed.

Alternatives

Package Version Architecture Repository
libcgi-expand-perl_2.05-2_all.deb 2.05 all Debian Main
libcgi-expand-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libcgi-expand-perl_2.05-2_all.deb
Source Package libcgi-expand-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcgi-expand-perl deb package:
    # sudo apt-get install libcgi-expand-perl

Files

Path
/usr/share/doc/libcgi-expand-perl/README.gz
/usr/share/doc/libcgi-expand-perl/buildinfo_all.gz
/usr/share/doc/libcgi-expand-perl/changelog.Debian.gz
/usr/share/doc/libcgi-expand-perl/changelog.gz
/usr/share/doc/libcgi-expand-perl/copyright
/usr/share/man/man3/CGI::Expand.3pm.gz
/usr/share/perl5/CGI/Expand.pm

Changelog

2014-04-30 - Jonas Smedegaard <dr@jones.dk>
libcgi-expand-perl (2.05-2) unstable; urgency=medium
* Lower debhelper compatibility level to 8: Need no newer features,
and debhelper 8 is satisfied even in oldstable.
Relax to build-depend unversioned on debhelper.
* Update copyright info:
+ Fix double-indent copyright holders.
* Stop track md5sum of upstream tarball: Compare tarball against
upstream git commits instead.
2014-04-24 - Damyan Ivanov <dmn@debian.org>
libcgi-expand-perl (2.05-1) unstable; urgency=low
* Team upload
[ Vasudev Kamath ]
* Initial Release.
Closes: bug#724506 (ITP).

See Also

Package Description
libcgi-extratags-perl_0.03-1_all.deb Useful Extensions for the CGI Module
libcgi-fast-perl_2.04-1_all.deb CGI subclass for work with FCGI
libcgi-formalware-perl_1.16-1_all.deb Perl module for converting an XML file into a suite of CGI forms
libcgi-formbuilder-perl_3.09-2_all.deb Easily generate and process stateful CGI forms
libcgi-formbuilder-source-yaml-perl_1.0.8-3_all.deb Initialize FormBuilder application from YAML file
libcgi-java_0.7.3-1_amd64.deb CGI library for Java
libcgi-pm-perl_4.09-1_all.deb module for Common Gateway Interface applications
libcgi-psgi-perl_0.15-1_all.deb Adapt CGI.pm to the PSGI protocol
libcgi-session-driver-memcached-perl_0.04-1_all.deb Perl module to allow CGI sessions to be stored in memcache
libcgi-session-expiresessions-perl_1.13-1_all.deb automatic deletion of expired CGI sessions
libcgi-session-perl_4.48-1+deb8u1_all.deb persistent session data in CGI applications
libcgi-session-serialize-yaml-perl_4.26-1_all.deb YAML and YAML::Syck support for CGI::Session's serializers
libcgi-simple-perl_1.115-1_all.deb simple CGI.pm compatible OO CGI interface
libcgi-ssi-parser-perl_0.01-1_all.deb used in CGI scripts for parsing SSI directives
libcgi-ssi-perl_0.92-3_all.deb Perl module to use SSI from CGI scripts
Advertisement
Advertisement