libcgi-emulate-psgi-perl_0.20-1_all.deb


Advertisement

Description

libcgi-emulate-psgi-perl - PSGI adapter for CGI

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcgi-emulate-psgi-perl
Package version: 0.20
Package release: 1
Package architecture: all
Package type: deb
Installed size: 63 B
Download size: 11.53 KB
Official Mirror: ftp.br.debian.org
This module allows an application designed for the CGI environment to run in a PSGI environment, and thus on any of the backends that PSGI supports. It works by translating the environment provided by the PSGI specification to one expected by the CGI specification. Likewise, it captures output as it would be prepared for the CGI standard, and translates it to the format expected for the PSGI standard using CGI::Parse::PSGI module.

Alternatives

    Download

    Source package: libcgi-emulate-psgi-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcgi-emulate-psgi-perl deb package:
      # sudo apt-get install libcgi-emulate-psgi-perl

    Files

    • /usr/share/doc/libcgi-emulate-psgi-perl/changelog.Debian.gz
    • /usr/share/doc/libcgi-emulate-psgi-perl/changelog.gz
    • /usr/share/doc/libcgi-emulate-psgi-perl/copyright
    • /usr/share/man/man3/CGI::Emulate::PSGI.3pm.gz
    • /usr/share/man/man3/CGI::Parse::PSGI.3pm.gz
    • /usr/share/perl5/CGI/Emulate/PSGI.pm
    • /usr/share/perl5/CGI/Parse/PSGI.pm

    Changelog

    2014-10-05 - Dominic Hargreaves <dom@earth.li> libcgi-emulate-psgi-perl (0.20-1) unstable; urgency=medium * Package now maintained by the Debian Perl Group * Update debian/watch to use metacpan URL * New upstream release - update dependencies * Update Standards-Version (no changes) * Don't install duplicate README content in /usr/share/doc

    2013-04-20 - Dominic Hargreaves <dom@earth.li> libcgi-emulate-psgi-perl (0.15-1) unstable; urgency=low * Switch to dpkg-source 3.0 (quilt) format * New upstream release

    2012-03-18 - Dominic Hargreaves <dom@earth.li> libcgi-emulate-psgi-perl (0.14-1) unstable; urgency=low * New upstream release * Switch to debhelper compat level 8 * Update debian/copyright to 1.0 format * Update Standards-Version (no changes)

    2011-08-29 - Dominic Hargreaves <dom@earth.li> libcgi-emulate-psgi-perl (0.12-1) unstable; urgency=low * New upstream release * Update Standards-Version (no changes)

    2010-12-30 - Dominic Hargreaves <dom@earth.li> libcgi-emulate-psgi-perl (0.10-1) unstable; urgency=low * Initial Release. (Closes: #608299)

    Advertisement
    Advertisement