libcgi-application-plugin-tt-perl_1.05-2_all.deb


Advertisement

Description

libcgi-application-plugin-tt-perl - plugin that adds Template Toolkit support to CGI::Application

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcgi-application-plugin-tt-perl
Package version: 1.05
Package release: 2
Package architecture: all
Package type: deb
Installed size: 124 B
Download size: 26.56 KB
Official Mirror: ftp.br.debian.org
CGI::Application::Plugin::TT adds support for the popular Template Toolkit engine to your CGI::Application modules by providing several helper methods that allow you to process template files from within your runmodes. It compliments the support for HTML::Template that is built into CGI::Application through the 'load_tmpl' method. This package also bundles in the CGI::Application::Plugin::TT::LastModified module, which adds support for setting a "Last-Modified" header based on the most recent modification time of all the components of a template that was processed with TT.

Provides

  • libcgi-application-plugin-tt-lastmodified-perl

Replaces

  • libcgi-application-extra-plugin-bundle-perl << 0.3

    Download

    Source package: libcgi-application-plugin-tt-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcgi-application-plugin-tt-perl deb package:
      # sudo apt-get install libcgi-application-plugin-tt-perl

    Files

    • /usr/share/doc/libcgi-application-plugin-tt-perl/changelog.Debian.gz
    • /usr/share/doc/libcgi-application-plugin-tt-perl/changelog.gz
    • /usr/share/doc/libcgi-application-plugin-tt-perl/copyright
    • /usr/share/doc/libcgi-application-plugin-tt-perl/lastmodified/Changes
    • /usr/share/man/man3/CGI::Application::Plugin::TT.3pm.gz
    • /usr/share/man/man3/CGI::Application::Plugin::TT::LastModified.3pm.gz
    • /usr/share/perl5/CGI/Application/Plugin/TT.pm
    • /usr/share/perl5/CGI/Application/Plugin/TT/LastModified.pm

    Changelog

    2011-06-08 - gregor herrmann <gregoa@debian.org> libcgi-application-plugin-tt-perl (1.05-2) unstable; urgency=low * Team upload. * Switch order of alternative (build) dependencies after the perl 5.12 upload. Closes: #629745. * Set Standards-Version to 3.9.2 (no changes).

    2010-12-20 - Nicholas Bamber <nicholas@periapt.co.uk> libcgi-application-plugin-tt-perl (1.05-1) unstable; urgency=low * Initial Release. (Closes: #606511)

    Advertisement
    Advertisement