libcgi-application-plugin-session-perl_1.05-1_all.deb


Advertisement

Description

libcgi-application-plugin-session-perl - plugin that adds session support to CGI::Application

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcgi-application-plugin-session-perl
Package version: 1.05
Package release: 1
Package architecture: all
Package type: deb
Installed size: 77 B
Download size: 15.60 KB
Official Mirror: ftp.br.debian.org
CGI::Application::Plugin::Session seamlessly adds session support to your CGI::Application modules, by providing a CGI::Session object that is accessible from anywhere in the application. Lazy loading is used to prevent expensive file system or database calls from being made if the session is not needed during this request.

Replaces

  • libcgi-application-basic-plugin-bundle-perl << 0.6
  • libcgi-application-plugins-perl << 0.11

    Download

    Source package: libcgi-application-plugin-session-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcgi-application-plugin-session-perl deb package:
      # sudo apt-get install libcgi-application-plugin-session-perl

    Files

    • /usr/share/doc/libcgi-application-plugin-session-perl/changelog.Debian.gz
    • /usr/share/doc/libcgi-application-plugin-session-perl/changelog.gz
    • /usr/share/doc/libcgi-application-plugin-session-perl/copyright
    • /usr/share/man/man3/CGI::Application::Plugin::Session.3pm.gz
    • /usr/share/perl5/CGI/Application/Plugin/Session.pm

    Changelog

    2013-12-27 - gregor herrmann <gregoa@debian.org> libcgi-application-plugin-session-perl (1.05-1) unstable; urgency=medium * Team upload. * New upstream release. * Update build dependencies.

    2013-11-24 - gregor herrmann <gregoa@debian.org> libcgi-application-plugin-session-perl (1.04-1) unstable; urgency=low * Team upload. * New upstream release. * Drop hash-ordering.patch, fixed upstream. * Update years of upstream copyright. * Drop unneeded build dependencies. * Make (build) dependency on libcgi-session-perl versioned. * Declare compliance with Debian Policy 3.9.5.

    2013-08-08 - gregor herrmann <gregoa@debian.org> libcgi-application-plugin-session-perl (1.03-2) unstable; urgency=low * Team upload. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Add patch to fix test failure on perl 5.18 caused by hash ordering, patch taken from upstream pull request. (Closes: #709679) * debian/copyright: switch formatting to Copyright-Format 1.0. * Declare compliance with Debian Policy 3.9.4.

    2011-06-24 - Nicholas Bamber <nicholas@periapt.co.uk> libcgi-application-plugin-session-perl (1.03-1) unstable; urgency=low * Split out from libcgi-application-basic-plugin-bundle-perl (Closes: #630916)

    Advertisement
    Advertisement