libcgi-application-plugin-dbh-perl_4.04-1_all.deb


Advertisement

Description

libcgi-application-plugin-dbh-perl - plugin adding database support to CGI::Application

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcgi-application-plugin-dbh-perl
Package version: 4.04
Package release: 1
Package architecture: all
Package type: deb
Installed size: 64 B
Download size: 10.04 KB
Official Mirror: ftp.br.debian.org
CGI::Application::Plugin::DBH adds access to a DBI database handle to your CGI::Application modules. Lazy loading is used to prevent a database connection from being made if the dbh method is not called during the request. In other words, the database connection is not created until it is actually needed.

Replaces

  • libcgi-application-basic-plugin-bundle-perl << 0.6
  • libcgi-application-plugins-perl << 0.11

    Download

    Source package: libcgi-application-plugin-dbh-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcgi-application-plugin-dbh-perl deb package:
      # sudo apt-get install libcgi-application-plugin-dbh-perl

    Files

    • /usr/share/doc/libcgi-application-plugin-dbh-perl/changelog.Debian.gz
    • /usr/share/doc/libcgi-application-plugin-dbh-perl/changelog.gz
    • /usr/share/doc/libcgi-application-plugin-dbh-perl/copyright
    • /usr/share/man/man3/CGI::Application::Plugin::DBH.3pm.gz
    • /usr/share/perl5/CGI/Application/Plugin/DBH.pm

    Changelog

    2013-11-26 - Florian Schlichting <fsfs@debian.org> libcgi-application-plugin-dbh-perl (4.04-1) unstable; urgency=low * Import Upstream version 4.03, 4.04 * Update upstream copyright (year and email address) * Drop build-dependencies on Module::Build and Test::Pod; add (bump) Test::More 1.001002 * Declare compliance with Debian Policy 3.9.5

    2013-10-05 - Florian Schlichting <fsfs@debian.org> libcgi-application-plugin-dbh-perl (4.01-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Axel Beckert ] * debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg- copyright" [ Florian Schlichting ] * Import Upstream version 4.01 * Update upstream copyright statement * Add build-dependencies on Module::Build 0.40 and Test::MockObject 1.20120301, wrapping dependencies * Declare compliance with Debian Policy 3.9.4 * Add myself to uploaders and copyright

    2011-06-24 - Nicholas Bamber <nicholas@periapt.co.uk> libcgi-application-plugin-dbh-perl (4.00-1) unstable; urgency=low * Split out from libcgi-application-basic-plugin-bundle-perl (Closes: #630886)

    Advertisement
    Advertisement