libcgi-application-plugin-config-simple-perl_1.01-1_all.deb


Advertisement

Description

libcgi-application-plugin-config-simple-perl - module providing Config::Simple support to CGI::Application

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libcgi-application-plugin-config-simple-perl
Package version 1.01
Package release 1
Package architecture all
Package type deb
Installed size 68 B
Download size 9.38 KB
Official Mirror ftp.br.debian.org
CGI::Application::Plugin::Config::Simple acts as a plugin for Config::Simple
to be easily used inside a CGI::Application module. It does not provide
every method available from Config::Simple but rather easy access to your
configuration variables. It does however provide direct access to the
underlying Config::General object created if you want to use it's full power.

Alternatives

Package Version Architecture Repository
libcgi-application-plugin-config-simple-perl_1.01-1_all.deb 1.01 all Debian Main
libcgi-application-plugin-config-simple-perl - - -

Requires

Name Value
libcgi-application-perl -
libconfig-simple-perl -
perl -

Replaces

Name Value
libcgi-application-extra-plugin-bundle-perl << 0.5

Download

Type URL
Binary Package libcgi-application-plugin-config-simple-perl_1.01-1_all.deb
Source Package libcgi-application-plugin-config-simple-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcgi-application-plugin-config-simple-perl deb package:
    # sudo apt-get install libcgi-application-plugin-config-simple-perl

Files

Path
/usr/share/doc/libcgi-application-plugin-config-simple-perl/changelog.Debian.gz
/usr/share/doc/libcgi-application-plugin-config-simple-perl/changelog.gz
/usr/share/doc/libcgi-application-plugin-config-simple-perl/copyright
/usr/share/man/man3/CGI::Application::Plugin::Config::Simple.3pm.gz
/usr/share/perl5/CGI/Application/Plugin/Config/Simple.pm

Changelog

2011-11-10 - Nicholas Bamber <nicholas@periapt.co.uk>
libcgi-application-plugin-config-simple-perl (1.01-1) unstable; urgency=low
* Split off from
libcgi-application-extra-plugin-bundle-perl (Closes: #646850).

See Also

Package Description
libcgi-application-plugin-configauto-perl_1.33-1_all.deb plugin that adds Config::Auto support to CGI::Application
libcgi-application-plugin-dbh-perl_4.04-1_all.deb plugin adding database support to CGI::Application
libcgi-application-plugin-dbiprofile-perl_0.07-1_all.deb plugin providing database profiling support
libcgi-application-plugin-devpopup-perl_1.07-2_all.deb debugging framework for CGI::Application
libcgi-application-plugin-fillinform-perl_1.15-1_all.deb plugin for CGI::Application to fill in forms
libcgi-application-plugin-formstate-perl_0.12-1_all.deb plugin to store form state without hidden fields
libcgi-application-plugin-forward-perl_1.06-1_all.deb plugin to allow one run mode pass control to another
libcgi-application-plugin-json-perl_1.02-1_all.deb plugin to facilitate manipulation of JSON headers
libcgi-application-plugin-linkintegrity-perl_0.06-1_all.deb plugin to make tamper-resisistent links in CGI::Application
libcgi-application-plugin-logdispatch-perl_1.02-1_all.deb plugin that adds Log::Dispatch support to CGI::Application
libcgi-application-plugin-messagestack-perl_0.34-1_all.deb message passing plugin for CGI::Application
libcgi-application-plugin-protectcsrf-perl_1.01-1_all.deb plugin to generate and verify anti-CSRF challenges
libcgi-application-plugin-ratelimit-perl_1.0-2_all.deb Perl module for limiting the runmode call rate per user
libcgi-application-plugin-requiressl-perl_0.04-1_all.deb plugin enforcing that certain run modes must be SSL secured
libcgi-application-plugin-session-perl_1.05-1_all.deb plugin that adds session support to CGI::Application
Advertisement
Advertisement