libcgi-application-plugin-autorunmode-perl_0.18-1_all.deb


Advertisement

Description

libcgi-application-plugin-autorunmode-perl - CGI::App plugin to automatically register runmodes

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcgi-application-plugin-autorunmode-perl
Package version: 0.18
Package release: 1
Package architecture: all
Package type: deb
Installed size: 96 B
Download size: 18.84 KB
Official Mirror: ftp.br.debian.org
The CGI::Application::Plugin::AutoRunmode plugin for CGI::Application provides easy ways to setup run modes. You can just write the method that implements a run mode. You do not have to explicitly register it with CGI::Application anymore. You can either flag methods in your CGI::App subclass with the "Runmode" or "StartRunmode" attributes or simply declare that every method in a class is a run mode. You can also assign a delegate object, all whose methods will become runmodes. You can also mix both approaches.

Replaces

  • libcgi-application-basic-plugin-bundle-perl << 0.6
  • libcgi-application-plugins-perl << 0.11

    Download

    Source package: libcgi-application-plugin-autorunmode-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcgi-application-plugin-autorunmode-perl deb package:
      # sudo apt-get install libcgi-application-plugin-autorunmode-perl

    Files

    • /usr/share/doc/libcgi-application-plugin-autorunmode-perl/changelog.Debian.gz
    • /usr/share/doc/libcgi-application-plugin-autorunmode-perl/changelog.gz
    • /usr/share/doc/libcgi-application-plugin-autorunmode-perl/copyright
    • /usr/share/man/man3/CGI::Application::Plugin::AutoRunmode.3pm.gz
    • /usr/share/man/man3/CGI::Application::Plugin::AutoRunmode::FileDelegate.3pm.gz
    • /usr/share/perl5/CGI/Application/Plugin/AutoRunmode.pm
    • /usr/share/perl5/CGI/Application/Plugin/AutoRunmode/FileDelegate.pm

    Changelog

    2011-06-24 - Nicholas Bamber <nicholas@periapt.co.uk> libcgi-application-plugin-autorunmode-perl (0.18-1) unstable; urgency=low * Split out from libcgi-application-basic-plugin-bundle-perl (Closes: #630870)

    Advertisement
    Advertisement