libcgi-application-dispatch-perl_3.12-1_all.deb


Advertisement

Description

libcgi-application-dispatch-perl - request dispatcher for CGI::Application

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcgi-application-dispatch-perl
Package version: 3.12
Package release: 1
Package architecture: all
Package type: deb
Installed size: 153 B
Download size: 54.23 KB
Official Mirror: ftp.br.debian.org
CGI::Application::Dispatch provides glue between web server environments such as mod_perl, Plack and straight CGI and the CGI::Application web framework. It does this by parsing the PATH_INFO environment variable and mapping it onto a CGI::Application subclass module invocation with the appropriate run mode and CGI::Application parameters.

Replaces

  • libcgi-application-basic-plugin-bundle-perl << 0.6
  • libcgi-application-plugins-perl << 0.11

    Download

    Source package: libcgi-application-dispatch-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcgi-application-dispatch-perl deb package:
      # sudo apt-get install libcgi-application-dispatch-perl

    Files

    • /usr/share/doc/libcgi-application-dispatch-perl/changelog.Debian.gz
    • /usr/share/doc/libcgi-application-dispatch-perl/changelog.gz
    • /usr/share/doc/libcgi-application-dispatch-perl/copyright
    • /usr/share/man/man3/CGI::Application::Dispatch.3pm.gz
    • /usr/share/man/man3/CGI::Application::Dispatch::PSGI.3pm.gz
    • /usr/share/man/man3/CGI::Application::Dispatch::Regexp.3pm.gz
    • /usr/share/perl5/CGI/Application/Dispatch.pm
    • /usr/share/perl5/CGI/Application/Dispatch/PSGI.pm
    • /usr/share/perl5/CGI/Application/Dispatch/Regexp.pm

    Changelog

    2012-11-04 - Xavier Guimard <x.guimard@free.fr> libcgi-application-dispatch-perl (3.12-1) unstable; urgency=low [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Xavier Guimard ] * New upstream release * Bump Standards-Version to 3.9.4 * Use debhelper 8 * Update debian/copyright to format 1.0 * Remove deprecation.patch now included in upstream * Remove obsolete lintian-overrides

    2011-11-26 - Nicholas Bamber <nicholas@periapt.co.uk> libcgi-application-dispatch-perl (3.07-2) unstable; urgency=low [ gregor herrmann ] * Remove version from libversion-perl (build) dependency. [ Nicholas Bamber ] * Added patch fixing 5.14 deprecation of qw(..) without enclosing parentheses where those parentheses are part of statement syntax * Added lintian override concerning DEP-5

    2011-09-09 - Nicholas Bamber <nicholas@periapt.co.uk> libcgi-application-dispatch-perl (3.07-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * debian/copyright: Replace DEP5 Format-Specification URL from svn.debian.org to anonscm.debian.org URL. [ Nicholas Bamber ] * New upstream release * Removed dependency on Exception::Class::TryCatch

    2011-06-29 - Nicholas Bamber <nicholas@periapt.co.uk> libcgi-application-dispatch-perl (3.04-1) unstable; urgency=low * Split out from libcgi-application-basic-plugin-bundle-perl (Closes: #630878)

    Advertisement
    Advertisement