libcatalyst-plugin-static-simple-perl_0.32-1_all.deb


Advertisement

Description

libcatalyst-plugin-static-simple-perl - Catalyst plugin for easy serving of static pages

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcatalyst-plugin-static-simple-perl
Package version: 0.32
Package release: 1
Package architecture: all
Package type: deb
Installed size: 80 B
Download size: 18.58 KB
Official Mirror: ftp.br.debian.org
Catalyst::Plugin::Static::Simple is designed to make serving static content in your application during development quick and easy, without requiring a single line of code from you. This plugin detects static files by looking at the file extension in the URL (such as .css or .png or .js). The plugin uses the lightweight MIME::Types module to map file extensions to IANA-registered MIME types, and will serve your static files with the correct MIME type directly to the browser, without being processed through Catalyst. Catalyst is an elegant Model-View-Controller web application framework written in Perl.

Replaces

  • libcatalyst-modules-perl << 48~

    Download

    Source package: libcatalyst-plugin-static-simple-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcatalyst-plugin-static-simple-perl deb package:
      # sudo apt-get install libcatalyst-plugin-static-simple-perl

    Files

    • /usr/share/doc/libcatalyst-plugin-static-simple-perl/changelog.Debian.gz
    • /usr/share/doc/libcatalyst-plugin-static-simple-perl/changelog.gz
    • /usr/share/doc/libcatalyst-plugin-static-simple-perl/copyright
    • /usr/share/man/man3/Catalyst::Plugin::Static::Simple.3pm.gz
    • /usr/share/perl5/Catalyst/Plugin/Static/Simple.pm

    Changelog

    2014-06-06 - gregor herrmann <gregoa@debian.org> libcatalyst-plugin-static-simple-perl (0.32-1) unstable; urgency=medium * Team upload. * New upstream release. * Add upstream copyright years. * Remove unneeded version from libcatalyst-perl (build) dependency.

    2014-05-15 - Damyan Ivanov <dmn@debian.org> libcatalyst-plugin-static-simple-perl (0.31-2) unstable; urgency=medium * fix version of broken/replaces libcatalyst-modules-perl

    2014-05-14 - Damyan Ivanov <dmn@debian.org> libcatalyst-plugin-static-simple-perl (0.31-1) unstable; urgency=low * Initial Release. Spin-off from libcatalyst-modules-perl, where it was bundled.

    Advertisement
    Advertisement