libcatalyst-plugin-authorization-roles-perl_0.09-2_all.deb


Advertisement

Description

libcatalyst-plugin-authorization-roles-perl - Role based authorization plugin for Catalyst

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcatalyst-plugin-authorization-roles-perl
Package version: 0.09
Package release: 2
Package architecture: all
Package type: deb
Installed size: 13 B
Download size: 8.08 KB
Official Mirror: ftp.br.debian.org
Catalyst::Plugin::Authorization::Roles provides role-based authorization (access control) for Catalyst applications. Role based access control is very simple: every user has a list of roles, which that user is allowed to assume, and every restricted part of the app makes an assertion about the necessary roles. With assert_user_roles, if the user is a member in all of the required roles access is granted. Otherwise, access is denied. With assert_any_user_role it is enough that the user is a member of one role. There are alternative approaches to do this on a per action basis, see Catalyst::ActionRole::ACL. Catalyst is an elegant Model-View-Controller web application framework written in Perl.

Replaces

  • libcatalyst-modules-perl << 48~

    Download

    Source package: libcatalyst-plugin-authorization-roles-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcatalyst-plugin-authorization-roles-perl deb package:
      # sudo apt-get install libcatalyst-plugin-authorization-roles-perl

    Files

    • /usr/share/doc/libcatalyst-plugin-authorization-roles-perl/changelog.Debian.gz
    • /usr/share/doc/libcatalyst-plugin-authorization-roles-perl/changelog.gz
    • /usr/share/doc/libcatalyst-plugin-authorization-roles-perl/copyright
    • /usr/share/man/man3/Catalyst::Plugin::Authorization::Roles.3pm.gz
    • /usr/share/perl5/Catalyst/Plugin/Authorization/Roles.pm

    Changelog

    2014-05-15 - Damyan Ivanov <dmn@debian.org> libcatalyst-plugin-authorization-roles-perl (0.09-2) unstable; urgency=medium * fix version of broken/replaces libcatalyst-modules-perl

    2014-05-14 - Damyan Ivanov <dmn@debian.org> libcatalyst-plugin-authorization-roles-perl (0.09-1) unstable; urgency=low * Initial Release. Spin-off from libcatalyst-modules-perl, where it was bundled.

    Advertisement
    Advertisement