libcatalyst-perl_5.90075-2_all.deb


Advertisement

Description

libcatalyst-perl - elegant Model-View-Controller Web Application Framework

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libcatalyst-perl
Package version 5.90075
Package release 2
Package architecture all
Package type deb
Installed size 668 B
Download size 334.14 KB
Official Mirror ftp.br.debian.org
Catalyst is an elegant web application framework, extremely flexible yet very
simple. It's similar to Ruby on Rails, Spring (Java) and Maypole, upon which
it was originally based.
Catalyst follows the Model-View-Controller (MVC) design pattern, allowing you
to easily separate concerns, like content, presentation, and flow control,
into separate modules. This separation allows you to modify code that handles
one concern without affecting code that handles the others. Catalyst promotes
the re-use of existing Perl modules that already handle common web application
concerns well.
This package only contains the Catalyst::Runtime module. If you want to develop
your own web applications install libcatalyst-modules-perl as well.

Alternatives

Package Version Architecture Repository
libcatalyst-perl_5.90075-2_all.deb 5.90075 all Debian Main
libcatalyst-perl - - -

Requires

Name Value
libcgi-simple-perl -
libcgi-struct-xs-perl -
libclass-accessor-perl -
libclass-c3-adopt-next-perl -
libclass-c3-perl -
libclass-data-inheritable-perl -
libclass-inspector-perl -
libclass-load-perl -
libdata-dump-perl -
libdata-optlist-perl -
libencode-perl >= 2.49
libextutils-autoinstall-perl -
libfile-copy-recursive-perl -
libfile-modified-perl -
libfile-slurp-perl -
libhash-multivalue-perl -
libhtml-parser-perl -
libhttp-body-perl -
libhttp-request-ascgi-perl -
libjson-maybexs-perl -
liblist-moreutils-perl -
libmime-types-perl -
libmodule-pluggable-perl -
libmoose-perl -
libmoosex-emulate-class-accessor-fast-perl -
libmoosex-getopt-perl >= 0.48
libmoosex-methodattributes-perl -
libmoosex-role-withoverloading-perl >= 0.09
libnamespace-autoclean-perl -
libnamespace-clean-perl >= 0.23
libpath-class-perl -
libplack-middleware-fixmissingbodyinredirect-perl -
libplack-middleware-methodoverride-perl -
libplack-middleware-removeredundantbody-perl -
libplack-middleware-reverseproxy-perl -
libplack-perl >= 0.9991
libplack-test-externalserver-perl -
libsafe-isa-perl -
libscope-upper-perl -
libstream-buffered-perl -
libstring-rewriteprefix-perl -
libtask-weaken-perl -
libtest-mockobject-perl -
libtext-simpletable-perl -
libtree-simple-perl -
libtree-simple-visitorfactory-perl -
libtry-tiny-perl >= 0.17
liburi-perl -
libwww-perl >= 5.837
perl >= 5.15.8
perl << 5.17.0
perl >= 5.17.10

Provides

Name Value
libcatalyst-plugin-unicode-encoding-perl -

Conflicts

Name Value
libcatalyst-plugin-unicode-encoding-perl -

Replaces

Name Value
libcatalyst-plugin-unicode-encoding-perl -

Download

Type URL
Binary Package libcatalyst-perl_5.90075-2_all.deb
Source Package libcatalyst-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcatalyst-perl deb package:
    # sudo apt-get install libcatalyst-perl

Files

Path
/usr/bin/catalyst.pl
/usr/share/doc/libcatalyst-perl/NEWS.Debian.gz
/usr/share/doc/libcatalyst-perl/changelog.Debian.gz
/usr/share/doc/libcatalyst-perl/changelog.gz
/usr/share/doc/libcatalyst-perl/copyright
/usr/share/lintian/overrides/libcatalyst-perl
/usr/share/man/man1/catalyst.pl.1p.gz
/usr/share/man/man3/Catalyst.3pm.gz
/usr/share/man/man3/Catalyst::Action.3pm.gz
/usr/share/man/man3/Catalyst::ActionChain.3pm.gz
/usr/share/man/man3/Catalyst::ActionContainer.3pm.gz
/usr/share/man/man3/Catalyst::ActionRole::ConsumesContent.3pm.gz
/usr/share/man/man3/Catalyst::ActionRole::HTTPMethods.3pm.gz
/usr/share/man/man3/Catalyst::Base.3pm.gz
/usr/share/man/man3/Catalyst::ClassData.3pm.gz
/usr/share/man/man3/Catalyst::Component.3pm.gz
/usr/share/man/man3/Catalyst::Component::ApplicationAttribute.3pm.gz
/usr/share/man/man3/Catalyst::Component::ContextClosure.3pm.gz
/usr/share/man/man3/Catalyst::Controller.3pm.gz
/usr/share/man/man3/Catalyst::Delta.3pm.gz
/usr/share/man/man3/Catalyst::DispatchType.3pm.gz
/usr/share/man/man3/Catalyst::DispatchType::Chained.3pm.gz
/usr/share/man/man3/Catalyst::DispatchType::Default.3pm.gz
/usr/share/man/man3/Catalyst::DispatchType::Index.3pm.gz
/usr/share/man/man3/Catalyst::DispatchType::Path.3pm.gz
/usr/share/man/man3/Catalyst::Dispatcher.3pm.gz
/usr/share/man/man3/Catalyst::Engine.3pm.gz
/usr/share/man/man3/Catalyst::Engine::HTTP.3pm.gz
/usr/share/man/man3/Catalyst::EngineLoader.3pm.gz
/usr/share/man/man3/Catalyst::Exception.3pm.gz
/usr/share/man/man3/Catalyst::Exception::Basic.3pm.gz
/usr/share/man/man3/Catalyst::Exception::Detach.3pm.gz
/usr/share/man/man3/Catalyst::Exception::Go.3pm.gz
/usr/share/man/man3/Catalyst::Exception::Interface.3pm.gz
/usr/share/man/man3/Catalyst::Log.3pm.gz
/usr/share/man/man3/Catalyst::Middleware::Stash.3pm.gz
/usr/share/man/man3/Catalyst::Model.3pm.gz
/usr/share/man/man3/Catalyst::PSGI.3pm.gz
/usr/share/man/man3/Catalyst::Plugin::Unicode::Encoding.3pm.gz
/usr/share/man/man3/Catalyst::Request.3pm.gz
/usr/share/man/man3/Catalyst::Request::Upload.3pm.gz
/usr/share/man/man3/Catalyst::Response.3pm.gz
/usr/share/man/man3/Catalyst::Runtime.3pm.gz
/usr/share/man/man3/Catalyst::Script::CGI.3pm.gz
/usr/share/man/man3/Catalyst::Script::Create.3pm.gz
/usr/share/man/man3/Catalyst::Script::FastCGI.3pm.gz
/usr/share/man/man3/Catalyst::Script::Server.3pm.gz
/usr/share/man/man3/Catalyst::Script::Test.3pm.gz
/usr/share/man/man3/Catalyst::ScriptRole.3pm.gz
/usr/share/man/man3/Catalyst::ScriptRunner.3pm.gz
/usr/share/man/man3/Catalyst::Stats.3pm.gz
/usr/share/man/man3/Catalyst::Test.3pm.gz
/usr/share/man/man3/Catalyst::Upgrading.3pm.gz
/usr/share/man/man3/Catalyst::Utils.3pm.gz
/usr/share/man/man3/Catalyst::View.3pm.gz
/usr/share/perl5/Catalyst.pm
/usr/share/perl5/Catalyst/Action.pm
/usr/share/perl5/Catalyst/ActionChain.pm
/usr/share/perl5/Catalyst/ActionContainer.pm
/usr/share/perl5/Catalyst/Base.pm
/usr/share/perl5/Catalyst/ClassData.pm
/usr/share/perl5/Catalyst/Component.pm
/usr/share/perl5/Catalyst/Controller.pm
/usr/share/perl5/Catalyst/Delta.pod
/usr/share/perl5/Catalyst/DispatchType.pm
/usr/share/perl5/Catalyst/Dispatcher.pm
/usr/share/perl5/Catalyst/Engine.pm
/usr/share/perl5/Catalyst/EngineLoader.pm
/usr/share/perl5/Catalyst/Exception.pm
/usr/share/perl5/Catalyst/Log.pm
/usr/share/perl5/Catalyst/Model.pm
/usr/share/perl5/Catalyst/PSGI.pod
/usr/share/perl5/Catalyst/Request.pm
/usr/share/perl5/Catalyst/Response.pm
/usr/share/perl5/Catalyst/Runtime.pm
/usr/share/perl5/Catalyst/ScriptRole.pm
/usr/share/perl5/Catalyst/ScriptRunner.pm
/usr/share/perl5/Catalyst/Stats.pm
/usr/share/perl5/Catalyst/Test.pm
/usr/share/perl5/Catalyst/Upgrading.pod
/usr/share/perl5/Catalyst/Utils.pm
/usr/share/perl5/Catalyst/View.pm
/usr/share/perl5/Catalyst/ActionRole/ConsumesContent.pm
/usr/share/perl5/Catalyst/ActionRole/HTTPMethods.pm
/usr/share/perl5/Catalyst/Component/ApplicationAttribute.pm
/usr/share/perl5/Catalyst/Component/ContextClosure.pm
/usr/share/perl5/Catalyst/DispatchType/Chained.pm
/usr/share/perl5/Catalyst/DispatchType/Default.pm
/usr/share/perl5/Catalyst/DispatchType/Index.pm
/usr/share/perl5/Catalyst/DispatchType/Path.pm
/usr/share/perl5/Catalyst/Engine/HTTP.pm
/usr/share/perl5/Catalyst/Exception/Basic.pm
/usr/share/perl5/Catalyst/Exception/Detach.pm
/usr/share/perl5/Catalyst/Exception/Go.pm
/usr/share/perl5/Catalyst/Exception/Interface.pm
/usr/share/perl5/Catalyst/Middleware/Stash.pm
/usr/share/perl5/Catalyst/Plugin/Unicode/Encoding.pm
/usr/share/perl5/Catalyst/Request/Upload.pm
/usr/share/perl5/Catalyst/Script/CGI.pm
/usr/share/perl5/Catalyst/Script/Create.pm
/usr/share/perl5/Catalyst/Script/FastCGI.pm
/usr/share/perl5/Catalyst/Script/Server.pm
/usr/share/perl5/Catalyst/Script/Test.pm

Changelog

2014-11-12 - Damyan Ivanov <dmn@debian.org>
libcatalyst-perl (5.90075-2) unstable; urgency=medium
* Team upload
* Remove obsolete build-dependency on libcatalyst-engine-psgi-perl
This allows for libcatalyst-engine-psgi-perl to be removed from the
archive. (Closes: #769093)
Thanks to Simon McVittie
2014-10-08 - gregor herrmann <gregoa@debian.org>
libcatalyst-perl (5.90075-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Imported upstream version 5.90075
* (Build-) depend on perl 5.15.8 to get Carp 1.25.
* Declare compliance with Debian Policy 3.9.6.
2014-08-13 - Damyan Ivanov <dmn@debian.org>
libcatalyst-perl (5.90071-1) unstable; urgency=medium
* Team Upload
* Imported Upstream version 5.90071
* add a patch fixing NAME section of Catalyst::Middleware::Stash POD
2014-06-06 - gregor herrmann <gregoa@debian.org>
libcatalyst-perl (5.90065-1) unstable; urgency=medium
* New upstream release.
* Add new upstream copyright holder to debian/copyright.
2014-05-11 - gregor herrmann <gregoa@debian.org>
libcatalyst-perl (5.90064-1) unstable; urgency=medium
* New upstream release.
* Update years of packaging copyright.
2014-05-01 - Florian Schlichting <fsfs@debian.org>
libcatalyst-perl (5.90062-1) unstable; urgency=medium
[ gregor herrmann ]
* Drop xz compression for {binary,source} package, set by default by
dpkg since 1.17.{0,6}.
* Strip trailing slash from metacpan URLs.
[ Florian Schlichting ]
* Import Upstream version 5.90062
* Update list of upstream contributors, bump copyright years
* Add (build-)dependencies on newly required plack middlewares
2013-12-23 - Florian Schlichting <fsfs@debian.org>
libcatalyst-perl (5.90053-1) unstable; urgency=low
* Import Upstream versions 5.90051, 5.90053
* Drop fix-whatis-entry.patch, applied upstream
* Update upstream (build-)dependencies
* Swap the order of the Encode dependency alternatives
* Drop versions on dependencies satisfied in oldstable
* Declare compliance with Debian Policy 3.9.5
2013-08-11 - Florian Schlichting <fsfs@debian.org>
libcatalyst-perl (5.90042-2) unstable; urgency=low
* Conflict/Provide/Replace libcatalyst-plugin-unicode-encoding-perl, whose
module and manpage we're taking over (Closes: #719430).
2013-08-08 - Florian Schlichting <fsfs@debian.org>
libcatalyst-perl (5.90042-1) unstable; urgency=low
* Imported Upstream version 5.90042.
* Updated list of upstream copyright holders.
* Updated (build-)dependencies.
* Added fix-whatis-entry.patch.
2013-07-01 - gregor herrmann <gregoa@debian.org>
libcatalyst-perl (5.90030-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Move libcatalyst-devel-perl and libfcgi-perl from Recommends to
Suggests. The former is only needed for development, the second is
more or less obsolete with PSGI. Thanks to Jonas Smedegaard for the
bug report. (Closes: #705229)
[ Florian Schlichting ]
* Import Upstream version 5.90030.
* Email change: Florian Schlichting -> fsfs@debian.org
* Bump Standards-Version to 3.9.4 (no change)
* Refresh d/copyright: new upstream contributor, years
* Add/remove (build-)dependencies
* Add NEWS entry on breaking changes
[ gregor herrmann ]
* This release also fixes "FTBFS: tests failed" (closes: #713243).

See Also

Package Description
libcatalyst-plugin-authentication-credential-openid-perl_0.03+rp-2_all.deb OpenID credential for Catalyst::Auth framework
libcatalyst-plugin-authentication-perl_0.10023-2_all.deb Infrastructure plugin for the Catalyst authentication framework
libcatalyst-plugin-authorization-acl-perl_0.16-1_all.deb ACL support for Catalyst applications
libcatalyst-plugin-authorization-roles-perl_0.09-2_all.deb Role based authorization plugin for Catalyst
libcatalyst-plugin-cache-perl_0.12-2_all.deb flexible caching support for Catalyst
libcatalyst-plugin-cache-store-fastmmap-perl_0.02-2_all.deb (deprecated) FastMmap cache store plugin for Catalyst::Plugin::Cache
libcatalyst-plugin-captcha-perl_0.04-2_all.deb create and validate Captcha for Catalyst
libcatalyst-plugin-compress-perl_0.5-1_all.deb Catalyst plugin to compress the response
libcatalyst-plugin-configloader-perl_0.34-2_all.deb Catalyst plugin for loading configuration files
libcatalyst-plugin-customerrormessage-perl_0.6-2_all.deb Catalyst plugin to have more "cute" error message
libcatalyst-plugin-fillinform-perl_0.12-1_all.deb module providing Fill-In-Form for Catalyst
libcatalyst-plugin-i18n-perl_0.10-2_all.deb I18N for Catalyst web application framework
libcatalyst-plugin-log-dispatch-perl_0.121-1_all.deb Catalyst log module that uses Log::Dispatch
libcatalyst-plugin-redirect-perl_0.2-1_all.deb Catalyst plugin for easy redirects
libcatalyst-plugin-scheduler-perl_0.10-1_all.deb Catalyst plugin for scheduling events to run in a cron-like fashion
Advertisement
Advertisement