libcatalyst-model-dbi-perl_0.32-2_all.deb


Advertisement

Description

libcatalyst-model-dbi-perl - Database model class for Catalyst

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcatalyst-model-dbi-perl
Package version: 0.32
Package release: 2
Package architecture: all
Package type: deb
Installed size: 15 B
Download size: 10.58 KB
Official Mirror: ftp.br.debian.org
Catalyst::Model::DBI is the DBI model class for Catalyst. There are two options for doing custom models with Catalyst. Either by using this model and any related modules as needed or by having a custom model decoupled from Catalyst and glued on using Catalyst::Model::Adaptor Some general rules are as follows. If you do not wish to use DBIx::Connector or DBI directly and setup connections in your custom models or have glue models, then use this model. If you however need models that can be re-used outside of your application or simply wish to maintain connection code yourself outside of the Catalyst, then use Catalyst::Model::Adaptor which allows you to glue outside models into your Catalyst app. Catalyst is an elegant Model-View-Controller web application framework written in Perl. DBI is a Perl database interface.

Alternatives

Replaces

  • libcatalyst-modules-perl << 48~

    Download

    Source package: libcatalyst-model-dbi-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcatalyst-model-dbi-perl deb package:
      # sudo apt-get install libcatalyst-model-dbi-perl

    Files

    • /usr/share/doc/libcatalyst-model-dbi-perl/changelog.Debian.gz
    • /usr/share/doc/libcatalyst-model-dbi-perl/changelog.gz
    • /usr/share/doc/libcatalyst-model-dbi-perl/copyright
    • /usr/share/man/man3/Catalyst::Helper::Model::DBI.3pm.gz
    • /usr/share/man/man3/Catalyst::Model::DBI.3pm.gz
    • /usr/share/perl5/Catalyst/Helper/Model/DBI.pm
    • /usr/share/perl5/Catalyst/Model/DBI.pm

    Changelog

    2014-05-15 - Damyan Ivanov <dmn@debian.org> libcatalyst-model-dbi-perl (0.32-2) unstable; urgency=medium * fix version of broken/replaces libcatalyst-modules-perl

    2014-05-14 - Damyan Ivanov <dmn@debian.org> libcatalyst-model-dbi-perl (0.32-1) unstable; urgency=low * Initial Release. Spin-off from libcatalyst-modules-perl, where it was bundled.

    Advertisement
    Advertisement