libbusiness-creditcard-perl_0.35-0+deb8u1_all.deb


Advertisement

Description

libbusiness-creditcard-perl - Perl module to validate or generate credit card checksums and names

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libbusiness-creditcard-perl
Package version: 0.35
Package release: 0+deb8u1
Package architecture: all
Package type: deb
Installed size: 62 B
Download size: 15.94 KB
Official Mirror: ftp.br.debian.org
Business::CreditCard tell you whether a credit card number is self-consistent -- whether the last digit of the number is a valid checksum for the preceding digits. The validate() subroutine returns 1 if the card number provided passes the checksum test, and 0 otherwise. The cardtype() subroutine returns a string containing the type of card: "MasterCard", "VISA", and so on. The generate_last_digit() subroutine computes and returns the last digit of the card given the preceding digits. With a 16-digit card, you provide the first 15 digits; the subroutine returns the sixteenth.

Requires

    Download

    Source package: libbusiness-creditcard-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libbusiness-creditcard-perl deb package:
      # sudo apt-get install libbusiness-creditcard-perl

    Files

    • /usr/share/doc/libbusiness-creditcard-perl/BINS.gz
    • /usr/share/doc/libbusiness-creditcard-perl/changelog.Debian.gz
    • /usr/share/doc/libbusiness-creditcard-perl/changelog.gz
    • /usr/share/doc/libbusiness-creditcard-perl/copyright
    • /usr/share/man/man3/Business::CreditCard.3pm.gz
    • /usr/share/perl5/Business/CreditCard.pm

    Changelog

    2016-07-07 - gregor herrmann <gregoa@debian.org> libbusiness-creditcard-perl (0.35-0+deb8u1) jessie; urgency=medium * Import upstream release 0.35 to adjust to changes in credit card ranges and processing of various companies. (Closes: #814479)

    2014-09-15 - gregor herrmann <gregoa@debian.org> libbusiness-creditcard-perl (0.33-1) unstable; urgency=medium * Team upload. [ gregor herrmann ] * Strip trailing slash from metacpan URLs. [ Salvatore Bonaccorso ] * Update Vcs-Browser URL to cgit web frontend [ gregor herrmann ] * New upstream release. * Update upstream copyright years. * Declare compliance with Debian Policy 3.9.5.

    2013-03-02 - gregor herrmann <gregoa@debian.org> libbusiness-creditcard-perl (0.32-1) unstable; urgency=low * Team upload. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * New upstream release. * Update years of upstream copyright.

    2013-01-07 - Xavier Guimard <x.guimard@free.fr> libbusiness-creditcard-perl (0.31-2) unstable; urgency=low [ Xavier Guimard ] * Take over for the Debian Perl Group on maintainer's request (http://bugs.debian.org/677732#10) * Add debian/watch file * Update source format to 3.0 (quilt) * Update debian/copyright (years and format) * Bump Standards-Version to 3.9.4 * Bump debhelper compatibility to 8 * Update description * Update debian/rules to use "dh $@" [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org)

    2009-10-19 - Ivan Kohler <ivan-debian@420.am> libbusiness-creditcard-perl (0.31-1) unstable; urgency=low * New upstream version

    2006-12-18 - Ivan Kohler <ivan-debian@420.am> libbusiness-creditcard-perl (0.30-1) unstable; urgency=low * New upstream version

    2004-08-07 - Ivan Kohler <ivan-debian@420.am> libbusiness-creditcard-perl (0.28-1) unstable; urgency=low * New upstream version. * Change Section: from interpreters to perl * debhelper compat v4

    2002-09-07 - Ivan Kohler <ivan-debian@420.am> libbusiness-creditcard-perl (0.27-2) unstable; urgency=low * binary-arch vs. binary-indep (closes: Bug#153345) * debian/copyright pedantry (closes: Bug#153370)

    2002-01-20 - Ivan Kohler <ivan-debian@420.am> libbusiness-creditcard-perl (0.27-1) unstable; urgency=low * new "upstream" version

    2001-07-15 - Ivan Kohler <ivan-debian@420.am> libbusiness-creditcard-perl (0.26-2) unstable; urgency=low * Rerun dh-make-perl, update to Standards-Version 3.5.1 (closes: Bug#104755)

    Advertisement
    Advertisement