libbsd-resource-perl_1.2907-1+b2_amd64.deb


Advertisement

Description

libbsd-resource-perl - BSD process resource limit and priority functions

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libbsd-resource-perl
Package version 1.2907
Package release 1+b2
Package architecture amd64
Package type deb
Installed size 134 B
Download size 32.37 KB
Official Mirror ftp.br.debian.org
The BSD::Resource module provides the BSD process resource limit functions
getrusage(), getrlimit(), setrlimit() and the BSD process priority functions.
These are also available via core Perl but here the PRIO_* constants are
available: getpriority(), setpriority().
Also provided is times() which provides the same functionality as the one
in core Perl, only with better time resolution.

Alternatives

Package Version Architecture Repository
libbsd-resource-perl_1.2907-1+b2_i386.deb 1.2907 i386 Debian Main
libbsd-resource-perl - - -

Requires

Name Value
libc6 >= 2.4
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libbsd-resource-perl_1.2907-1+b2_amd64.deb
Source Package libbsd-resource-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libbsd-resource-perl deb package:
    # sudo apt-get install libbsd-resource-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/BSD/Resource.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/Resource.so
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/_find_prio.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/_find_rlimit.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/_g.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/autosplit.ix
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/get_prios.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/get_rlimits.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/getpriority.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/getrlimit.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/getrusage.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/hard.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/idrss.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/inblock.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/isrss.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/ixrss.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/majflt.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/maxrss.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/minflt.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/msgrcv.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/msgsnd.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/nivcsw.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/nsignals.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/nswap.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/nvcsw.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/oublock.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/setpriority.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/setrlimit.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/soft.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/stime.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/times.al
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/BSD/Resource/utime.al
/usr/share/doc/libbsd-resource-perl/README
/usr/share/doc/libbsd-resource-perl/changelog.Debian.amd64.gz
/usr/share/doc/libbsd-resource-perl/changelog.Debian.gz
/usr/share/doc/libbsd-resource-perl/changelog.gz
/usr/share/doc/libbsd-resource-perl/copyright
/usr/share/man/man3/BSD::Resource.3pm.gz

Changelog

2013-07-15 - Salvatore Bonaccorso <carnil@debian.org>
libbsd-resource-perl (1.2907-1) unstable; urgency=low
* Imported Upstream version 1.2907
2013-06-28 - Salvatore Bonaccorso <carnil@debian.org>
libbsd-resource-perl (1.2905-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Email change: Salvatore Bonaccorso -> carnil@debian.org
[ Ansgar Burchardt ]
* Email change: Ansgar Burchardt -> ansgar@debian.org
* debian/control: Convert Vcs-* fields to Git.
[ Fabrizio Regalli ]
* Update d/compat to 8
* Update debhelper to (>= 8)
[ Jonathan Steinert ]
* Add myself to Uploaders.
* Change package priority to optional (was extra)
[ Salvatore Bonaccorso ]
* Imported Upstream version 1.2905
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
* Update debian/copyright file information.
Update format to copyright-format 1.0 as released together with Debian
policy 3.9.3.
Update copyright years for debian/* packaging files.
Refer to Debian systems in general instead of only Debian GNU/Linux
systems.
Explicitly refert to GPL-1 license text in common-licenses.
* Convert package to '3.0 (quilt)' source package format
* Update copyright stanza for ppport.h
* Adjust upstream copyright information.
Update copyright years for upstream files.
Upstrem clarified the license to be Artistic-2.0 or LGPL-2. Add stanzas
for LGPL-2 and Artistic-2.0 and correct License field in upstream's
stanza.
* Bump Standards-Version to 3.9.4
* Update Debhelper compat level to 9.
Adjust versioned Build-Depends on debhelper to (>= 9.20120312) to get
all hardening flags passed correctly for the build.
2010-03-17 - Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>
libbsd-resource-perl (1.2904-1) unstable; urgency=low
* New upstream release
* Refresh debian/copyright: Add myself to debian/copyright and update
copyright years for holder. 
* Add myself to Uploaders. 
2010-01-30 - gregor herrmann <gregoa@debian.org>
libbsd-resource-perl (1.2903-3) unstable; urgency=low
* debian/rules: don't run the tests that randomly fail; note that upstream
writes in INSTALL: "... known to be tricky and to fail once in a while.
This is because the results depend on timing issues and the activity of
the operating system, it is moderately icky to guestimate such tolerances
that leave some slack while still proving anything." (closes: #560643).
* Set Standards-Version to 3.8.4 (no changes).
* Remove version from perl build dependency.
* debian/copyright: update formatting.
2009-12-29 - Damyan Ivanov <dmn@debian.org>
libbsd-resource-perl (1.2903-2) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Damyan Ivanov ]
* rules: convert to a 3-liner
* rules: when testing, use verbose output to help diagnose #560643 (FTBFS)
* add myself to Uploaders
* Standards-Version: 3.8.3 (no changes necessary)
2009-04-05 - Franck Joncourt <franck.mail@dthconnex.com>
libbsd-resource-perl (1.2903-1) unstable; urgency=low
* New upstream release
* Add /me to Uploaders.
* Bumped up Standards-Version to 3.8.1 (no changes).
* Updated long description to make lintian happy due to the use of
the first person pronoun.
2009-01-01 - gregor herrmann <gregoa@debian.org>
libbsd-resource-perl (1.2902-1) unstable; urgency=low
[ Ansgar Burchardt ]
* Fix typo in debian/copyright.
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* New upstream release.
* debian/copyright: update packaging copyright.
* Add /me to Uploaders.

See Also

Package Description
libbsd0_0.7.0-2_amd64.deb utility functions from BSD systems - shared library
libbsearch-ruby1.8_1.5-9_all.deb Transitional package for ruby-bsearch
libbsearch-ruby_1.5-9_all.deb Transitional package for ruby-bsearch
libbsf-java-doc_2.4.0-5_all.deb Bean Scripting Framework to support scripting - documentation
libbsf-java_2.4.0-5_all.deb Bean Scripting Framework to support scripting languages in Java
libbsh-java_2.0b4-15+deb8u1_all.deb Java scripting environment (BeanShell) Version 2 (library)
libbssolv-perl_0.02-1_amd64.deb compute package dependencies (for Open Build Service backend)
libbt-dev_0.70.1-23+deb8u1_amd64.deb Blackbox - development library
libbt0_0.70.1-23+deb8u1_amd64.deb Blackbox - shared library
libbtf1.2.0_4.2.1-3_amd64.deb permutation to block triangular form library for sparse matrices
libbtm-java_2.1.4-2_all.deb Bitronix JTA Transaction Manager
libbtparse-dev_0.69-1+b1_amd64.deb C library to parse BibTeX files - development files
libbtparse1_0.69-1+b1_amd64.deb C library to parse BibTeX files
libbuffy-dev_1.9.2-2_amd64.deb Base functions for building mailbox summary applications
libbuffy-perl_0.16_amd64.deb Perl wrapper for the libbuffy library
Advertisement
Advertisement