libboost-iostreams-dev_1.55.0.2_amd64.deb


Advertisement

Description

libboost-iostreams-dev - Boost.Iostreams Library development files (default version)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libboost-iostreams-dev
Package version 1.55.0.2
Package architecture amd64
Package type deb
Installed size 27 B
Download size 2.94 KB
Official Mirror ftp.br.debian.org
This package forms part of the Boost C++ Libraries collection.
Boost.Iostreams are a collection of concepts and a set of templates
which turn models of these concepts into C++ standard library streams
and stream buffers.
This package is a dependency package, which depends on Debian's default
Boost version (currently 1.55).

Alternatives

Package Version Architecture Repository
libboost-iostreams-dev_1.55.0.2_i386.deb 1.55.0.2 i386 Debian Main
libboost-iostreams-dev - - -

Requires

Name Value
libboost-iostreams1.55-dev -

Download

Type URL
Binary Package libboost-iostreams-dev_1.55.0.2_amd64.deb
Source Package boost-defaults

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libboost-iostreams-dev deb package:
    # sudo apt-get install libboost-iostreams-dev

Files

Path
/usr/share/doc/libboost-iostreams-dev/changelog.gz
/usr/share/doc/libboost-iostreams-dev/copyright

Changelog

2014-05-18 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.55.0.2) unstable; urgency=medium
* Upload to unstable.
- control file was regenerated in 1.55.0.1 (Closes: #736627, #720160)
2014-04-24 - Dimitri John Ledkov <xnox@ubuntu.com>
boost-defaults (1.55.0.1) experimental; urgency=medium
* Set default Boost to 1.55.0.
2013-08-17 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.54.0.1) unstable; urgency=low
* Set default Boost to 1.54.0.
2012-09-23 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.49.0.2) unstable; urgency=low
* libboost-doc.README.Debian: New.  Explain BOOST_ROOT.  
Closes: #687524.
2012-03-27 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.49.0.1) unstable; urgency=low
* Set default Boost to 1.49.0.
2012-02-01 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.48.0.3) unstable; urgency=low
* Set default Boost to 1.48.0.  Closes: #653823, #653228.
2011-12-20 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.48.0.2) unstable; urgency=low
* Revert to 1.46.1 until some build issues are worked out.  See
http://lists.debian.org/debian-release/2011/12/msg00263.html.
2011-12-17 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.48.0.1) unstable; urgency=low
* Set default Boost to 1.48.0.
* control.in: make libboost-dev suggest libboost-doc.  Closes: #625684.
2011-04-06 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.46.1.1) unstable; urgency=low
* Set default Boost to 1.46.1.
* control.in: Update Standards-Version, debhelper build-dep on v8.  Add
package libboost-random-dev.
* copyright: Change to MIT license.
2010-04-20 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.42.0.1) unstable; urgency=low
* Set default Boost to 1.42.0.  Closes: #574486.
* control.in: New packages libboost-graph-parallel-dev,
libboost-mpi-python-dev.  Change libboost-all-dev to depend on all the
unversioned -dev packages, rather than the versioned -all-dev package.
Closes: #554410.

See Also

Package Description
libboost-iostreams1.55-dev_1.55.0+dfsg-3_amd64.deb Boost.Iostreams Library development files
libboost-iostreams1.55.0_1.55.0+dfsg-3_amd64.deb Boost.Iostreams Library
libboost-locale-dev_1.55.0.2_amd64.deb C++ facilities for localization (default version)
libboost-locale1.55-dev_1.55.0+dfsg-3_amd64.deb C++ facilities for localization
libboost-locale1.55.0_1.55.0+dfsg-3_amd64.deb C++ facilities for localization
libboost-log-dev_1.55.0.2_amd64.deb C++ logging library (default version)
libboost-log1.55-dev_1.55.0+dfsg-3_amd64.deb C++ logging library
libboost-log1.55.0_1.55.0+dfsg-3_amd64.deb C++ logging library
libboost-math-dev_1.55.0.2_amd64.deb Boost.Math Library development files (default version)
libboost-math1.55-dev_1.55.0+dfsg-3_amd64.deb Boost.Math Library development files
libboost-math1.55.0_1.55.0+dfsg-3_amd64.deb Boost.Math Library
libboost-mpi-dev_1.55.0.2_amd64.deb C++ interface to the Message Passing Interface (MPI) (default version)
libboost-mpi-python-dev_1.55.0.2_amd64.deb C++ interface to the Message Passing Interface (MPI), Python Bindings (default version)
libboost-mpi-python1.55-dev_1.55.0+dfsg-3_amd64.deb C++ interface to the Message Passing Interface (MPI), Python Bindings
libboost-mpi-python1.55.0_1.55.0+dfsg-3_amd64.deb C++ interface to the Message Passing Interface (MPI), Python Bindings
Advertisement
Advertisement