libboost-graph1.55.0_1.55.0+dfsg-3_amd64.deb


Advertisement

Description

libboost-graph1.55.0 - generic graph components and algorithms in C++

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libboost-graph1.55.0
Package version 1.55.0+dfsg
Package release 3
Package architecture amd64
Package type deb
Installed size 422 B
Download size 121.09 KB
Official Mirror ftp.br.debian.org
This package forms part of the Boost C++ Libraries collection.
Graphs are mathematical abstractions that are useful for solving
many types of problems in computer science. Consequently, these
abstractions must also be represented in computer programs. A
standardized generic interface for traversing graphs is of utmost
importance to encourage reuse of graph algorithms and data structures.

Alternatives

Package Version Architecture Repository
libboost-graph1.55.0_1.55.0+dfsg-3_i386.deb 1.55.0+dfsg i386 Debian Main
libboost-graph1.55.0 - - -

Requires

Name Value
libboost-regex1.55.0 -
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libicu52 >= 52~m1-1~
libstdc++6 >= 4.2.1
multiarch-support -

Download

Type URL
Binary Package libboost-graph1.55.0_1.55.0+dfsg-3_amd64.deb
Source Package boost1.55

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libboost-graph1.55.0 deb package:
    # sudo apt-get install libboost-graph1.55.0

Files

Path
/usr/lib/x86_64-linux-gnu/libboost_graph.so.1.55.0
/usr/share/doc/libboost-graph1.55.0/changelog.Debian.gz
/usr/share/doc/libboost-graph1.55.0/copyright
/usr/share/lintian/overrides/libboost-graph1.55.0

Changelog

2014-09-18 - Steve M. Robbins <smr@debian.org>
boost1.55 (1.55.0+dfsg-3) unstable; urgency=medium
* patches/boost-1.55-128bit_int_support.patch: New. Patch fixing build
where 128-bit integer not supported, cherry-picked from upstream.
Closes: #758892.
* patches/ppc64el-fp_traits-ibm-long-double.patch: New.  Patch removing
fp_traits_non_native for long double on powerPC, which is apparently
broken.  Closes: #761926.
* control.in, control: Update vcs URLs.
2014-06-10 - Dimitri John Ledkov <xnox@ubuntu.com>
boost1.55 (1.55.0+dfsg-2) unstable; urgency=medium
* Disable pch on arm64, to avoid FTBFS. (Closes: #750956)
* Speed up qemu-static builds a little, by not working perl many times
when computing version strings to use.
2014-05-11 - Dimitri John Ledkov <xnox@ubuntu.com>
boost1.55 (1.55.0+dfsg-1) unstable; urgency=medium
* Convert debian/copyright to copyright-format 1.0.
* Use Uscan extension https://wiki.debian.org/UscanEnhancements to
declare excluded file (W3C validation icon)
* Use uscan to download current version of boost, and thus
auto-repackage with above non-dfsg file removed. Or
e.g. --svn-download-orig option to svn-buildpackage.
* Adjust version parsing in the debian/rules to keep the same versioning
information.
2014-05-02 - Dimitri John Ledkov <xnox@ubuntu.com>
boost1.55 (1.55.0-2) unstable; urgency=medium
* In libboost-python1.55-dev drop gccxml to Suggests as it's not
available on all architectures, is based upon old gcc, and not at all
required to compile boost-python based projects.
* Mark libboost1.55-dev & libboost-coroutine1.55-dev as Multi-Arch same.
* Automate more of building boost without mpi, or just mpi portions.
2014-01-04 - Steve M. Robbins <smr@debian.org>
boost1.55 (1.55.0-1) unstable; urgency=low
[ Steve M. Robbins ]
* New upstream.  
- control.in, control: regenerated using update-control.py.  Set
Standards-Version to 3.9.5.
* Remove patches applied upstream:
- 001-coroutine.patch
- 002-date-time.patch
- boost-1.44-py3.1.patch
- boost-1.54.0-thread-link_atomic.patch
- 85160.patch
- eglibc-long-long.patch
* patches/endian.patch: Remove.  Upstream changed endian detection.
* patches/boost-1.55.0-001-log_fix_dump_avx2.patch: New.  Upstream patch
to fix incorrect output of the dump manipulator, when used on
AVX2-enabled CPU (e.g. Intel Haswell).
* rules: Suppress warnings about unused local typedefs
(-Wno-unused-local-typedefs) because they are massively generated by
Boost Concept Check Library.
[ Dimitri John Ledkov ]
* Refresh patches/ELFv2-libboost1.54-dev-context-asm.patch
* Refresh patches/boost-python-examples.patch: Hopefully does not
reopen: #452410.
* Enable context library on ppc64, ppc64el.
2013-12-18 - Dimitri John Ledkov <xnox@ubuntu.com>
boost1.54 (1.54.0-5) UNRELEASED; urgency=low
[ William Grant ]
* debian/patches/eglibc-long-long.patch: Fix build with eglibc 2.18.
* debian/rules: Treat ppc64el like ppc64.

See Also

Package Description
libboost-iostreams-dev_1.55.0.2_amd64.deb Boost.Iostreams Library development files (default version)
libboost-iostreams1.55-dev_1.55.0+dfsg-3_amd64.deb Boost.Iostreams Library development files
libboost-iostreams1.55.0_1.55.0+dfsg-3_amd64.deb Boost.Iostreams Library
libboost-locale-dev_1.55.0.2_amd64.deb C++ facilities for localization (default version)
libboost-locale1.55-dev_1.55.0+dfsg-3_amd64.deb C++ facilities for localization
libboost-locale1.55.0_1.55.0+dfsg-3_amd64.deb C++ facilities for localization
libboost-log-dev_1.55.0.2_amd64.deb C++ logging library (default version)
libboost-log1.55-dev_1.55.0+dfsg-3_amd64.deb C++ logging library
libboost-log1.55.0_1.55.0+dfsg-3_amd64.deb C++ logging library
libboost-math-dev_1.55.0.2_amd64.deb Boost.Math Library development files (default version)
libboost-math1.55-dev_1.55.0+dfsg-3_amd64.deb Boost.Math Library development files
libboost-math1.55.0_1.55.0+dfsg-3_amd64.deb Boost.Math Library
libboost-mpi-dev_1.55.0.2_amd64.deb C++ interface to the Message Passing Interface (MPI) (default version)
libboost-mpi-python-dev_1.55.0.2_amd64.deb C++ interface to the Message Passing Interface (MPI), Python Bindings (default version)
libboost-mpi-python1.55-dev_1.55.0+dfsg-3_amd64.deb C++ interface to the Message Passing Interface (MPI), Python Bindings
Advertisement
Advertisement