libboost-dev_1.55.0.2_amd64.deb


Advertisement

Description

libboost-dev - Boost C++ Libraries development files (default version)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libboost-dev
Package version 1.55.0.2
Package architecture amd64
Package type deb
Installed size 27 B
Download size 3.29 KB
Official Mirror ftp.br.debian.org
The Boost web site provides free, peer-reviewed, portable C++ source
libraries. The emphasis is on libraries which work well with the C++
Standard Library. One goal is to establish "existing practice" and
provide reference implementations so that the Boost libraries are
suitable for eventual standardization. Some of the libraries have
already been proposed for inclusion in the C++ Standards Committee's
upcoming C++ Standard Library Technical Report.
This package provides headers for all Boost libraries.
Extended precision arithmetic package libmpfrc++-dev or libntl-dev is
required to use the Boost.Multiprecision wrapping of the respective
library.
For the following subprojects separate packages exist: chrono,
date-time, exception filesystem, graph, iostreams, locale, math, mpi,
program_options, python, regex, serialization, signals, system, test,
thread, timer, and wave.
This package is a dependency package, which depends on Debian's default
Boost version (currently 1.55).

Alternatives

Package Version Architecture Repository
libboost-dev_1.55.0.2_i386.deb 1.55.0.2 i386 Debian Main
libboost-dev - - -

Requires

Name Value
libboost1.55-dev -

Download

Type URL
Binary Package libboost-dev_1.55.0.2_amd64.deb
Source Package boost-defaults

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libboost-dev deb package:
    # sudo apt-get install libboost-dev

Files

Path
/usr/share/doc/libboost-dev/changelog.gz
/usr/share/doc/libboost-dev/copyright

Changelog

2014-05-18 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.55.0.2) unstable; urgency=medium
* Upload to unstable.
- control file was regenerated in 1.55.0.1 (Closes: #736627, #720160)
2014-04-24 - Dimitri John Ledkov <xnox@ubuntu.com>
boost-defaults (1.55.0.1) experimental; urgency=medium
* Set default Boost to 1.55.0.
2013-08-17 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.54.0.1) unstable; urgency=low
* Set default Boost to 1.54.0.
2012-09-23 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.49.0.2) unstable; urgency=low
* libboost-doc.README.Debian: New.  Explain BOOST_ROOT.  
Closes: #687524.
2012-03-27 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.49.0.1) unstable; urgency=low
* Set default Boost to 1.49.0.
2012-02-01 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.48.0.3) unstable; urgency=low
* Set default Boost to 1.48.0.  Closes: #653823, #653228.
2011-12-20 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.48.0.2) unstable; urgency=low
* Revert to 1.46.1 until some build issues are worked out.  See
http://lists.debian.org/debian-release/2011/12/msg00263.html.
2011-12-17 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.48.0.1) unstable; urgency=low
* Set default Boost to 1.48.0.
* control.in: make libboost-dev suggest libboost-doc.  Closes: #625684.
2011-04-06 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.46.1.1) unstable; urgency=low
* Set default Boost to 1.46.1.
* control.in: Update Standards-Version, debhelper build-dep on v8.  Add
package libboost-random-dev.
* copyright: Change to MIT license.
2010-04-20 - Steve M. Robbins <smr@debian.org>
boost-defaults (1.42.0.1) unstable; urgency=low
* Set default Boost to 1.42.0.  Closes: #574486.
* control.in: New packages libboost-graph-parallel-dev,
libboost-mpi-python-dev.  Change libboost-all-dev to depend on all the
unversioned -dev packages, rather than the versioned -all-dev package.
Closes: #554410.

See Also

Package Description
libboost-doc_1.55.0.2_all.deb Boost.org libraries documentation (default version)
libboost-exception-dev_1.55.0.2_amd64.deb library to help write exceptions and handlers (default version)
libboost-exception1.55-dev_1.55.0+dfsg-3_amd64.deb library to help write exceptions and handlers
libboost-filesystem-dev_1.55.0.2_amd64.deb filesystem operations (portable paths, iteration over directories, etc) in C++ (default version)
libboost-filesystem1.55-dev_1.55.0+dfsg-3_amd64.deb filesystem operations (portable paths, iteration over directories, etc) in C++
libboost-filesystem1.55.0_1.55.0+dfsg-3_amd64.deb filesystem operations (portable paths, iteration over directories, etc) in C++
libboost-geometry-utils-perl_0.15-2+b1_amd64.deb Perl module providing bindings to the Boost Geometry library
libboost-graph-dev_1.55.0.2_amd64.deb generic graph components and algorithms in C++ (default version)
libboost-graph-parallel-dev_1.55.0.2_amd64.deb generic graph components and algorithms in C++ (default version)
libboost-graph-parallel1.55-dev_1.55.0+dfsg-3_amd64.deb generic graph components and algorithms in C++
libboost-graph-parallel1.55.0_1.55.0+dfsg-3_amd64.deb generic graph components and algorithms in C++
libboost-graph1.55-dev_1.55.0+dfsg-3_amd64.deb generic graph components and algorithms in C++
libboost-graph1.55.0_1.55.0+dfsg-3_amd64.deb generic graph components and algorithms in C++
libboost-iostreams-dev_1.55.0.2_amd64.deb Boost.Iostreams Library development files (default version)
libboost-iostreams1.55-dev_1.55.0+dfsg-3_amd64.deb Boost.Iostreams Library development files
Advertisement
Advertisement