libbit-vector-perl_7.3-1+b2_amd64.deb


Advertisement

Description

libbit-vector-perl - Perl module for bit vectors and more

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libbit-vector-perl
Package version 7.3
Package release 1+b2
Package architecture amd64
Package type deb
Installed size 410 B
Download size 143.05 KB
Official Mirror ftp.br.debian.org
Bit::Vector is a module that allows you to handle bit vectors, integer sets,
"big integer arithmetic" and boolean matrices, all of arbitrary sizes. It is
efficient (in terms of algorithmic complexity) and therefore fast (in terms
of execution speed). It also provides overloaded operators for ease of use.

Alternatives

Package Version Architecture Repository
libbit-vector-perl_7.3-1+b2_i386.deb 7.3 i386 Debian Main
libbit-vector-perl - - -

Requires

Name Value
libc6 >= 2.4
libcarp-clan-perl -
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libbit-vector-perl_7.3-1+b2_amd64.deb
Source Package libbit-vector-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libbit-vector-perl deb package:
    # sudo apt-get install libbit-vector-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Bit/Vector.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Bit/Vector.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Bit/Vector/Overload.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Bit/Vector/Overload.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Bit/Vector/String.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Bit/Vector/String.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Bit/Vector/Vector.so
/usr/share/doc/libbit-vector-perl/CREDITS.txt.gz
/usr/share/doc/libbit-vector-perl/README.txt.gz
/usr/share/doc/libbit-vector-perl/changelog.Debian.amd64.gz
/usr/share/doc/libbit-vector-perl/changelog.Debian.gz
/usr/share/doc/libbit-vector-perl/changelog.gz
/usr/share/doc/libbit-vector-perl/copyright
/usr/share/doc/libbit-vector-perl/examples/SetObject.pl.gz
/usr/share/doc/libbit-vector-perl/examples/benchmk1.pl
/usr/share/doc/libbit-vector-perl/examples/benchmk2.pl
/usr/share/doc/libbit-vector-perl/examples/benchmk3.pl
/usr/share/doc/libbit-vector-perl/examples/primes.pl
/usr/share/doc/libbit-vector-perl/examples/test.c
/usr/share/man/man3/Bit::Vector.3pm.gz
/usr/share/man/man3/Bit::Vector::Overload.3pm.gz
/usr/share/man/man3/Bit::Vector::String.3pm.gz

Changelog

2013-07-25 - gregor herrmann <gregoa@debian.org>
libbit-vector-perl (7.3-1) unstable; urgency=low
* New upstream release.
* Drop Bit-Vector-destroy.patch, merged upstream.
* Update years of upstream copyright.
* Add /me to Uploaders.
2013-05-12 - gregor herrmann <gregoa@debian.org>
libbit-vector-perl (7.2-2) unstable; urgency=low
* Team upload.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Add patch Bit-Vector-destroy.patch from CPAN RT. Fixes test failure
with perl >= 5.17. (Closes: #708003)
* Set Standards-Version to 3.9.4 (no changes).
* Use debhelper 9.20120312 to get all hardening flags.
2012-03-10 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libbit-vector-perl (7.2-1) unstable; urgency=low
[ gregor herrmann ]
* debian/rules: fix hashbang in example scripts, thanks to Dario Minnucci
for the bug report (closes: #543671).
[ Ryan Niebur ]
* Update jawnsy's email address
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Florian Schlichting ]
* Imported Upstream version 7.2.
* Switched debhelper compatibility level to 9 to enable passing of CFLAGS.
* Bumped Standards-Version to 3.9.3 (use copyright-format 1.0).
* Switched to source format "3.0 (quilt)".
* Added a separate copyright stanza for BitVector.c, BitVector.h and 
ToolBox.h, referencing the optional LGPL-2 licensing.
* Added spelling-error-in-manpage.patch.
* Added myself to Uploaders and copyright.
2009-10-11 - Christian Hammers <ch@debian.org>
libbit-vector-perl (7.1-1) unstable; urgency=low
* New upstream release
2009-08-24 - Jonathan Yu <frequency@cpan.org>
libbit-vector-perl (7.0-1) unstable; urgency=low
* New upstream release
+ Fix GCD2() when used with null-size vectors
* Remove version dependency on libcarp-clan-perl (we have a
newer version even in oldstable)
2009-08-20 - Jonathan Yu <frequency@cpan.org>
libbit-vector-perl (6.9-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
+ Bugfix: Storable wasn't reconstructing nested data structures
properly when they contained several references to the same
Bit::Vector object
+ Fix hard-coded table size MASKTABSIZE in BitVector.c
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ gregor herrmann ]
* debian/copyright: merge stanzas.
* Set Standards-Version to 3.8.3 (no changes).
* Remove historical debian/README.Maintainer.
2009-07-28 - Jonathan Yu <frequency@cpan.org>
libbit-vector-perl (6.6-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
[ Jonathan Yu ]
* New upstream release
+ Fixes for thread-safety
+ Add automatic support for "Storable"
* Bump compat to 7
* Use new shorter debhelper format
* Cleaned up copyright, brought it to the new machine-readable format
* Cleaned up the description a bit
* Added myself to Uploaders and Copyright
[ gregor herrmann ]
* debian/watch: use extended regexp for matching upstream versions.

See Also

Package Description
libbitcoin-dev_2.0-2.2_amd64.deb Bitcoin toolkit library for asynchronous apps - development headers
libbitcoin0_2.0-2.2_amd64.deb Bitcoin toolkit library for asynchronous apps
libbitmask-dev_2.0-2_amd64.deb header files and docs for libbitmask
libbitmask1_2.0-2_amd64.deb supports multi-word bitmask operations
libbitstream-dev_1.0-1_all.deb access to binary structures such as specified by MPEG, DVB, IETF and more
libbitstring-ocaml-dev_2.0.4-2_amd64.deb Erlang-style bitstrings for OCaml (development files)
libbitstring-ocaml_2.0.4-2_amd64.deb Erlang-style bitstrings for OCaml (runtime)
libbjack-ocaml-dev_0.1.4-2+b1_amd64.deb OCaml blocking interface to jack audio connection kit
libbjack-ocaml_0.1.4-2+b1_amd64.deb OCaml blocking interface to jack audio connection kit
libblacs-mpi-dev_1.1-33_amd64.deb Basic Linear Algebra Comm. Subprograms - Dev. files for MPI
libblacs-openmpi1_1.1-33_amd64.deb Basic Linear Algebra Comm. Subprograms - Shared libs. for OpenMPI
libbladerf-dev_0.2014.09~rc2-5_amd64.deb nuand bladeRF software-defined radio device (header files)
libbladerf0_0.2014.09~rc2-5_amd64.deb nuand bladeRF software-defined radio device
libblas-common_1.2.20110419-10_amd64.deb Dependency package for all BLAS implementations
libblas-dev_1.2.20110419-10_amd64.deb Basic Linear Algebra Subroutines 3, static library
Advertisement
Advertisement