libballview1.4_1.4.2+20140406-1+b2_amd64.deb


Advertisement

Description

libballview1.4 - Biochemical Algorithms Library, VIEW framework

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libballview1.4
Package version 1.4.2+20140406
Package release 1+b2
Package architecture amd64
Package type deb
Installed size 4.67 KB
Download size 1.21 MB
Official Mirror ftp.br.debian.org
BALL (Biochemical Algorithms Library) is an application framework
in C++ that has been specifically designed for rapid software
development in Molecular Modeling and Computational Molecular Biology.
It provides an extensive set of data structures as well as classes
for Molecular Mechanics, advanced solvation methods, comparison and
analysis of protein structures, file import/export, and visualization.
BALL is currently being developed in the groups of Oliver Kohlbacher
(University of Tuebingen, Germany), Andreas Hildebrandt (Saarland
University, Saarbruecken, Germany), and Hans-Peter Lenhof (Saarland
University, Saarbruecken, Germany).
This package contains the view parts of BALL (libVIEW). Those are
required for molecular visualization and for running BALLView.

Alternatives

Package Version Architecture Repository
libballview1.4_1.4.2+20140406-1+b2_i386.deb 1.4.2+20140406 i386 Debian Main
libballview1.4 - - -

Requires

Name Value
libball1.4 -
libboost-date-time1.55.0 -
libboost-iostreams1.55.0 -
libboost-regex1.55.0 -
libboost-system1.55.0 -
libboost-thread1.55.0 -
libc6 >= 2.14
libfftw3-double3 -
libfftw3-single3 -
libgcc1 >= 1:4.1.1
libgl1 -
libgl1-mesa-glx -
libglew1.10 >= 1.10.0
libglu1 -
libglu1-mesa -
libgsl0ldbl >= 1.9
libice6 >= 1:1.0.0
libpython2.7 >= 2.7
libqt4-network >= 4:4.5.3
libqt4-opengl >= 4:4.5.3
libqt4-sql >= 4:4.5.3
libqt4-test >= 4:4.5.3
libqt4-xml >= 4:4.5.3
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.8.0
libqtwebkit4 >= 2.1.0~2011week13
libsm6 -
libstdc++6 >= 4.6
libx11-6 -
libxext6 -

Download

Type URL
Binary Package libballview1.4_1.4.2+20140406-1+b2_amd64.deb
Source Package ball

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libballview1.4 deb package:
    # sudo apt-get install libballview1.4

Files

Path
/usr/lib/libVIEW.so.1.4
/usr/share/doc/libballview1.4/changelog.Debian.amd64.gz
/usr/share/doc/libballview1.4/changelog.Debian.gz
/usr/share/doc/libballview1.4/changelog.gz
/usr/share/doc/libballview1.4/copyright

Changelog

2014-04-07 - Steffen Moeller <moeller@debian.org>
ball (1.4.2+20140406-1) unstable; urgency=medium
* New upstream version (upstream reported better compatibility
with latest compilers)
2013-12-12 - Andreas Tille <tille@debian.org>
ball (1.4.2-1) UNRELEASED; urgency=medium
* New upstream version (adapted patches)
* debian/watch: Fix to report latest upstream version
* debian/control:
- cme fix dpkg-control
- canonical Vcs fields
- debhelper 9
- Fix Build-Depends-Indep to enable doxygen documentation
- Fix Build-Depends (add libglew-dev, drop long outdated versions
of libboost)
- Add Build-Depends libqt4-dev-bin for uic-qt4 to auto generate UI
header files
* debian/copyright: DEP5
* debian/rules:
- do not delete *.doc files since these are also in upstream tarball
- create UI header files
* debian/patches/0101-cmake-syntax.patch: Fix cmake
syntax to prevent annoying warnings in build log
* debian/patches/0102-fix-boost-compatibility-issue.patch:  Fix build
issue with more recent boost versions (Thanks to Gert Wollny
<gw.fossdev@gmail.com> for the patch)
Closes: #720681
* debian/upstream: Drop outdated watch information
* debian/patches/0103-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch:
commit 1e76c9 in the ball git repro
(thanks to Gert Wollny <gw.fossdev@gmail.com> for the hint)
2012-08-15 - Andreas Hildebrandt <andreas.hildebrandt@uni-mainz.de>
ball (1.4.1+20111206-4) unstable; urgency=low
* Fix compilation with g++ >= 4.7 (Closes: 674226) 
* Updated policy to 3.9.3 (no changes required)
2012-01-06 - Steffen Moeller <moeller@debian.org>
ball (1.4.1+20111206-3) unstable; urgency=low
* Fixed "const" in .sip files (Closes: #653626)
2011-12-09 - Steffen Moeller <moeller@debian.org>
ball (1.4.1+20111206-2) unstable; urgency=low
* Added "signed" to char because of platform differences
2011-12-08 - Andreas Hildebrandt <andreas.hildebrandt@uni-mainz.de>
ball (1.4.1+20111206-1) unstable; urgency=low
* New upstream version.
* Depending on ghostscript, not gs-common (Closes: #649711)
2011-10-20 - Andreas Hildebrandt <andreas.hildebrandt@uni-mainz.de>
ball (1.4.1-1) UNRELEASED; urgency=low
* Updated to new upstream release 1.4.1 
2011-07-22 - Steffen Moeller <moeller@debian.org>
ball (1.4.0-5) unstable; urgency=low
* Added myself to Uploaders
* Rebuilt with current version of python (Closes: #632488).
* Added dependency on texlive-latex-recommended and the build
instructions should already separate the documentation from
the rest (Closes: #631999).
* Unsigned char issue was at some point already fixed (Closes: #631998).
2011-07-21 - Andreas or Steffen  <moeller@debian.org>
ball (1.4.0-4) UNRELEASED; urgency=low
* Documentation packages are in conflict (Closes: #631911)
* Removed (redundant) conflict of ballview to itself
* Helped quirk in descrition (Closes: #598081)
2011-07-20 - Steffen Moeller <moeller@debian.org>
ball (1.4.0-3) unstable; urgency=low
* Added -fpermissive to compiler flags to avoid "narrowing" error

See Also

Package Description
libbaloocore4_4.14.2-1_amd64.deb core functionality for Baloo
libbaloofiles4_4.14.2-1_amd64.deb files functionality for Baloo
libbaloopim4_4.14.2-1_amd64.deb PIM functionality for Baloo
libbalooqueryparser4_4.14.2-1_amd64.deb query Parser for Baloo
libbaloowidgets-dev_4.14.0-1_amd64.deb Development headers for developing applications with Baloo
libbaloowidgets4_4.14.0-1_amd64.deb Widgets for Baloo
libbalooxapian4_4.14.2-1_amd64.deb Xapian functionality for Baloo
libbam-dev_0.1.19-2_amd64.deb manipulates nucleotide sequence alignments in BAM or SAM format
libbambamc-dev_0.0.50-1_amd64.deb Development files for reading and writing BAM (genome alignment) files
libbambamc0_0.0.50-1_amd64.deb Runtime library for reading and writing BAM (genome alignment) files
libbamf-dev_0.2.118-1_amd64.deb Window matching library - development files (gtk2)
libbamf-doc_0.2.118-1_all.deb Window matching library - documentation
libbamf0_0.2.118-1_amd64.deb Window matching library - shared library (gtk2)
libbamf3-0_0.2.118-1_amd64.deb Window matching library - shared library
libbamf3-dev_0.2.118-1_amd64.deb Window matching library - development files
Advertisement
Advertisement