libb-perlreq-perl_0.82-3+b1_amd64.deb


Advertisement

Description

libb-perlreq-perl - Perl module to determine Perl module dependencies

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libb-perlreq-perl
Package version: 0.82
Package release: 3+b1
Package architecture: amd64
Package type: deb
Installed size: 121 B
Download size: 29.62 KB
Official Mirror: ftp.br.debian.org
B::PerlReq is a backend module for the Perl compiler that determines the dependencies of Perl source code, based on the internal structure that Perl creates itself after parsing a program source file. The output of this module is suitable for automatic dependency detection, tracking and organization, particularly for building and maintaining binary packages.

Alternatives

    Download

    Source package: libb-perlreq-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libb-perlreq-perl deb package:
      # sudo apt-get install libb-perlreq-perl

    Files

    • /usr/lib/x86_64-linux-gnu/perl5/5.20/B/Clobbers.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/B/ConstOptree.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/B/PerlReq.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/B/Walker.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/PerlReq/Utils.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/B/ConstOptree/ConstOptree.so
    • /usr/share/doc/libb-perlreq-perl/changelog.Debian.amd64.gz
    • /usr/share/doc/libb-perlreq-perl/changelog.Debian.gz
    • /usr/share/doc/libb-perlreq-perl/changelog.gz
    • /usr/share/doc/libb-perlreq-perl/copyright
    • /usr/share/man/man3/B::Clobbers.3pm.gz
    • /usr/share/man/man3/B::ConstOptree.3pm.gz
    • /usr/share/man/man3/B::PerlReq.3pm.gz
    • /usr/share/man/man3/B::Walker.3pm.gz
    • /usr/share/man/man3/PerlReq::Utils.3pm.gz

    Changelog

    2014-06-02 - gregor herrmann <gregoa@debian.org> libb-perlreq-perl (0.82-3) unstable; urgency=medium * Strip trailing slash from metacpan URLs. * Use $Config{vendorarch} in debian/rules as a preparation for the multi-arched perl 5.20. * Update years of packaging copyright. * Declare compliance with Debian Policy 3.9.5.

    2013-05-18 - gregor herrmann <gregoa@debian.org> libb-perlreq-perl (0.82-2) unstable; urgency=low [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Add patch from Niko Tyni to handle hash randomization changes in Perl since 5.17. (Closes: #708592) * Update years of packaging copyright.

    2012-12-01 - Xavier Guimard <x.guimard@free.fr> libb-perlreq-perl (0.82-1) unstable; urgency=low [ Xavier Guimard ] * Imported Upstream version 0.82 * Bump Standards-Version to 3.9.4 * Update debian/copyright (years and format) * Use debhelper >= 9.20120312 * Change Architecture from "all" to "any" [ gregor herrmann ] * Refresh patch (offset).

    2011-12-07 - gregor herrmann <gregoa@debian.org> libb-perlreq-perl (0.80-1) unstable; urgency=low * New upstream release. * Add libtry-tiny-perl to Build-Depends-Indep.

    2011-11-14 - Florian Schlichting <fschlich@zedat.fu-berlin.de> libb-perlreq-perl (0.78-1) unstable; urgency=low [ Florian Schlichting ] * Imported Upstream version 0.77, 0.78 * Add myself to Uploaders. * Remove all perl.* scripts (questionable utility on non-RPM-based distributions) [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * debian/copyright: Replace DEP5 Format-Specification URL from svn.debian.org to anonscm.debian.org URL. [ gregor herrmann ] * New upstream release. * Drop 0001-Adapt-to-5.13.x-dependency-changes.patch, the issue is solved now. * Refresh spelling.patch (offset).

    2011-07-10 - gregor herrmann <gregoa@debian.org> libb-perlreq-perl (0.74-2) unstable; urgency=low * Add patch by Niko Tyni to work with perl 5.14 (closes: #629275). * Add /me to Uploaders. * Set Standards-Version to 3.9.2 (no changes).

    2011-02-27 - Jonathan Yu <jawnsy@cpan.org> libb-perlreq-perl (0.74-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Standards-Version 3.9.1 (no changes) * Bump to debhelper 8 * Refresh copyright information [ Ansgar Burchardt ] * Update my email address.

    2010-04-24 - Ansgar Burchardt <ansgar@43-1.org> libb-perlreq-perl (0.72-1) unstable; urgency=low * New upstream release. + Builds with perl 5.12.0. (Closes: #579010) * Use source format 3.0 (quilt). * debian/copyright: Formatting changes for current DEP-5 proposal. * debian/copyright: Update years of copyright. * Fix spelling error in the documentation. + new patch: spelling.patch * Bump Standards-Version to 3.8.4. * Add myself to Uploaders.

    2009-09-27 - Jonathan Yu <jawnsy@cpan.org> libb-perlreq-perl (0.71-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Standards-Version 3.8.3 (drop perl version dependency) * Use new short debhelper rules format (dh 7.0.50 for overrides) [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Ryan Niebur ] * Update jawnsy's email address

    2009-05-19 - Jonathan Yu <frequency@cpan.org> libb-perlreq-perl (0.70-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release -> Adds a few experimental modules (B::Walker, B::Clobbers, PerlReq::Utils) -> Added some macros for compilation -> Now handles 'leavetry' operations from B::Walker * Updated copyright statement * Added /me to uploaders * Standards-Version changed to 3.8.1 [ gregor herrmann ] * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza).

    Advertisement
    Advertisement