libb-hooks-endofscope-perl_0.13-1_all.deb


Advertisement

Description

libb-hooks-endofscope-perl - module for executing code after a scope finished compilation

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libb-hooks-endofscope-perl
Package version: 0.13
Package release: 1
Package architecture: all
Package type: deb
Installed size: 73 B
Download size: 15.03 KB
Official Mirror: ftp.br.debian.org
B::Hooks::EndOfScope allows you to execute code when perl finished compiling the surrounding scope. It exports a single function, 'on_scope_end $codeblock', which can be used e.g. for introspection in the constructor of your class.

Alternatives

    Download

    Source package: libb-hooks-endofscope-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libb-hooks-endofscope-perl deb package:
      # sudo apt-get install libb-hooks-endofscope-perl

    Files

    • /usr/share/doc/libb-hooks-endofscope-perl/changelog.Debian.gz
    • /usr/share/doc/libb-hooks-endofscope-perl/changelog.gz
    • /usr/share/doc/libb-hooks-endofscope-perl/copyright
    • /usr/share/man/man3/B::Hooks::EndOfScope.3pm.gz
    • /usr/share/man/man3/B::Hooks::EndOfScope::PP.3pm.gz
    • /usr/share/man/man3/B::Hooks::EndOfScope::XS.3pm.gz
    • /usr/share/perl5/B/Hooks/EndOfScope.pm
    • /usr/share/perl5/B/Hooks/EndOfScope/PP.pm
    • /usr/share/perl5/B/Hooks/EndOfScope/XS.pm
    • /usr/share/perl5/B/Hooks/EndOfScope/PP/FieldHash.pm
    • /usr/share/perl5/B/Hooks/EndOfScope/PP/HintHash.pm

    Changelog

    2014-01-10 - Florian Schlichting <fsfs@debian.org> libb-hooks-endofscope-perl (0.13-1) unstable; urgency=medium * Import Upstream version 0.13 * Add upstream-repo URL to Source field * Email change: Florian Schlichting -> fsfs@debian.org * Declare compliance with Debian Policy 3.9.5 * Update copyright years

    2013-05-04 - gregor herrmann <gregoa@debian.org> libb-hooks-endofscope-perl (0.12-1) unstable; urgency=low [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * New upstream release. * Update years of packaging copyright. * Set Standards-Version to 3.9.4 (no changes). * Update build and runtime dependencies.

    2012-02-26 - Florian Schlichting <fschlich@zedat.fu-berlin.de> libb-hooks-endofscope-perl (0.11-1) unstable; urgency=low * Imported Upstream version 0.11. * Dependency on libvariable-magic-perl now needs to be versioned (>= 0.48). * Bumped Standards-Version to 3.9.3 (use copyright-format 1.0).

    2012-02-21 - Florian Schlichting <fschlich@zedat.fu-berlin.de> libb-hooks-endofscope-perl (0.10-1) unstable; urgency=low [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Ansgar Burchardt ] * debian/copyright: Update years of copyright, remove information on ./inc/* (removed upstream). * debian/control: Convert Vcs-* fields to Git. [ Fabrizio Regalli ] * Imported Upstream version 0.10 * Added myself to Uploaders and Copyright * Updated d/compat to 8 * Updated debhelper to (>= 8) * Switch to dpkg-source 3.0 (quilt) format * Bump Standards-Version to 3.9.2 * Moved to three lines standard d/rules * debian/copyright: - Removed all Original-Source-* lines - Removed License-Alias: Perl - Changed '|' with 'or' in license type - Removed 'GNU/Linux' from license text - Updated to latest revision (.174) of DEP5 format - Changed path of GPL license in '/usr/share/common-licenses/GPL-1' - Updated copyright year [ Florian Schlichting ] * Provided an extended description that satisfies lintian. * debian/control: + removed versioned Depends: satisfied in oldstable + added ${perl:Depends} to Depends: + added build-dependency on perl (>= 5.10.1) | libtest-more-perl (>= 0.89) * Added Antonio Radici back to debian/copyright. * Added myself to Uploaders and copyright.

    2009-04-27 - gregor herrmann <gregoa@debian.org> libb-hooks-endofscope-perl (0.08-1) unstable; urgency=low [ Jeremiah C. Foster ] * New upstream release [ gregor herrmann ] * debian/control: remove not really helpful last line from long description. * Set Standards-Version to 3.8.1 (no changes). * Make (build) dependency on libvariable-magic-perl versioned.

    2009-03-10 - gregor herrmann <gregoa@debian.org> libb-hooks-endofscope-perl (0.07-1) unstable; urgency=low [ Antonio Radici ] * New upstream release * debian/control: + adding me to the Uploaders * debian/copyright: + fixed some missing commas and chars [ gregor herrmann ] * debian/copyright: update years of copyright for files under inc/. * debian/control: - switch Vcs-Browser field to ViewSVN - replace libscope-guard-perl with libvariable-magic-perl - add /me to Uploaders - improve short and long description

    2008-11-11 - Jose Luis Rivas <ghostbar38@gmail.com> libb-hooks-endofscope-perl (0.04-1) unstable; urgency=low * Initial Release. (Closes: #504241)

    Advertisement
    Advertisement