libautocomplete-java_2.5.0-1_all.deb


Advertisement

Description

libautocomplete-java - Java library for auto-completion in text component

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libautocomplete-java
Package version 2.5.0
Package release 1
Package architecture all
Package type deb
Installed size 143 B
Download size 123.03 KB
Official Mirror ftp.br.debian.org
AutoComplete is a library allowing you to add IDE-like auto-completion
(aka "code completion" or "Intellisense") to any Swing JTextComponent.
Special integration is added for RSyntaxTextArea.
It features:
* Drop-down completion choice list
* Optional companion "description" window, complete with full HTML
support and navigable with hyperlinks
* Optional parameter completion assistance for functions/methods,
ala Eclipse and NetBeans
* Completion information is typically specified in an XML file,
but can even be dynamic.

Alternatives

Package Version Architecture Repository
libautocomplete-java_2.5.0-1_all.deb 2.5.0 all Debian Main
libautocomplete-java - - -

Requires

Name Value
librsyntaxtextarea-java -

Download

Type URL
Binary Package libautocomplete-java_2.5.0-1_all.deb
Source Package autocomplete

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libautocomplete-java deb package:
    # sudo apt-get install libautocomplete-java

Files

Path
/usr/share/doc/libautocomplete-java/changelog.Debian.gz
/usr/share/doc/libautocomplete-java/copyright
/usr/share/java/autocomplete-2.5.0.jar
/usr/share/java/autocomplete.jar
/usr/share/maven-repo/com/fifesoft/autocomplete/2.5.0/autocomplete-2.5.0.jar
/usr/share/maven-repo/com/fifesoft/autocomplete/2.5.0/autocomplete-2.5.0.pom
/usr/share/maven-repo/com/fifesoft/autocomplete/debian/autocomplete-debian.jar
/usr/share/maven-repo/com/fifesoft/autocomplete/debian/autocomplete-debian.pom

Changelog

2013-10-21 - Benjamin Mesing <ben@debian.org>
autocomplete (2.5.0-1) unstable; urgency=low
* new upstream release
* first upload to archive (Closes: #619046)
2011-05-11 - Vladimir Kotov <vladimir@kotov.lv>
autocomplete (1.5.1-1) unstable; urgency=low
* Initial release. (Closes: #619046)
* Never uploaded to archive

See Also

Package Description
libautodie-perl_2.25-1_all.deb Perl pragma to make certain failures fatal
libautomaton-java_1.11-8+dfsg1-1_all.deb Finite-State Automaton for Regular Expressions
libautounit-dev_0.20.1-4_amd64.deb Development files for C unit testing framework
libautounit2_0.20.1-4_amd64.deb C unit testing framework interfacing well with autotools
libautovivification-perl_0.12-1+b1_amd64.deb pragma for lexically disabling autovivification
libav-doc_11.12-1~deb8u1_all.deb Documentation of the Libav API
libav-tools_11.12-1~deb8u1_amd64.deb Multimedia player, encoder and transcoder
libavahi-cil-dev_0.6.19-4.2_all.deb CLI bindings for Avahi
libavahi-client-dev_0.6.31-5_amd64.deb Development files for the Avahi client library
libavahi-client3_0.6.31-5_amd64.deb Avahi client library
libavahi-common-data_0.6.31-5_amd64.deb Avahi common data files
libavahi-common-dev_0.6.31-5_amd64.deb Development files for the Avahi common library
libavahi-common3_0.6.31-5_amd64.deb Avahi common library
libavahi-compat-libdnssd-dev_0.6.31-5_amd64.deb Development headers for the Avahi Apple Bonjour compatibility library
libavahi-compat-libdnssd1_0.6.31-5_amd64.deb Avahi Apple Bonjour compatibility library
Advertisement
Advertisement