libautobox-perl_2.82-1+b1_amd64.deb


Advertisement

Description

libautobox-perl - Perl pragma for method calls on native types

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libautobox-perl
Package version 2.82
Package release 1+b1
Package architecture amd64
Package type deb
Installed size 61 B
Download size 29.58 KB
Official Mirror ftp.br.debian.org
autobox is a Perl pragma that enables method calls on Perl's native data types
including numeric values (integers and floats), strings, arrays, hashes and
even code references in a simple and consistent way.
When a method is invoked on something which is not a blessed object reference,
autobox looks for the method in a package whose name corresponds to the ref()
type of the value. This design means extending the default functionality for
new methods on a type-by-type basis is very simple.

Alternatives

Package Version Architecture Repository
libautobox-perl_2.82-1+b1_i386.deb 2.82 i386 Debian Main
libautobox-perl - - -

Requires

Name Value
libc6 >= 2.4
libscope-guard-perl -
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libautobox-perl_2.82-1+b1_amd64.deb
Source Package libautobox-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libautobox-perl deb package:
    # sudo apt-get install libautobox-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/autobox.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/autobox.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/autobox/autobox.so
/usr/lib/x86_64-linux-gnu/perl5/5.20/autobox/universal.pm
/usr/share/doc/libautobox-perl/changelog.Debian.amd64.gz
/usr/share/doc/libautobox-perl/changelog.Debian.gz
/usr/share/doc/libautobox-perl/changelog.gz
/usr/share/doc/libautobox-perl/copyright
/usr/share/man/man3/autobox.3pm.gz

Changelog

2013-10-27 - Florian Schlichting <fsfs@debian.org>
libautobox-perl (2.82-1) unstable; urgency=low
* Team upload
* Import Upstream version 2.82
* Remove lintian override for hardening-no-fortify-functions, seems to be
detected properly now
2013-05-01 - Xavier Guimard <x.guimard@free.fr>
libautobox-perl (2.79-1) unstable; urgency=low
* Imported Upstream version 2.79
2013-02-25 - Xavier Guimard <x.guimard@free.fr>
libautobox-perl (2.77-1) unstable; urgency=low
[ Xavier Guimard ]
* Imported Upstream version 2.77
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
2012-11-23 - Xavier Guimard <x.guimard@free.fr>
libautobox-perl (2.76-1) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Angel Abad ]
* Email change: Angel Abad -> angel@debian.org
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Xavier Guimard ]
* Imported Upstream version 2.76
* Bump Standards-Version to 3.9.4
* Update copyright (years and format)
* Use debhelper 9.20120312
* Add lintian-overrides to remove false-positive lintian report
2011-07-22 - Angel Abad <angelabad@gmail.com>
libautobox-perl (2.75-1) unstable; urgency=low
* New upstream release
* debian/patches/fix-pod-spelling.patch:
- Remove patch, applied upstream
2011-07-20 - Angel Abad <angelabad@gmail.com>
libautobox-perl (2.74-1) unstable; urgency=low
* New upstream release
* Bump Debhelper compat level to 8.
* Bump Standards-Version to 3.9.2 (no changes)
2011-01-29 - Angel Abad <angelabad@gmail.com>
libautobox-perl (2.72-1) unstable; urgency=low
* New upstream release
* debian/copyright:
- Update copyright years
- Update license stanzas
2010-09-30 - Angel Abad <angelabad@gmail.com>
libautobox-perl (2.71-1) unstable; urgency=low
* New upstream release
* debian/control:
- Add versioned {Build-}Depends to libscope-guard-perl (>= 0.20)
- Add myself to Uploaders
* debian/copyright:
- Update Maintainer email
- Update license information
* Bump Standards-Version to 3.9.1 (no changes)
2010-03-18 - Jonathan Yu <jawnsy@cpan.org>
libautobox-perl (2.70-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Standards-Version 3.8.4 (no changes)
* Update to new DEP5 format
* Use new 3.0 (quilt) source format
* Add a patch to fix POD spelling errors
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ Ryan Niebur ]
* Update jawnsy's email address
[ gregor herrmann ]
* debian/copyright: update years of upstream copyright.
2009-08-07 - Jonathan Yu <frequency@cpan.org>
libautobox-perl (2.55-1) unstable; urgency=low
* Initial Release. (Closes: #479221)

See Also

Package Description
libautocomplete-java-doc_2.5.0-1_all.deb Java library for auto-completion in text component (documentation)
libautocomplete-java_2.5.0-1_all.deb Java library for auto-completion in text component
libautodie-perl_2.25-1_all.deb Perl pragma to make certain failures fatal
libautomaton-java_1.11-8+dfsg1-1_all.deb Finite-State Automaton for Regular Expressions
libautounit-dev_0.20.1-4_amd64.deb Development files for C unit testing framework
libautounit2_0.20.1-4_amd64.deb C unit testing framework interfacing well with autotools
libautovivification-perl_0.12-1+b1_amd64.deb pragma for lexically disabling autovivification
libav-doc_11.12-1~deb8u1_all.deb Documentation of the Libav API
libav-tools_11.12-1~deb8u1_amd64.deb Multimedia player, encoder and transcoder
libavahi-cil-dev_0.6.19-4.2_all.deb CLI bindings for Avahi
libavahi-client-dev_0.6.31-5_amd64.deb Development files for the Avahi client library
libavahi-client3_0.6.31-5_amd64.deb Avahi client library
libavahi-common-data_0.6.31-5_amd64.deb Avahi common data files
libavahi-common-dev_0.6.31-5_amd64.deb Development files for the Avahi common library
libavahi-common3_0.6.31-5_amd64.deb Avahi common library
Advertisement
Advertisement