libauthen-radius-perl_0.24-1_all.deb


Advertisement

Description

libauthen-radius-perl - module to authenticate users using RADIUS

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libauthen-radius-perl
Package version: 0.24
Package release: 1
Package architecture: all
Package type: deb
Installed size: 127 B
Download size: 47.53 KB
Official Mirror: ftp.br.debian.org
Authen::Radius is a Perl module that supports authentication of credentials against a RADIUS database. It also permits retrieval and modification of a user's settings. Name/value attribute pairs are automatically translated by the loaded dictionary.

Alternatives

Requires

    Download

    Source package: libauthen-radius-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libauthen-radius-perl deb package:
      # sudo apt-get install libauthen-radius-perl

    Files

    • /usr/share/doc/libauthen-radius-perl/NEWS.Debian.gz
    • /usr/share/doc/libauthen-radius-perl/changelog.Debian.gz
    • /usr/share/doc/libauthen-radius-perl/changelog.gz
    • /usr/share/doc/libauthen-radius-perl/copyright
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.ascend.gz
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.cisco.gz
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.compat
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.gz
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.livingston
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.quintum.gz
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.rfc2869
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.shiva
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.tunnel
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.usr.gz
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.versanet
    • /usr/share/doc/libauthen-radius-perl/raddb/dictionary.xtradius
    • /usr/share/man/man3/Authen::Radius.3pm.gz
    • /usr/share/perl5/Authen/Radius.pm

    Changelog

    2014-01-10 - Salvatore Bonaccorso <carnil@debian.org> libauthen-radius-perl (0.24-1) unstable; urgency=low * Team upload. * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs * Imported Upstream version 0.24 * Update copyright years for upstream files * Declare compliance with Debian policy 3.9.5 * Refresh 01_radius_port.patch (offset) * Refresh 02_use_dumper.patch patch

    2012-11-18 - Xavier Guimard <x.guimard@free.fr> libauthen-radius-perl (0.22-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Xavier Guimard ] * New upstream version 0.22 * Bump Standards-Version to 3.9.4 * Use debhelper 8 * Update copyright (years, authors and format) * Update patches

    2010-12-24 - Jonathan Yu <jawnsy@cpan.org> libauthen-radius-perl (0.20-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release + Improved support for CoA + Adds support for dictionaries in FreeRADIUS format + Partial support for WiMAX attributes + Now supports multiple RADIUS servers (i.e. a cluster) * Standards-Version 3.9.1 (no changes) * Use new 3.0 (quilt) source format * RADIUS port patch is now a documentation fix only * Refresh patch to use Data::Dumper instead of HexDump

    2010-01-17 - Jonathan Yu <jawnsy@cpan.org> libauthen-radius-perl (0.17-1) unstable; urgency=low * New upstream release * Refresh patches * Update copyright to DEP5 format * No longer install README in .docs * Rename README.Debian to NEWS, as it seems more appropriate

    2009-11-01 - Jonathan Yu <jawnsy@cpan.org> libauthen-radius-perl (0.15-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Wrote a better control description * Added myself to Copyright and Uploaders [ gregor herrmann ] * Refresh patches.

    2009-08-18 - Italo Valcy <italo@dcc.ufba.br> libauthen-radius-perl (0.14-1) unstable; urgency=low [ gregor herrmann ] * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza). Removed: XS- Vcs-Svn fields. * debian/watch: use dist-based URL. * Change patch system from dpatch to quilt. * Refresh debian/rules, no functional changes. * Add debian/README.source to document quilt usage, as required by Debian Policy since 3.8.0. * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). * debian/control: remove Replaces/Conflicts: libradius-authen-perl (introduced 2001, the package is not in Debian anymore). [ Italo Valcy ] * New upstream release. * debian/control: Set Standards-Version to 3.8.3; update homepage; update description to make easier to find the package; update Gregor's e-mail; bump debhelper and quilt build dependencies. * debian/copyright: using the new copyright format; the module is now released under Artistic-2.0; put the people from the changelog trailer lines. * debian/rules: Simplified. * debian/watch: Updated using regexp example from another package. * debian/patches/*: simplified headers in the patches; included patch to ingnore install-radius-db.PL script.

    2007-04-13 - gregor herrmann <gregor+debian@comodo.priv.at> libauthen-radius-perl (0.13-1) unstable; urgency=low * New upstream release. * Set Standards-Version to 3.7.2 (no changes). * Adjust patch 02_use_dumper.

    2006-02-13 - Niko Tyni <ntyni@iki.fi> libauthen-radius-perl (0.12-2) unstable; urgency=low * Adopt the package for the Debian Perl Group. (Closes: #314851) * Don't ignore the result of 'make distclean'. * Move debhelper and dpatch to Build-Depends, as they are required for the 'clean' target. * Add dependency on dpatch >= 2.0.9, for /usr/share/dpatch/dpatch-run. * Upgrade to debhelper compatibility level 5. * Add dependency on ${misc:Depends}, as recommended by debhelper. * Point debian/watch to mirrors.kernel.org/cpan instead of www.cpan.org.

    Advertisement
    Advertisement