libauthen-krb5-perl_1.9-4+b1_amd64.deb


Advertisement

Description

libauthen-krb5-perl - Perl interface to Kerberos 5 API

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libauthen-krb5-perl
Package version 1.9
Package release 4+b1
Package architecture amd64
Package type deb
Installed size 220 B
Download size 48.27 KB
Official Mirror ftp.br.debian.org
Authen::Krb5 is a Perl module providing an object-oriented interface to the
Kerberos 5 API. It rearranges the API slightly to provide an object-oriented
view, but otherwise closely matches the C interface. Use may require previous
experience with Kerberos 5 programming or reference to the Kerberos 5 API
documentation.
This package is built against the MIT Kerberos 5 libraries.

Alternatives

Package Version Architecture Repository
libauthen-krb5-perl_1.9-4+b1_i386.deb 1.9 i386 Debian Main
libauthen-krb5-perl - - -

Requires

Name Value
libc6 >= 2.4
libcomerr2 >= 1.01
libk5crypto3 >= 1.6.dfsg.2
libkrb5-3 >= 1.7dfsg
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libauthen-krb5-perl_1.9-4+b1_amd64.deb
Source Package libauthen-krb5-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libauthen-krb5-perl deb package:
    # sudo apt-get install libauthen-krb5-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Authen/Krb5.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Authen/Krb5/Krb5.so
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Authen/Krb5/autosplit.ix
/usr/share/doc/libauthen-krb5-perl/changelog.Debian.amd64.gz
/usr/share/doc/libauthen-krb5-perl/changelog.Debian.gz
/usr/share/doc/libauthen-krb5-perl/changelog.gz
/usr/share/doc/libauthen-krb5-perl/copyright
/usr/share/doc/libauthen-krb5-perl/examples/sample_client
/usr/share/doc/libauthen-krb5-perl/examples/sample_server
/usr/share/doc/libauthen-krb5-perl/examples/simple_client
/usr/share/doc/libauthen-krb5-perl/examples/simple_server
/usr/share/man/man3/Authen::Krb5.3pm.gz

Changelog

2014-03-15 - Florian Schlichting <fsfs@debian.org>
libauthen-krb5-perl (1.9-4) unstable; urgency=low
* Team upload
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Florian Schlichting ]
* Switch dh compatibility to level 9 to enable passing of hardening flags
* Declare compliance with Debian Policy 3.9.5
* Forward fix_pod patch
2011-04-10 - gregor herrmann <gregoa@debian.org>
libauthen-krb5-perl (1.9-3) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Update Homepage field.
* Email change: Ansgar Burchardt -> ansgar@debian.org
[ gregor herrmann ]
* New version of patch better-compiler-flags: use krb5-config to query the
necessary library options; thanks to Steve Langasek for forwarding the
patch from Ubuntu (closes: #622090).
* debian/copyright: update formatting.
* Add /me to Uploaders.
* Switch to debhelper 8.
* Set Standards-Version to 3.9.2 (no further changes).
2010-01-24 - Ansgar Burchardt <ansgar@43-1.org>
libauthen-krb5-perl (1.9-2) unstable; urgency=low
[ Ansgar Burchardt ]
* Introduce patch to make init_context() return the context as documented.
(new patch: fix-init_context.patch)
* Switch to source format 3.0 (quilt).
* Add myself to Uploaders.
[ gregor herrmann ]
* debian/watch: use extended regexp to match upstream versions.
2010-01-05 - Jonathan Yu <jawnsy@cpan.org>
libauthen-krb5-perl (1.9-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Move examples -> libauthen-krb5-perl.examples
* Use new debhelper 7 short rules file
* Add myself to Uploaders and Copyright
* Standards-Version 3.8.3 (drop perl version dep)
* Slight rewrite of control description
* Remove perl-path patch, replace with override
* Refresh all remaining patches
* Add DEP3 patch headers
* No longer install README or TODO, same info in POD
* Refresh copyright to new DEP5 format
[ gregor herrmann ]
* Add debian/README.source to document quilt usage, as required by
Debian Policy since 3.8.0.
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
[ Maximilian Gaß ]
* Added patch for manpage-has-errors-from-pod2man
2008-03-17 - Roberto C. Sanchez <roberto@debian.org>
libauthen-krb5-perl (1.8-1) unstable; urgency=low
* New upstream release.
* debian/patches/fix-get-in-tkt-with-password: Removed.  Included upstream.
* debian/patches/warning-cleanup: Removed.  Included upstream.
2008-03-08 - Russ Allbery <rra@debian.org>
libauthen-krb5-perl (1.7-2) unstable; urgency=low
* Fix the krb5_get_in_tkt_with_password backwards-compatibility
interface to call the correct new function instead of the old
function with the wrong arguments.
* New patch warnings-cleanup:
- Request prototypes of private functions from the Kerberos library
headers so that we get compiler diagnostics of argument mismatches
and prototype all functions.
- Prototype the unprototyped functions we call anyway.
- Clean up some other minor compiler warnings.
* Patch cleanup:
- Remove extraneous .patch file suffixes and rename patches.
- Remove unnecessary time stamps and patch headers.
- Add explanatory comments to each patch.
* Touch Makefile before make distclean so that Perl doesn't try to
rebuild it from Makefile.PL after removing the patch.
* Use a distribution-based watch URL.
* Minor debian/rules cleanup.

See Also

Package Description
libauthen-krb5-simple-perl_0.43-2+b2_amd64.deb Perl module for authentication using Kerberos 5
libauthen-ntlm-perl_1.09-1_all.deb authentication module for NTLM
libauthen-oath-perl_1.0.0-1_all.deb Perl module for OATH One Time Passwords
libauthen-pam-perl_0.16-3+b1_amd64.deb Perl interface to PAM library
libauthen-passphrase-perl_0.008-1_all.deb Perl module encapsulating hashed passwords/passphrases as objects
libauthen-radius-perl_0.24-1_all.deb module to authenticate users using RADIUS
libauthen-sasl-cyrus-perl_0.13-server-10+b1_amd64.deb Perl extension for Cyrus SASL library
libauthen-sasl-perl_2.1600-1_all.deb Authen::SASL - SASL Authentication framework
libauthen-simple-cdbi-perl_0.2-2_all.deb Simple CDBI authentication
libauthen-simple-dbi-perl_0.2-2_all.deb Simple DBI authentication
libauthen-simple-dbm-perl_0.2-3_all.deb module to allow simple DBM authentication
libauthen-simple-http-perl_0.2-4_all.deb module to allow the use of simple HTTP authentication
libauthen-simple-kerberos-perl_0.1-4_all.deb module to allow the use of simple Kerberos authentication methods
libauthen-simple-ldap-perl_0.3-1_all.deb module for simple LDAP authentication
libauthen-simple-net-perl_0.2-4_all.deb module to use simple NET authentication methods
Advertisement
Advertisement