libauthen-krb5-admin-perl_0.17-1+b2_amd64.deb


Advertisement

Description

libauthen-krb5-admin-perl - Perl extension for MIT Kerberos 5 admin interface

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libauthen-krb5-admin-perl
Package version 0.17
Package release 1+b2
Package architecture amd64
Package type deb
Installed size 124 B
Download size 41.67 KB
Official Mirror ftp.br.debian.org
The Authen::Krb5::Admin Perl module is an object-oriented interface to
the MIT Kerberos 5 admin server.  This allows creation, deletion,
renaming, and examination of Kerberos principals, changing passwords or
keys, and changing policy settings in the KDC.
This module only supports the MIT Kerberos admin protocol.  For Heimdal
KDCs, see libheimdal-kadm5-perl instead.

Alternatives

Package Version Architecture Repository
libauthen-krb5-admin-perl_0.17-1+b2_i386.deb 0.17 i386 Debian Main
libauthen-krb5-admin-perl - - -

Requires

Name Value
libauthen-krb5-perl -
libc6 >= 2.14
libcomerr2 >= 1.01
libkadm5clnt-mit9 >= 1.12~alpha1+dfsg
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libauthen-krb5-admin-perl_0.17-1+b2_amd64.deb
Source Package libauthen-krb5-admin-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libauthen-krb5-admin-perl deb package:
    # sudo apt-get install libauthen-krb5-admin-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Authen/Krb5/Admin.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Authen/Krb5/Admin/Admin.so
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Authen/Krb5/Admin/autosplit.ix
/usr/share/doc/libauthen-krb5-admin-perl/changelog.Debian.amd64.gz
/usr/share/doc/libauthen-krb5-admin-perl/changelog.Debian.gz
/usr/share/doc/libauthen-krb5-admin-perl/changelog.gz
/usr/share/doc/libauthen-krb5-admin-perl/copyright
/usr/share/man/man3/Authen::Krb5::Admin.3pm.gz

Changelog

2013-08-30 - gregor herrmann <gregoa@debian.org>
libauthen-krb5-admin-perl (0.17-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.15, 0.16 and 0.17
Closes: #721288
* Bump Standards-Version to 3.9.4
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Use debhelper 9.20120312 to get all hardening flags.
* Add patch to fix POD warnings with perl 5.18.
* Update years of packaging copyright.
2012-05-17 - Salvatore Bonaccorso <carnil@debian.org>
libauthen-krb5-admin-perl (0.13-1) unstable; urgency=low
* Team upload.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.13
* Drop link_less_libraries.diff patch.
Patch was applied upstream.
* Drop use_1_7_admin_interface.patch patch.
Upstream now uses the Kerberos admin.h rather than a local copy.
* Update debian/copyright information.
Update format to copyright-format 1.0 as released together with Debian
policy 3.9.3.
Update Upstream-Contact to refer to the new author of Authen-Krb5-Admin.
Update copyright years for included ppport.h.
* Bump Standards-Version to 3.9.3
* Bump Debhelper compat level to 9.
Adjust versioned Build-Depends on debhelper to (>= 9).
2011-03-31 - Russ Allbery <rra@debian.org>
libauthen-krb5-admin-perl (0.11-4) unstable; urgency=medium
[ Ansgar Burchardt ]
* Update my email address.
[ Russ Allbery ]
* Urgency medium to allow the krb5 package to migrate faster.
* Expand the long description to say what types of Kerberos operations
this module allows.  Add a pointer to libheimdal-kadm5-perl for
Heimdal KDCs.  Remove the note that the author envisions support for
other KDC implementations; it's been nine years and this hasn't
happened, so it's probably not imminent.
* Update debian/copyright to the current draft DEP-5 format and add some
additional copyright statements.  Change the GPL pointer to the GPL v1
text now that it's in common-licenses.
* Add myself to Uploaders.
* Update debhelper compatibility level to V8.
* Update standards version to 3.9.1 (no changes required).
2010-01-24 - Ansgar Burchardt <ansgar@43-1.org>
libauthen-krb5-admin-perl (0.11-3) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ansgar Burchardt ]
* Update patch use_1_7_admin_interface.patch for MIT Kerberos 1.8.
(Closes: #566368)
+ This requires libauthen-krb5-perl (>= 1.9-2).
* debian/control: Make build-dep on perl unversioned.
* Use source format 3.0 (quilt).
* Simplify debian/rules.
* Bump Standards-Version to 3.8.3.
2009-05-07 - gregor herrmann <gregoa@debian.org>
libauthen-krb5-admin-perl (0.11-2) unstable; urgency=low
* Add patch use_1_7_admin_interface.patch from Sam Hartman to use the new
public admin.h interface of Kerberos 1.7. Bump build dependency on
libkrb5-dev to (>= 1.7dfsg~beta1). (Closes: #527260)
* Set Standards-Version to 3.8.1 (no changes).
* Add /me to Uploaders.
2008-11-05 - Ansgar Burchardt <ansgar@43-1.org>
libauthen-krb5-admin-perl (0.11-1) unstable; urgency=low
* Initial Release (Closes: #502986)

See Also

Package Description
libauthen-krb5-perl_1.9-4+b1_amd64.deb Perl interface to Kerberos 5 API
libauthen-krb5-simple-perl_0.43-2+b2_amd64.deb Perl module for authentication using Kerberos 5
libauthen-ntlm-perl_1.09-1_all.deb authentication module for NTLM
libauthen-oath-perl_1.0.0-1_all.deb Perl module for OATH One Time Passwords
libauthen-pam-perl_0.16-3+b1_amd64.deb Perl interface to PAM library
libauthen-passphrase-perl_0.008-1_all.deb Perl module encapsulating hashed passwords/passphrases as objects
libauthen-radius-perl_0.24-1_all.deb module to authenticate users using RADIUS
libauthen-sasl-cyrus-perl_0.13-server-10+b1_amd64.deb Perl extension for Cyrus SASL library
libauthen-sasl-perl_2.1600-1_all.deb Authen::SASL - SASL Authentication framework
libauthen-simple-cdbi-perl_0.2-2_all.deb Simple CDBI authentication
libauthen-simple-dbi-perl_0.2-2_all.deb Simple DBI authentication
libauthen-simple-dbm-perl_0.2-3_all.deb module to allow simple DBM authentication
libauthen-simple-http-perl_0.2-4_all.deb module to allow the use of simple HTTP authentication
libauthen-simple-kerberos-perl_0.1-4_all.deb module to allow the use of simple Kerberos authentication methods
libauthen-simple-ldap-perl_0.3-1_all.deb module for simple LDAP authentication
Advertisement
Advertisement