libasync-interrupt-perl_1.20-1+b1_amd64.deb


Advertisement

Description

libasync-interrupt-perl - module to allow C/XS libraries to interrupt perl

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libasync-interrupt-perl
Package version: 1.20
Package release: 1+b1
Package architecture: amd64
Package type: deb
Installed size: 143 B
Download size: 33.01 KB
Official Mirror: ftp.br.debian.org
Async::Interrupt is a Perl module that implements asynchronous interruptions, similar in nature to UNIX signals, in a cross-platform manner. Modules might want to run code asynchronously (in another thread or from a signal handler) and then signal the interpreter on certain events. One common way is to write data to a pipe and use an event handling toolkit to watch for I/O events. Another way is to send a signal. Those methods are slow, and in the case of a pipe, also not asynchronous - it won't interrupt a running Perl interpreter. This module implements asynchronous notifications that enable you to signal running Perl code from another thread, asynchronously, and sometimes even without using a single syscall.

Alternatives

    Download

    Source package: libasync-interrupt-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libasync-interrupt-perl deb package:
      # sudo apt-get install libasync-interrupt-perl

    Files

    • /usr/lib/x86_64-linux-gnu/perl5/5.20/Async/Interrupt.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Async/Interrupt/Interrupt.so
    • /usr/share/doc/libasync-interrupt-perl/changelog.Debian.amd64.gz
    • /usr/share/doc/libasync-interrupt-perl/changelog.Debian.gz
    • /usr/share/doc/libasync-interrupt-perl/changelog.gz
    • /usr/share/doc/libasync-interrupt-perl/copyright
    • /usr/share/lintian/overrides/libasync-interrupt-perl
    • /usr/share/man/man3/Async::Interrupt.3pm.gz

    Changelog

    2014-05-10 - gregor herrmann <gregoa@debian.org> libasync-interrupt-perl (1.20-1) unstable; urgency=low * Team upload. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * New upstream release. * debian/copyright: use Comment instead of the deprecated X-Comment. * Declare compliance with Debian Policy 3.9.5.

    2012-06-19 - Jotam Jr. Trejo <jotamjr@debian.org.sv> libasync-interrupt-perl (1.10-1) unstable; urgency=low [ Fabrizio Regalli ] * Bump to 3.9.2 Standard-Version. * Add myself to Uploaders and Copyright. * Switch d/compat to 8. * Build-Depends: switch to debhelper (>= 8). * Fixed lintian copyright-refers-to-symlink-license message. * Updated Format-Specification url in d/copyright. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * debian/copyright: Replace DEP5 Format-Specification URL from svn.debian.org to anonscm.debian.org URL. [ gregor herrmann ] * debian/watch: pad minor version to cover single digits. [ Jotam Jr. Trejo ] * Imported Upstream version 1.10 * Changed debhelper compatibility level to 9 * debian/control: updated required debhelper version to 9 * debian/copyright: refreshed the format to use copyright-format 1.0 * Updated the Standards Version to 3.9.3 + Added lintian override to disable a no fortified functions warning since we are using the -D_FORTIFY_SOURCE=2 flag at build time * Added myself to Uploaders and Copyright

    2010-05-15 - Jonathan Yu <jawnsy@cpan.org> libasync-interrupt-perl (1.05-1) unstable; urgency=low * New upstream release

    2010-04-02 - Jonathan Yu <jawnsy@cpan.org> libasync-interrupt-perl (1.04-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Standards-Version 3.8.4 (no changes) * Use new DEP5 copyright format * Rewrite control description [ gregor herrmann ] * Convert to source format 3.0 (quilt).

    2009-09-03 - Jonathan Yu <jawnsy@cpan.org> libasync-interrupt-perl (1.02-1) unstable; urgency=low * Initial Release (Closes: #544718)

    Advertisement
    Advertisement