libassuan-dev_2.1.2-2_amd64.deb


Advertisement

Description

libassuan-dev - IPC library for the GnuPG components -- header files

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libassuan-dev
Package version: 2.1.2
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 282 B
Download size: 89.49 KB
Official Mirror: ftp.br.debian.org
Libassuan is a small library implementing the so-called "Assuan protocol". This protocol is used for IPC between most newer GnuPG components. Both server and client side functions are provided. This package contains header files and static libraries for libassuan.

Alternatives

    Download

    Source package: libassuan

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libassuan-dev deb package:
      # sudo apt-get install libassuan-dev

    Files

    • /usr/bin/libassuan-config
    • /usr/include/assuan.h
    • /usr/lib/x86_64-linux-gnu/libassuan.a
    • /usr/lib/x86_64-linux-gnu/libassuan.so
    • /usr/share/aclocal/libassuan.m4
    • /usr/share/doc-base/assuan
    • /usr/share/doc/libassuan-dev/changelog.Debian.gz
    • /usr/share/doc/libassuan-dev/changelog.gz
    • /usr/share/doc/libassuan-dev/copyright
    • /usr/share/info/assuan.info.gz
    • /usr/share/man/man1/libassuan-config.1.gz

    Changelog

    2014-08-30 - Eric Dorland <eric@debian.org> libassuan (2.1.2-2) unstable; urgency=medium * debian/control: Switch maintainer to Debian GnuPG-Maintainers. * debian/control: Move to new pkg-gnupg git repository. * Run wrap-and-sort on debian directory. Thanks dkg for showing me this tool. * debian/gbp.conf: Add git-buildpackage config and turn on pristine-tar.

    2014-08-23 - Eric Dorland <eric@debian.org> libassuan (2.1.2-1) unstable; urgency=medium * New upstream release.

    2014-08-23 - Eric Dorland <eric@debian.org> libassuan (2.1.1-2) unstable; urgency=low * debian/control: Canonicalize Vcs-Browser field. * debian/watch, debian/upstream/signing-key.asc: Add upstream signing key for the watch file. * debian/control: Fix descriptions to be more descriptive. * debian/control: Upgrade Standards-Version to 3.9.5. * debian/control, debian/rules: Use dh-autoreconf. (Closes: #752025)

    2013-07-27 - Eric Dorland <eric@debian.org> libassuan (2.1.1-1) unstable; urgency=low * New upstream release. * debian/control: Fix Vcs-Git to point at the right location.

    2013-05-06 - Eric Dorland <eric@debian.org> libassuan (2.1.0-1) unstable; urgency=low * New upstream release. * debian/control: Depend on version 9 or later for debhelper. * debian/control: Update Standards-Version to 3.9.4. * debian/control, debian/rules: Use autotools-dev to update autotools helper files. * debian/libassuan0.symbols: Add new symbols in 2.1.0.

    2012-02-04 - Eric Dorland <eric@debian.org> libassuan (2.0.3-1) unstable; urgency=low * New upstream release. * debian/rules, debian/control: Drop hardening-wrapper, now that we have dpkg-buildflags.

    2011-07-05 - Eric Dorland <eric@debian.org> libassuan (2.0.2-1) unstable; urgency=low * New upstream release. * debian/compat, debian/control: Update to debhelper v9. * debian/control, debian/libassuan0.install, debian/libassuan-dev.install: Add Multi-Arch support. * debian/libassuan0.symbols: Add new symbols for 2.0.2. * debian/control: Upgrade Standards-Version to 3.9.2.

    2011-02-14 - Eric Dorland <eric@debian.org> libassuan (2.0.1-3) unstable; urgency=low * debian/rules, debian/libassuan-dev.install: Build static libraries and install them in the -dev package. * debian/rules, debian/control: Add -dbg package.

    2011-02-12 - Eric Dorland <eric@debian.org> libassuan (2.0.1-2) unstable; urgency=low * debian/control: - Upgrade Standards-Version to 3.9.1. - Add ${misc:Depends} to package Depends. - Add dependency on dpkg (>= 1.15.4) | install-info for info file. * debian/libassuan0.symbols: Add a symbols file. * debian/libassuan-dev.doc-base: Set Section to Programming/C.

    2011-02-12 - Eric Dorland <eric@debian.org> libassuan (2.0.1-1) unstable; urgency=low * New upstream release. (Closes: #568669) * debian/compat, debian/control, debian/rules: Convert to debhelper 8, drop cdbs. * debian/control: - Add Build Depends on libgpg-error-dev. - Drop Build Depends on libpth-dev. - Make libassuan0's section libs. * debian/control, debian/libassuan-dev.install, debian/libassuan0.install: New binary package libassuan0 since libassuan is now built as a shared lib. * debian/control, debian/rules: Build with hardening-wrapper. * debian/source/format: Use 3.0 (quilt) source format.

    Advertisement
    Advertisement