libassa3.5-5_3.5.1-4_amd64.deb


Advertisement

Description

libassa3.5-5 - object-oriented C++ networking library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libassa3.5-5
Package version 3.5.1
Package release 4
Package architecture amd64
Package type deb
Installed size 904 B
Download size 232.88 KB
Official Mirror ftp.br.debian.org
libASSA is an object-oriented C++ networking library based on Adaptive
Communication Patterns. It features a simplistic implementation of the set
of communication patterns such as Service Configurator, Reactor, Acceptor,
Connector, and others described in various papers published by
Dr. D. C. Schmidt.
libASSA happily co-exists with other frameworks such as GUI toolkits and
various CORBA implementations
This package contains the shared libraries.

Alternatives

Package Version Architecture Repository
libassa3.5-5_3.5.1-4_i386.deb 3.5.1 i386 Debian Main
libassa3.5-5 - - -

Requires

Name Value
libc6 >= 2.15
libgcc1 >= 1:4.1.1
libstdc++6 >= 4.9
multiarch-support -

Conflicts

Name Value
libassa0 -

Replaces

Name Value
libassa0 -

Download

Type URL
Binary Package libassa3.5-5_3.5.1-4_amd64.deb
Source Package libassa

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libassa3.5-5 deb package:
    # sudo apt-get install libassa3.5-5

Files

Path
/usr/lib/x86_64-linux-gnu/libassa-3.5.so.5
/usr/lib/x86_64-linux-gnu/libassa-3.5.so.5.0.1
/usr/share/doc/libassa3.5-5/changelog.Debian.gz
/usr/share/doc/libassa3.5-5/changelog.gz
/usr/share/doc/libassa3.5-5/copyright

Changelog

2014-08-27 - Eric Dorland <eric@debian.org>
libassa (3.5.1-4) unstable; urgency=medium
* debian/control: Standards-Version to 3.9.5.
* debian/control: Fix Vcs headers.
* debian/control, debian/rules: Switch to dh-autoreconf. (Closes: #734024)
2013-11-11 - Eric Dorland <eric@debian.org>
libassa (3.5.1-3) unstable; urgency=low
* debian/control, debian/rules: Use autotools-dev to update
config.{guess,sub}. (Closes: #727393)
* debian/control: Standards-Version to 3.9.4.
2012-06-19 - Eric Dorland <eric@debian.org>
libassa (3.5.1-2) unstable; urgency=high
* Urgency high to beat the freeze.
* debian/control: -dev package should depend on libtirpc-dev.
* debian/control: Make shlib and dbg package Multi-Arch aware.
2012-06-12 - Eric Dorland <eric@debian.org>
libassa (3.5.1-1) unstable; urgency=medium
* New upstream release.
* Urgency medium to try and beat the freeze.
* debian/source/format: Use 3.0 quilt source format.
* debian/compat, debian/control, debian/rules: Switch dh.
* debian/patches/0001-patch-relibtoolize.patch: Remove unneeded patch.
* debian/control: Add build depends on libtirpc-dev.
* debian/rules: Don't run make check.
* debian/patches/01-include-fixes.diff: Move include file fixes to patch.
* debian/control: Standards-Version to 3.9.3.
* debian/control: Move libassa3.5-5-dbg to section: debug.
* debian/control: Add ${misc:Depends} to all packages.
* debian/control: Add build depends on pkg-config.
* debian/libassa3.5-5-dev.install, debian/libassa3.5-5.install: Update
for multi-arch lib paths.
2012-05-04 - Matthias Klose <doko@debian.org>
libassa (3.5.0-1.3) unstable; urgency=low
* Non-maintainer upload.
* Fix build failure with GCC 4.7. Closes: #667192.
2012-02-18 - Picca Frédéric-Emmanuel <picca@debian.org>
libassa (3.5.0-1.2) unstable; urgency=low
* Non-maintainer upload.
* relibtoolize (Closes: #649138)
2009-12-21 - David Paleino <dapal@debian.org>
libassa (3.5.0-1.1) unstable; urgency=low
* Non-maintainer upload.
* Fix FTBFS with GCC 4.4, thanks to Martin Michlmayr (Closes: #504943)
2008-03-02 - Eric Dorland <eric@debian.org>
libassa (3.5.0-1) unstable; urgency=low
* New upstream release.
* The library is now libassa-3.5.so.5. Clearly someone upstream doesn't get 
sonames. Lots of renames for the new package name.
* debian/control: Add Homepage and Vcs-* headers.
2008-01-17 - Eric Dorland <eric@debian.org>
libassa (3.4.2-3) unstable; urgency=low
* debian/control:
- Use binary:Version instead of Source-Version.
- Add ${shlibs:Depends} to libassa3.4-0-dev Depends.
- Update Standards-Version to 3.7.3.
2007-04-29 - Eric Dorland <eric@debian.org>
libassa (3.4.2-2) unstable; urgency=low
* debian/control: 
- -dbg package Priority to extra, to match the override.
- Add Section: libs to source header. 
* assa/Reactor.cpp: Apply patch from #385800 and acknowledge
NMU. (Closes: #385800)
* assa/INETAddress.cpp, assa/FdSet.h: Fix from Martin Michlmayr to build
with gcc 4.3. (Closes: #420897)

See Also

Package Description
libassimp-dev_3.0~dfsg-3_amd64.deb 3D model import library (development)
libassimp-doc_3.0~dfsg-3_all.deb 3D model import library (documentation)
libassimp3_3.0~dfsg-3_amd64.deb 3D model import library
libassuan-dev_2.1.2-2_amd64.deb IPC library for the GnuPG components -- header files
libassuan0_2.1.2-2_amd64.deb IPC library for the GnuPG components
libast2-dev_0.7-7_amd64.deb libast2 development files
libast2_0.7-7_amd64.deb Library of Assorted Spiffy Things
libasterisk-agi-perl_1.01-2_all.deb Collections of Perl modules to be used with Asterisk PBX AGI
libastro-dev_4.14.2-1_amd64.deb development files for the Marble astrononmy library
libastro-fits-cfitsio-perl_1.10-1+b2_amd64.deb Perl extension for using the cfitsio library
libastro-fits-header-perl_3.07-1_all.deb module for reading, modifying and writing FITS headers
libastro1_4.14.2-1_amd64.deb Marble astronomy library
libastyle-dev_2.04-1_amd64.deb Library header files for Artistic Style
libastyle0debian0_2.04-1_amd64.deb Shared library for Artistic Style
libastylej-jni_2.04-1_amd64.deb Java JNI library for Artistic Style
Advertisement
Advertisement