libarray-iterator-perl_0.11-1_all.deb


Advertisement

Description

libarray-iterator-perl - simple class to provide iterators over Perl arrays

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libarray-iterator-perl
Package version: 0.11
Package release: 1
Package architecture: all
Package type: deb
Installed size: 89 B
Download size: 25.67 KB
Official Mirror: ftp.br.debian.org
Array::Iterator Perl module provides a very simple iterator interface. It is uni-directional and can only be used once. It provides no means of reversing or resetting the iterator. It is not recommended to alter the array during iteration, however no attempt is made to enforce this. This class only intends to provide a clear and simple means of generic iteration, nothing more (yet). This package also provides: * Array::Iterator::BiDirectional to allow forward and backward iteration * Array::Iterator::Circular to allow circular iteration * Array::Iterator::Reusable to allow reuse of iterators

Alternatives

Requires

    Download

    Source package: libarray-iterator-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libarray-iterator-perl deb package:
      # sudo apt-get install libarray-iterator-perl

    Files

    • /usr/share/doc/libarray-iterator-perl/changelog.Debian.gz
    • /usr/share/doc/libarray-iterator-perl/changelog.gz
    • /usr/share/doc/libarray-iterator-perl/copyright
    • /usr/share/man/man3/Array::Iterator.3pm.gz
    • /usr/share/man/man3/Array::Iterator::BiDirectional.3pm.gz
    • /usr/share/man/man3/Array::Iterator::Circular.3pm.gz
    • /usr/share/man/man3/Array::Iterator::Reusable.3pm.gz
    • /usr/share/perl5/Array/Iterator.pm
    • /usr/share/perl5/Array/Iterator/BiDirectional.pm
    • /usr/share/perl5/Array/Iterator/Circular.pm
    • /usr/share/perl5/Array/Iterator/Reusable.pm

    Changelog

    2013-09-18 - gregor herrmann <gregoa@debian.org> libarray-iterator-perl (0.11-1) unstable; urgency=low * Team upload. * New upstream releases 0.10, 0.11. * Drop patch fix-spelling: merged upstream. * Add new build dependency.

    2013-09-17 - gregor herrmann <gregoa@debian.org> libarray-iterator-perl (0.09-1) unstable; urgency=low * Team upload * New upstream release. * Update patches. Drop fix-whatis-entry (fixed upstream), refresh (offset) and forward fix-spelling. * Stop installing README. Text version of the POD. * Update years of upstream copyright. * Declare compliance with Debian Policy 3.9.4.

    2013-03-26 - Alessandro Ghedini <ghedo@debian.org> libarray-iterator-perl (0.8-2) unstable; urgency=low * Team upload [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Alessandro Ghedini ] * Remove useless Depends on libarray-iterator-perl (Closes: #703984)

    2012-10-07 - Dominique Dumont <dod@debian.org> libarray-iterator-perl (0.8-1) unstable; urgency=low * Initial Release. (Closes: #689711)

    Advertisement
    Advertisement