libapache2-reload-perl_0.12-3_all.deb


Advertisement

Description

libapache2-reload-perl - module for reloading Perl modules when changed on disk

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libapache2-reload-perl
Package version: 0.12
Package release: 3
Package architecture: all
Package type: deb
Installed size: 68 B
Download size: 16.94 KB
Official Mirror: ftp.br.debian.org
Apache2::Reload reloads modules that change on the disk. When Perl pulls a file via "require", it stores the filename in the global hash %INC. The next time Perl tries to "require" the same file, it sees the file in %INC and does not reload from disk. This module's handler can be configured to iterate over the modules in %INC and reload those that have changed on disk. It can also monitor only specific modules that have registered themselves with Apache2::Reload. It is possible to trigger the check only when a special touch-file has been modified, minimizing the number of stat() calls per request.

Alternatives

    Download

    Source package: libapache2-reload-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libapache2-reload-perl deb package:
      # sudo apt-get install libapache2-reload-perl

    Files

    • /usr/share/doc/libapache2-reload-perl/changelog.Debian.gz
    • /usr/share/doc/libapache2-reload-perl/changelog.gz
    • /usr/share/doc/libapache2-reload-perl/copyright
    • /usr/share/man/man3/Apache2::Reload.3pm.gz
    • /usr/share/perl5/Apache2/Reload.pm

    Changelog

    2014-07-17 - gregor herrmann <gregoa@debian.org> libapache2-reload-perl (0.12-3) unstable; urgency=medium * debian/control: remove Nicholas Bamber from Uploaders on request of the MIA team. * Strip trailing slash from metacpan URLs. * Add patch from mod_perl upstream to fix build failure with Perl 5.20. Thanks to Niko Tyni for digging out the patch. (Closes: #754999) * Update years of packaging copyright. * Declare compliance with Debian Policy 3.9.5.

    2013-06-03 - gregor herrmann <gregoa@debian.org> libapache2-reload-perl (0.12-2) unstable; urgency=low [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Apache 2.4 transition: - debian/control: build-depend on apache2-dev - add a minimal debian/apache2.conf and use it in debian/rules for the test suite Closes: #666799 * Set Standards-Version to 3.9.4 (no changes).

    2012-06-16 - gregor herrmann <gregoa@debian.org> libapache2-reload-perl (0.12-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * New upstream release. * Drop spelling.patch, merged upstream. * debian/copyright: update to Copyright-Format 1.0. * Update years of packaging copyright. * Bump Standards-Version to 3.9.3 (no changes). * Set debhelper compatibility level to 8. * Add /me to Uploaders.

    2011-01-10 - Nicholas Bamber <nicholas@periapt.co.uk> libapache2-reload-perl (0.11-2) unstable; urgency=low * Override home directory (Closes: #609402) * Adding debian/clean file to clean up generated files * Updated copyright

    2010-10-23 - Nicholas Bamber <nicholas@periapt.co.uk> libapache2-reload-perl (0.11-1) unstable; urgency=low [ gregor herrmann ] * debian/copyright: point to /usr/share/common-licenses/Apache-2.0 instead of including the full text of the Apache 2.0 license. * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ gregor herrmann ] * Make short description a noun phrase. * Set Standards-Version to 3.9.1; replace Conflicts with Breaks. [ Nicholas Bamber ] * Added myself to uploaders * New upstream release * echo '3.0 (quilt)' > debian/source/format * Added patch for spelling mistake * Upped debhelper dependency to 7.0.50~ for overrides * Modernized build rules [ gregor herrmann ] * debian/rules: run configure and tests as user www-data. [ Nicholas Bamber ] * Removed Breaks/Replaces clauses from control * Removed versioned dependency on perl * Refreshed copyright

    2008-05-08 - Damyan Ivanov <dmn@debian.org> libapache2-reload-perl (0.10-2) unstable; urgency=low * debian/control: add forgotten Conflicts/Replaces: libapache2-mod-perl2 (<< 2.0.4~rc1).

    2008-05-08 - Damyan Ivanov <dmn@debian.org> libapache2-reload-perl (0.10-1) unstable; urgency=low * Initial Release. Closes: #475151

    Advertisement
    Advertisement