libapache2-mod-proxy-msrpc_0.5-1_amd64.deb


Advertisement

Description

libapache2-mod-proxy-msrpc - Apache module for Outlook Anywhere support in reverse proxy setups

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libapache2-mod-proxy-msrpc
Package version: 0.5
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 69 B
Download size: 23.29 KB
Official Mirror: ftp.br.debian.org
This module intends to make Apache httpd work in a reverse proxy setup in front of a MS Exchange server offering Outlook Anywhere services. Without it, Apache would block any Outlook Anywhere requests as the used protocol does not fully comply with HTTP standards. The mod_proxy_msrpc module detects the used MSRPC messages and forwards them to the server or client as needed. As soon as the initial handshake completed, i.e. Exchange accepted the connecting client, the mod_proxy_msrpc module switches into tunnel mode and forwards all data from client to server and vice versa.

Alternatives

    Download

    Source package: mod-proxy-msrpc

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libapache2-mod-proxy-msrpc deb package:
      # sudo apt-get install libapache2-mod-proxy-msrpc

    Files

    • /etc/apache2/mods-available/proxy_msrpc.load
    • /usr/lib/apache2/modules/mod_proxy_msrpc.so
    • /usr/share/doc/libapache2-mod-proxy-msrpc/README.pod
    • /usr/share/doc/libapache2-mod-proxy-msrpc/TODO
    • /usr/share/doc/libapache2-mod-proxy-msrpc/changelog.Debian.gz
    • /usr/share/doc/libapache2-mod-proxy-msrpc/copyright

    Changelog

    2014-04-29 - Micha Lenk <micha@debian.org> mod-proxy-msrpc (0.5-1) unstable; urgency=medium * New upstream version * Don't let apxs hide the used build flags by setting LTFLAGS. * Use autoreconf helper on newer arches to correctly build shared library. Thanks to Daniel T Chen <crimsun@ubuntu.com> for providing the patch via Ubuntu.

    2014-02-03 - Micha Lenk <micha@debian.org> mod-proxy-msrpc (0.4-1) unstable; urgency=low * New upstream version * Package is compliant to Debian Policy 3.9.5 (no changes needed). * Correctly attribute copyright ownership to Astaro.

    2013-11-04 - Micha Lenk <micha@debian.org> mod-proxy-msrpc (0.2-1) unstable; urgency=low * Initial release (Closes: #728713)

    Advertisement
    Advertisement