libapache2-mod-php5_5.6.30+dfsg-0+deb8u1_amd64.deb


Advertisement

Description

libapache2-mod-php5 - server-side, HTML-embedded scripting language (Apache 2 module)

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libapache2-mod-php5
Package version: 5.6.30+dfsg
Package release: 0+deb8u1
Package architecture: amd64
Package type: deb
Installed size: 9.47 KB
Download size: 2.13 MB
Official Mirror: ftp.br.debian.org
This package provides the PHP5 module for the Apache 2 webserver (as found in the apache2-mpm-prefork package). Please note that this package ONLY works with Apache's prefork MPM, as it is not compiled thread-safe. The following extensions are built in: bcmath bz2 calendar Core ctype date dba dom ereg exif fileinfo filter ftp gettext hash iconv libxml mbstring mhash openssl pcre Phar posix Reflection session shmop SimpleXML soap sockets SPL standard sysvmsg sysvsem sysvshm tokenizer wddx xml xmlreader xmlwriter zip zlib. PHP (recursive acronym for PHP: Hypertext Preprocessor) is a widely-used open source general-purpose scripting language that is especially suited for web development and can be embedded into HTML.

Conflicts

  • libapache2-mod-php4
  • libapache2-mod-php5filter

    Download

    Source package: php5

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libapache2-mod-php5 deb package:
      # sudo apt-get install libapache2-mod-php5

    Changelog

    2017-01-25 - Ondřej Surý <ondrej@debian.org> php5 (5.6.30+dfsg-0+deb8u1) jessie-security; urgency=medium * Allow relaxed ; priority=<num> parsing (Closes: #783246) * New upstream version 5.6.30+dfsg - [CVE-2016-10158] FPE when parsing a tag format. - [CVE-2016-10159] Crash while loading hostile phar archive - [CVE-2016-10160] Memory corruption when loading hostile phar - [CVE-2016-10161] Heap out of bounds read on unserialize in finish_nested_data() * Rebase patches on top of PHP 5.6.30

    2016-12-13 - Ondřej Surý <ondrej@debian.org> php5 (5.6.29+dfsg-0+deb8u1) jessie-security; urgency=high * Imported Upstream version 5.6.29+dfsg * Rebase patches on top of PHP 5.6.29 release * Change Build-Depend from libsystemd-daemon-dev to libsystemd-dev

    2016-11-15 - Ondřej Surý <ondrej@debian.org> php5 (5.6.28+dfsg-0+deb8u1) jessie-security; urgency=high * Imported Upstream version 5.6.28+dfsg * Rebase patches on top of 5.6.28+dfsg release

    2016-10-15 - Ondřej Surý <ondrej@debian.org> php5 (5.6.27+dfsg-0+deb8u1) jessie-security; urgency=high * Imported Upstream version 5.6.27+dfsg * Rebase patches on to of 5.6.27+dfsg

    2016-09-18 - Ondřej Surý <ondrej@debian.org> php5 (5.6.26+dfsg-0+deb8u1) jessie-security; urgency=high * Imported Upstream version 5.6.26+dfsg * Rebase patches on top of PHP 5.6.26+dfsg

    2016-07-26 - Ondřej Surý <ondrej@debian.org> php5 (5.6.24+dfsg-0+deb8u1) jessie-security; urgency=high * Imported Upstream version 5.6.24+dfsg * Rebase patches on top of 5.6.24+dfsg release

    2016-07-12 - Ondřej Surý <ondrej@debian.org> php5 (5.6.23+dfsg-0+deb8u1) jessie-security; urgency=medium * Silence errors from find caused by time race (Closes: #827370) * Replace cut&paste error php@PHP_VERSION@ in libapache2-mod-php5 postinst just to php5 (Closes: #822855) * Merge sessionclean script from master to fix reading conf.d directories (Closes: #827548) * Imported Upstream version 5.6.23+dfsg * Rebase patches on top of 5.6.23 * Move -ignore_session_path to be the first argument (Closes: #830792) * Update Vcs-* to point at pkg-php/php5.git

    2016-05-26 - Ondřej Surý <ondrej@debian.org> php5 (5.6.22+dfsg-0+deb8u1) jessie-security; urgency=medium [ Bernat Arlandis ] * Fix the bug where sessionclean doesn't touch session files (Closes: #799155) [ Ondřej Surý ] * Add patch to make opcache lockfile path configurable + Courtesy of Gandi and already merged in PHP 7.0 upstream * Imported Upstream version 5.6.22+dfsg * Add Provides: php5-mysql to php5-mysqlnd (Closes: #820451) * Rebase patches on top of PHP 5.6.22

    2016-04-27 - Ondřej Surý <ondrej@debian.org> php5 (5.6.20+dfsg-0+deb8u1) jessie-security; urgency=medium * Imported Upstream version 5.6.20+dfsg * Rebase patches on top of 5.6.20+dfsg release

    2016-03-07 - Ondřej Surý <ondrej@debian.org> php5 (5.6.19+dfsg-0+deb8u1) jessie-security; urgency=medium * Imported Upstream version 5.6.19+dfsg * Rebase patches on top of 5.6.19+dfsg release * Allow multiple whitespace in php5-fpm init script (Closes: #818102)

    Advertisement
    Advertisement